Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Newbie Questions

Just downloaded and installed the app. I’m a Vista user and have already learned the trick where the app goes to the tray per the minimize function (via the forum post). I have not yet taken the software for a drive, but plan to use it for recording stream items (PBS, network shows, etc.). My first intent is to watch a YouTube instructional video or two. Until then, two questions:

1) When streaming I experience periodic pauses for content load, likely due to low-speed capacity. In use does the CS recorder have ability to edit-out or somehow minimize those disruptions?
2) Is there an overall-best instructional video to watch?

I am likely to have more questions as I go, so much appreciate the short-term help.
Thank you,
TheKingfish
«1

Comments

  • Have a look at this video or any of the others which Terry has done:

    http://camstudio.org/forum/discussion/980/2012-camstudio-2.0-and-2.6-b-c-tech-webinar-win7-xvid-audio-video-settings-etc-

    Terry’s instructional videos seem to be the only ones which don’t supply some serious mis-information, so I’d recommend not bothering with the others.

    The hesitation you’re experiencing watching the PBS vids on your Vista machine is a problem which probably cannot be overcome. If it were a result of connection speed, that could be dealt with by getting a faster connection, but I suspect that your computer is simply too slow to process that kind of streaming video. Your computer is also probably overmatched by the latest version of Adobe Flash which PBS uses to stream its videos. You can try going back to version 10.3.183.25 which is somewhat kinder to older computers, but this will not work on sites which use a hybrid Adobe player, if you’re using Internet Explorer. It will work as a Firefox plugin. With CamStudio running, the problem will get much worse, because it requires even more resource to run both Adobe and Cam at the same time.

    Ken
  • Much thanks for your feedback; I will try the Terry instructional videos. I am a streaming novice, so have limited knowledge/experience. Speed may be a factor for me, as online tests show a paltry 0.7 mbps maximum (AT&T DSL). My research sees minimum recommendations in the 1.5-3.0 mbps range (???). For the record, Firefox is my browser; I have 2 GB RAM and a 1.86 GHz processor. I do have the latest Adobe Flash (11.5.502.146).

    Have read about the Firefox Video Downloader, but have no idea if it has applicability. Based on my current profile, is there any hope for me? I’m willing to upgrade but not sure where the true bang-for-the-buck resides.
    Thank you,
    TheKingfish
  • Sites like PBS, Hulu and most of the broadcast sites have purely streaming video, which means that no downloadable file is created when you view it, and your computer is constructing the video as information is streamed into it. In those cases, there’s no file left behind in your browser cache to recover and save.

    About all you can do is give Cam a try and see if you can produce something viewable. Use either x264 or Xvid MPEG-4 on a test recording of a minute or so and see how it looks. My guess is that your connection speed and processing resource just won’t be adequate to run both Adobe and Cam at the same time, but it’s worth a try.

    BTW I gave the PBS site a second look and as it turns out, it uses the same sort of hybrid player that Hulu does, meaning that one needs the latest Adobe player to view vids, unless Firefox is the browser used.

    Ken
  • Hmmmmm. Your feedback on PBS and broadcast sites (purely streaming video; download not possible) was extremely helpful, though not exactly a happy-ending in my case. As you suggested, following a couple instructional videos I will give Cam a try. It doesn’t sound too promising however.

    Based on our dialog, I took a side road into the Firefox option of Video DownloadHelper; a popular plug-in. That extension software seems well developed and documented. I’m still learning about its capabilities. It boasts a long list of compatible sites, including some PBS, but did not seem to include the one PBS show that I targeted (Washington Week). There is much info to mine there, but if you have anything to add to that experience please do.
    Thank you,
    TheKingfish
  • edited January 2013
    I use RealPlayer Free and include its streaming video downloader when installing it. It does not work with Washington Week in Review or other PBS titles - they are blocking the downloader with a script. So, capturing the video using Stereo Mix to capture the audio using CamStudio or something similar would be your only option.

    They will allow you to embed any of their videos into a web page, though, and that is even better for some things - though not editable, of course, if that was your goal.

    Terry
  • edited January 2013
    First let me offer the disclaimer that we’re speaking in a hypothetical sense here and not making any recommendations about making file copies.

    For those using downloaders such as “Download Helper”, keep in mind that you don’t absolutely need them in most cases where you want to save a downloadable file. Simply view the video and then find it in your browser cache, move it into a different folder and re-name both the file name and extension (to keep Windows from finding it and deleting it as a temp file).

    Most “streaming” video is already embedded as you’re viewing it, and unless one can successfully snoop out the source URL, there’s nothing to download. On occasion, sites will momentarily flash their source URLs, but Download Helper will loose them as soon as they become inactive. FVD (another Firefox add-on) will lock onto such a URL and list it as a video source, so it might be worthwhile to run it through and check it with that program to see if something made it onto the list.

    I have no experience with RealPlayer, but the site certainly makes no promises as to its ability to download otherwise non-downloadable files.

    Here’s an example of how a well-constructed streaming video behaves when it encounters a downloader. If you have no ad-blocker enabled, it’ll throw you an ad URL from the Youtube site, and then disappear, leaving no cache file at all. (The content is of no particular importance - you need to click on the Youtube icon to view on the site):



    Note that most Youtube vids are NOT streaming in the strict sense of the word, but some are, and they’re well “covered” compared to other streaming sites. There’s no legitimate way to get this file onto your computer. Notice that I’m not saying that it can’t be had, but not in any legitimate way.

    One note to my earlier comments about the Adobe player versions. Backdating to “lighter” versions seems to have no ill effect when using it as a Firefox plugin, but when using them with IE, sites such as Hulu, PBS, broadcast sites, and Ebay (which uses flash photo uploaders) will generally be crippled.

    Bottom line here is that I’d try Cam as a potential resource, but it sounds like the only real chance of getting it to work is backdate the Flash player and go through the usual exercise of shutting down all non-essential programs, such as anti-virus, aggressive firewalls and anything else that could be draining resource. The computer in question is quite similar to our older Vista machine, and all I can say is that it can’t really do the job of capturing motion videos. It probably just requires more resource.

    Ken


  • Well, I tuned into Terry’s instruction video and have come to an early standstill. In the Video Options section, my pull-down shows just four items and your recommended Xvid MPEG-4 is not one of them (???). Mine shows: MS Video 1, Intel IYUV codec (twice) and Cinepak Codec by Radius. Please advise.
    Thank you,
    TheKingfish
  • Thanks for the good feedback – I watched the excellent Terry video and moved on to (hypothetically) record PBS Washington Week with CamStudio. That was more than I was expecting, but I encountered two file-playback problems. The first was a total lack of audio (I have the proper CS settings and double checked my Win Media Player volume setting).

    The second is likely CS unfamiliarity. I used ‘Fixed Region’ and it recorded a large area, of which the TV play-screen comprised about 30 percent. I earlier used ‘Region’ figuring to manually size it, and it produced the “could not record using current compressor” error; a non-starter. Of course, in a perfect world the playback play-screen would be full and I could listen to it. Any remedial thoughts?
    Thank you,
    TheKingfish
  • The resolution on that particular show isn’t as good as some of the other vids on the site, but you can at least try clicking it over to full screen and trying that. That will really bog down the system, but you may not have any trouble with it. Without some sort of sizer you have no other options except to use the oddball player size. I much prefer the old fashion way of doing that which is using the “region” option and dragging the window to fit the area to be recorded. You must record with both dimensions being even numbers to avoid the “use default compressor” warning.

    As for sound, make sure “record audio frm microphone” is checked in the options dropdown, and that “stereo mix” or “what u hear” is enabled on your computer. On most computers you can check that by right clicking on your speaker icon and then selecting “recording devices” which will take you to a menu of which devices are enabled and selected.

    Ken
  • Also, in case you hadn't seen this yet, the Fixed Region dialog box includes a "Select" button that, when clicked, acts just like the "Region" choice in allowing you to drag your mouse to select a specific region to record. The trick is this: un-check the top-left item first, then click the 'Select' button and perform your selection, then re-check the top-left button. If your numbers for width and height are not both even numbers, make them so! Then you'll have no trouble.

    Terry
  • More thanks to you both for taking the time to help me. I have progress to report, but also some humps that remain.

    On the viewing front. The Terry ‘Fixed Region’ trick worked marvelously. As intended, the only thing captured was the actual video screen. File playback on the Win Media Player was of a same size (about 25% of full screen). Can that final playback size be enlarged via a Media Player adjustment or maybe an initial recording setting?

    On the audio front. Per your advice, I made sure the “record audio from microphone” was checked. I then proceeded to investigate the “stereo mix” or “what u hear” enablement. My speaker icon and subsequent recording device area does not include either of those items. I sought additional info (Google) and came upon a site that seemed relevant (http://stream-recorder.com/forum/enable-stereo-mix-wave-out-mix-u-t8109.html). In spite of that relevancy, on my Vista I could not summon up those “stereo mix” or “what u hear” recording devices (???); thus I could not enable them. Following the second-tier advice of that site, I downloaded and installed the enabling audio software Freecorder, a Firefox add-on. Still no audio on the recorded file.......

    I’m getting close it seems, but still no cigar. Any more good thoughts?
    Thank you,
    TheKingfish
  • This assumes that you’re using a desktop computer. Go back to “recording devices”. Right click on the white background area and check “show disabled devices”. Stereo mix should then show up. I’ve talked to some who have used the software bridges which go around the stereo mix problem and they report mixed results.

    Many of the programs on PBS go to a hi-res version when one switches the player to full screen, so in most cases, that’s the way to go. The show you recorded does not seem to do that, meaning that you’re doing nothing more than enlarging a lower res image to view or record, so that you’d probably just be taxing your resource by going full screen, but there’s always a decision to be made on which way to go. In cases where it’s preferable to capture at actual player size, you can switch your media player to full size (which basically accomplishes the same thing as enlarging the original low res image to full screen) or try to capture at the original file size and use a video editor to upscale the final product. Neither is a substitute for having a good quality hi-res source video, but often it’s the best you can do.

    Ken
  • If it turns out that your machine does not have drivers supporting Stereo Mix, you can use the attenuating patch cord method if you have an output and an input. See here:

    https://www.radioshack.com/product/index.jsp?productId=2103841

    and here:

    http://forum.audacityteam.org/viewtopic.php?f=27&t=6764

    and this:



    Note that the attenuating patch cords are mono - I've never seen a stereo version, but you might find one with diligent searching!

    Terry
  • Stereo Mix does not show up in my Vista under any circumstance. You mentioned that “software bridges which go around the stereo mix problem show mixed results.” That could be an understatement. My requisite research suggests the industry has essentially eradicated this feature (post XP) in the interest of copyright infringement. In fact I saw one guy who had Stereo Mix; updated his audio driver with a current version and totally lost his former capability. He was irked!

    Given the barrier in place here, Terry’s method (attenuating patch cord, if you have an output and an input) seems the only potential path to consider. Can you be more specific with what you are thinking here? Plugging into the speaker microphone-output and going where? Unlike a stereo receiver, I am thinking there is no physical audio input; a way to appropriately route the audio signal into the recording stream.
    Thank you,
    TheKingfish
  • Have a look at this post almost half way down the page for an explanation.

    http://camstudio.org/forum/discussion/288/realtek-hd-audio-does-not-work

    But most computers, laptops excluded, do have stereo mix. All three of ours (XP, Vista and Win 7) do. What type of computer do you have?

    Ken
  • More thanks for hanging in there with me on this. For the explanation, are you speaking of Terry’s post regarding the headphone out to the line or mic in? Or the post from Joyseeker who has Vista? Or the post from JBartley91 with the Vista video link? All three were about half way down.

    FYI My desktop computer is an Antec with a Sigma Tel High Def audio driver (still current from 2007). For all my investigative prodding, there is no hint that I have Stereo Mix. If that is essential here, then maybe I’m toast.
    Thanks,
    TheKingfish
  • This is the part I was referring to:

    “” If you have such a computer, you will have to get an attenuating patch cord from Radio Shack, going from the speaker or headphone out to the line or mic in. Be certain to have all your levels turned way down when you plug this in, and ease the levels up slowly and conservatively, testing until you find out what works.”“

    I’m sure that places besides Radio Shack would have these. If you try this, do be sure to turn the volume all the way down when starting. You can use a program like Audacity for bringing levels up for proper recording.

    Your audio version is a real stinker. There’s no one fix for it, although from what I’ve read, some have had success by doing one of the following: Backdate to an XP driver operating in XP compatibility mode OR buy a new audio card which allows stereo mix, OR do a registry tweak which MAY allow stereo mix to become a visible choice. The mix of success and failure using these seems to be somewhat random, so the cord idea might be the least expensive method to try.

    This seems to be yet another Dell inspired dilemma.

    Ken
  • Again, thanks for hanging in. Your advice regarding the audio card is good stuff, in that it efficiently lays out all the options. Knowing my present card is a bust and the other avenues are rather unwieldy is very helpful. You are The Man! As you say, the cord idea is probably the least expensive method to try going forward, and audio quality is not a premium for me as I’m just capturing an occasional TV video here.

    I was skeptical about the computer input, but further investigation showed that mine has a ‘line in’ jack available. I will now procure the attenuating patch cord from the local Radio Shack and report back with my results.
    Thanks,
    TheKingfish
  • The Radio Shack cord was purchased and connected between my speaker headphone output and computer microphone input. I recorded; then played the test file with the cord disconnected to allow the speakers to function. I wish the news were better, but the audio is still not coming through in the recorded file (???). I also have the Audacity software active but don’t have a feel for how it can be applied.

    Via ear buds I did verify the speaker headphone output is working. Via the sound card I also enabled the ‘microphone’ input (test #1, noted above). For a test #2 I did the same thing with the ‘line’ input; these were two separate tests. I’m confident the direct-connect patch cord method will work, but suspect my settings (CS + computer) are off in some manner. Any directional thoughts?
    Thanks,
    TheKingfish
  • First make sure that “do not record audio” is de-selected in Cam’s options dropdown. I don’t know if your Sigma Tel auto detects the presence of a line-in plug, but that needs to be enabled and selected as the recording source. I believe that you have to go to the ‘line in’ properties and click ‘listen to this device’ and playback through speakers, BUT since I don’t have a line in plug to test this on, I would hope that someone who has worked this through to a successful conclusion might chime in here with the correct configuration.

    Ken
  • TheKingfish,

    It seems you are really, really close now! Just make certain that you have line-in enabled in both the recording control panel AND in CamStudio's "Options/Audio Options/Audio options for microphone" dialog.

    Terry
  • I am glad to be really, really close! I say that in humor, but with full respect and thankfulness for all your help. Here is the latest, based on your good advice:
    1) Sigma Tel does auto-detect the presence of a line-in plug; that is enabled and selected as the recording source (General tab); this is the Control Panel function within Properties of Sigma Tel. Still within ST Properties, the Level tab is set to 37 on the scale of 100.
    2) Line-in is enabled in CamStudio's "Options/Audio Options/Audio options for microphone."

    The recorded-file result >> no audio. I then tried just switching into the CS “Options/Record Audio From Speakers.” Still no audio. Am I toast yet?
    Thanks,
    TheKingfish
  • Hmmm, let’s try going back through the settings.

    First, in Cam, select “record frm microphone”. Then options/audio options/Audio options for Microphone, check that “Audio Capture Device” is set to display your Sigma Tel and not the “default input device”. Then check “Use MCI Recording” down at the bottom.

    Here’s a bit of problem, because I’m using Win 7, but I right click on the speaker icon, then select “volume control options” and note that “all devices” is checked. Then click select “line in” and go to its properties tabs. Different O.S. will show different options here, but I believe that you want to select “Use This Device (enable)” and “playback through speakers”, but I can’t remember how the tabs are set up in Vista. Obviously, if there’s a mute for the line-in, it would need to be de-selected and the volume would need to be raised somewhat. Other than the volume controls, I can’t think of anything else.

    Ken
  • Yes, the logical thing is to go back through the settings:
    1) In Cam, “record from microphone” is selected
    2) In Cam, the “Audio Capture Device” is set to display the line-in Sigma Tel and not the “default input device”. “Use MCI Recording” is duly checked down at the bottom.
    3) The speaker icon, right-click >> recording devices >> line-in >> properties >> general >> use this device enabled
    4) The speaker icon, right-click >> recording devices >> line-in >> properties >> levels >> 37

    While the hard-wire connection (speaker headphone >> computer line-in) seems like it would be the unmistakable workaround here, there are always patients that just fade away inexplicably for lack of a proper cure. In spite of your tireless help, it would seem I am approaching that hopeless threshold.
    Thanks,
    TheKingfish

    PS – Within the speaker icon, right-click >> recording devices; one curiosity. There are four elements: line in, rear mic, front mic (monitor), front mic. The first two state “no jack information.” The last two state “front panel 3.5mm jack.” Regarding the latter statement; the computer does not have a jack on the front panel. There are three jacks on the rear panel (line-in, line-out, mic); I am plugged into the line-in presently and have alternately tried the mic jack with no success. With this situation, I wonder if I physically have zero (0) jacks devoted to recording.
  • I wonder myself if the wires are plugged into the motherboard at all coming from the line-in jacks!

    Terry
  • Terry: It does seem to be a strange combination of things happening. I’m wondering if the onboard audio is doing something funny because it’s detecting a “forbidden” source. I’ll try it out on our Vista computer tonight, but for now, I’d try this. Unplug both ends of the patch cord. Now plug into the line-in ONLY. Now right click on the speaker icon and see what’s showing on the recording menu. Normally, the line-in should be activated, and by default, should be enabled. Select and go to properties. On the “general” tab, make sure it shows as enabled. On the “Listen” tab, check “listen to this device” and select the speaker option right below. On the “levels” tab, make sure there is no red mute “x” next to the speaker icon. Click OK, and leaving the playback devices/sound menu open, insert the plug into the speaker/earphone socket and observe what happens to the list of devices shown. As I said, I’ll check our Vista later and see how that corresponds to what I see on my Win 7. I would advise against using any mic-in sockets, because there is some slight risk in doing that.

    Just remember, if all else fails, you can buy a Creative Labs audio card for $30 (or less) which has “what u hear” capabilities.

    Ken
  • Okay, following your exact direction, I have progressed and am in the line-in properties menu. The general tab shows line-in enabled. Your next directive (on the “Listen” tab, check “listen to this device” and select the speaker option right below) cannot be done, as I do not have a Listen tab.

    Progressing, the Levels tab is not muted (but this is for line-in, not the speaker option). Moving forward with the experiment, nothing happens. But then, the missing element above () would likely be the reason.

    Another thought in response to your audio card buy suggestion (not so inclined). For full convenience, I have been trying to make my desktop do the deed here. Now that walls have rapidly risen on that approach, there is another in-house approach. I have a netbook with Win 7 -- I’ll take a peek. If it is equipped with the Holy Grail “Stereo Mix” I should be able to do a conventional Cam record. I hadn’t considered this since post-XP devices seemed less likely to possess the accommodating audio card.
    Thanks,
    TheKingfish
  • Okay, I did some experimenting on our Vista machine. First, the tabs on the Line In are: General-Levels-Enhancements-Advanced. There is no “Listen” tab on yours. Now, this is probably bad news. I ran the test I suggested above, just plugging the patch cord into the Line-In socket only, and it immediately detected and presented all of the settings tabs in the properties interface. When I plugged the other end into the speaker out, everything was working as expected; in fact, the “set default” at the bottom of the panel didn’t even have to be selected. The sound, as has been reported by others, was rather low, but I’m not sure how much of a problem that might be. Also, right clicking on the speaker again, and then selecting the mixer (at the top) the audio source was identified on the right side. Assuming your Line In icon has “working” showing under it, I might begin to assume the worst in terms of its actual functionally, as Terry suggested in his last post. Is this a system impedance issue with the Sigma Tel chip/software? Could they actually have gone through the trouble of disabling the line in when it senses the computer’s output? The test would be to send the output frm another device into the computer’s Line In to see if that is detected. (A longer cord would be in order). If that worked, an external mixer patched into the loop MIGHT solve the problem.

    The netbook solution doesn’t sound promising, but it’s worth a try. If it were mine, I’d buy the $30 internal sound card and go with that. The audio will likely be better, and the “what u hear” would be available. This assumes you have an available PCI or PCI-e slot.

    Ken
  • A new development. I’ve got a conventional cable new-install bundle under consideration, so not sure I’d presently want to invest in the new desktop computer sound card (although I am confident it would do the job). It’s a deal where U-Verse (w/free DVR) just came available to me following many years of a nasty relationship with Comcast. I know that’s shocking to most forum readers -- a cable company in disfavor.

    Not sure why you thought the netbook solution unpromising – maybe the prospects of same. The quick netbook check showed Realtek to be the card and Stereo Mix to be available. So, now I think maybe I need to do the Cam download and all other supporting functions (settings, added software, etc.) on that machine. Then take it for a drive to check capability. As always, your thoughts are appreciated.
    Thanks,
    TheKingfish
Sign In or Register to comment.