Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
CamStudio 2.7 Bug Reports and Installer Issues
  • Please post 2.7 bug reports and installer issues here!

    Terry
  • The installer is currently providing no way to opt-out of piggybacked software. The linked image [1] shows a page of the installation wizard asking for permission to install FantasiGames. Fantasti Games does unwanted things to the end-user's computer such as overriding the web browser's default search provider. I have not clicked the 'Next' button, as I do not trust that the software will remove cleanly.

    The EULA for FantasiGames grants itself permission to install other 3rd party advertising software, collect user data including personally identifying information (Privacy notice, section 2, bullet 3), and change terms at any time.

    Internet Explorer's smartscreen filter is currently advising users not to run CamStudio's installer because of malicious software. [2]

    [1]: http://i.imgur.com/hPLbU8T.png
    [2]: http://i.imgur.com/wtsMDvE.png
  • What you missed is that the custom installation allows the un-checking of both check boxes, which effectively installs CamStudio alone. We sure got a bunch of doozies with this advertiser - FantasiGames, Delta Search - ugh!!! This could not be worse.

    (Check your inbox here also.)

    That is VERY bad news that the smart-screen filter is nixing this software. So is some other anti-virus, identifying it as Adware and refusing to install it. (post below)

    Terry
  • Selecting "custom installation" and unchecking both boxes looks to me like it would still install FantasiGames.
  • That is not how it reads to me at all. Checking asks to set and keep, un-checking consequently asks it not to.

    Terry
  • Unchecking those boxes does not result in any prompt to opt-out of the installation on my computer.
  • avira anti-virus scans the installer after downloading and states it has adware/installcore.gen
    sorry but things like that i delete straight away, the only other option is to dl the rar file that is provided in the other thread which works file.

    sorry Terry if the adware is intentional but i don't think your doing yourself ant favours with it
  • Kitir,

    Un-checking the boxes is the opt-out itself. It then goes on to install only CamStudio. There is no further prompt - the check boxes are all there is, so un-check them and you should be fine.

    geodav,

    As per Nick's post on the future of CamStudio,

    http://camstudio.org/forum/discussion/1181/camstudio-2.7-is-coming-and-a-word-about-its-future

    we added an advertising supported installer in order to raise funds to pay for programmers to fix the remaining bugs and then add features (like AVI-2 spec compliance to overcome the 2-gigabyte file size limitation). Donations have been very thin, so this was a way to speed up the development to make the program better for everyone.

    See here if you absolutely do not want to use that installer:

    http://camstudio.org/forum/discussion/comment/5041#Comment_5041

    Terry
  • Denied by SmartScreen Filter...picture says it all...
    http://imagebin.org/246436

    Also Producer Help may be missing, as it wasn't in the Zip alternative.

    Sorry to see the damage to your rep.
  • I downloaded the software last night and it worked perfectly. Clicked on it this morning and it started redownloading again, then half way through the download said theres a problem deleting a file, searched for said file but its non existant, what should I do?
  • I'm not clear what you are meaning - do you mean it installed on one machine fine, but when you tried to install it on a different machine using a copy of the installer it stalled?

    You should not be needing to install it twice on the same machine, of course. There is a program icon in the CamStudio 2.7 folder that should have been added automatically to your programs list from the Start button/All programs area.

    Terry
  • Only 2 piggyback software packages have been offered to me. The dealply offering does allow an opt-out, but the FantasiGames offering does not. Unchecking one box implies that the user's home page will be left alone, and unchecking the other implies that the default search provider will be left alone. Regardless of those checkboxes' status, there is a statement reading, "By clicking "Next" you agree to the License Agreement".
  • I stand corrected, then! Thank you, Kitir, for bringing this to our attention. I'll notify Nick of this at once, as he is the one dealing with the advert-supplier.

    Terry
  • @Kitir every application offered should have an opt-out function, can you email me privately at support @ camstudio . org and I will try to get this sorted out. Also let me know your country and I will try to duplicate your results.

    Thanks

    Nick :)

  • @MrGadget, yeah I've confirmed that.

    Thanks for bringing it to our attention, I'm on it.

    Cheers

    Nick :)
  • When I download the 2.7 download from the site and select "Run" nothing happens after that. I have unblocked it and even ran it as Administrator. When I click on the download and select RUN nothing happens after that. I am on Windows 7 and am using the XPS Dell Laptop. Can anyone assist me?
  • H2K,

    Did you delete your original download and try to download it again? Sounds like the download was corrupted somehow. Check your inbox here.

    Terry
  • hi all, i have a problem with the installation... i downloaded the installer, it start as normal and i uncheck the delta toolbar. after i press next and it appear the page with the grey progress bar moving... it stuck there forever doing nothing... it is a know error? thanks for the help... i'm running win7 x86 and i execute as admin as well...
  • tondo,

    It sounds like you received an older version of the installer, possibly because the old link that was on the CamStudio.org page was still in your cache. Empty the cache and try again, or get the file from my website for the time being:

    http://screencasttutorial.org/Release_r316.zip

    We have dropped the advert-supported installer for now, and are looking for better methods to do something similar that works smoothly and does not trigger adware alerts on some browsers and antivirus programs. (nor get stuck like you have!)

    Terry
  • Windows Vista. Downloaded latest version today: CamStudio_2.7_r316_setup.exe and CamStudioCodec_1.5_Setup.exe.

    During program install all seems fine until the last step of the install when I elect to launch the program which generates error:

    "Recorder.exe - Unable to Locate Component: This application has failed to start because mfc100.dll was not found. Re-installing the application may fix this problem."

    I un-installed the program and then again downloaded the file but same result.
  • You likely need this
    https://www.microsoft.com/en-us/download/details.aspx?id=5555
    Older computers had the 2008 version of this file installed. You need the 2010 version for 2.7 as it was compiled using Visual Studio 2010.

    Terry
  • Wanted to install CamStudio2.7r316.exe on Win7, unchecked the 3rd party apps, but the installer froze. So I tested including the 3rd party apps, installer went through the process completely. Unfortunately though, one of the 3rd party apps, going by name BrowserProtect.exe, is detected as Virus/Malware by Trend Micro (TROJ_SPNR.0BBC13). I would urge you to stop using that 3rd party crap in your install routines. It seems you really don't know what you could cause to other people with that.
  • You have our oldest download of the program there. We have removed the advertising stuff entirely. It was definitely a mistake to go with the company who approached us, as you'll see several posts here of folks having problems like this.

    We still want to earn some advertiser-supported installer revenues so we can pay programmers to make CamStudio better, as donations have fallen off sharply. If you know of any reputable companies who offer such an installer we'd sure be happy to hear about them!

    Here is the most reliable place to get CamStudio from:

    http://sourceforge.net/projects/camstudio/

    Here is the current download link:

    http://sourceforge.net/projects/camstudio/files/latest/download

    Terry
  • When running this new version in a VMware Windows XP environment I lose the ability to double-click open files/folders after I have pressed the record button. Closing CamStudio returns the ability for me to double-click open files again. Just opening CamStudio won't cause this problem, its not until I hit record. This was not an issue I had previously with 2.6b.
  • Glad you guys removed the troublesome adware! I just got the app yesterday and it seems to be working fine so far. HOWEVER, I am new to this sort of thing, and I noticed that the Help link on the app's Help menu window doesn't work--I get 4 things, in this order:
    (1) this error message: "This webpage is not found / No webpage was found for the web address: file:///C:/Program / Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found."
    Followed by (2) a couple of "Oops" messages from Chrome, and (3) an apparent effort to load something unloadable--tries to open something and can't get there, resulting in (4) "No data received / Unable to load the webpage because the server sent no data.
    Here are some suggestions: • Reload this webpage later.
    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data."

    What is going on? Should the help file have downloaded and if it didn't, how can I get it?
    Do you have any kind of user guide? Or just the FAQs?

    Thanks!
  • Here is a video explaining how to move the files from a 2.0 download into 2.6 or 2.7.



    Terry
  • can anyone help me. my minecraft controls mess up when i have it and camstudio up
  • On Feb 18, TerryBritton wrote:

    You likely need this
    https://www.microsoft.com/en-us/download/details.aspx?id=5555
    Older computers had the 2008 version of this file installed. You need the 2010 version for 2.7 as it was compiled using Visual Studio 2010.

    Hi Terry
    Downloaded the file but it didn't solve the mfc100.dll error. Still giving the same error prompt. However, managed to fix the error using some 3rd Party app DLLFixer or something like that (can't really recall). Works fine now.
  • haizal,

    That's interesting! Perhaps your file was replaced by an older version, or de-registered somehow.

    Anyway, glad to hear you've got it up and working!

    Terry
  • Terry, I see this folder in my program files under CamStudio 2.7, called help.chm: (mk:@MSITStore:C:\Program%20Files%20(x86)\CamStudio%202.7\help.chm::/) - but it still doesn't show up on the Help menu. I watched the video on moving help files from 2.0 to 2.7, but since I don't have 2.0 and those are in folders, it didn't help in my situation. Got other ideas for connecting it to Help?
  • The CHM files, to my knowledge, have not been implemented at all yet. The HTML help files from 2.0 would work from the help menu if they were present. You can still get 2.0 from our Sourceforge project site in the folder marked "Legacy."

    http://sourceforge.net/projects/camstudio/files/legacy/Camstudio2-0.exe/download

    Just install that along with 2.7 and copy the folders over. The two programs can actually be used at the same time, IF you open 2.7 first, followed by opening 2.0. BUT 2.0 uses the older C++ runtime libraries from 2008, so you'd need those as well.

    Terry
  • Hi, I have a problem installing the software. I have tried 3 times but keep getting an error which says 'The program can't stat because mfc100.dll is missing from your computer'.
    I have reinstalled it twice, but I get the same message.
  • Keith,

    See this post above: http://camstudio.org/forum/discussion/comment/5218#Comment_5218

    You need this version (the x86 version) even if you have a 64-bit machine.

    Terry
  • Thanks Terry,
    I've sorted that.
    When I record full screen, I now get a crazy flashing screen, that goes different colours!

    Keith
  • In Options/Program Options, check "Hide Flashing Window During Recording". That runs in a separate process - be certain if your CamStudio minimized during recording to stop it from the TRAY and do NOT attempt to end it from the task bar by closing it - you'll get crazy stuff then.

    Terry
  • An "advanced" computer user here. Found CamStudio and wanted to give it a try. Downloaded and installed (from Sourceforge) CamStudio_2.7_r316_setup.exe on Windows 7 SP1 32-bit (with all Windows Updates & hardware drivers updated to this date).

    No mfc100.dll issues (I manually extracted it from the free Microsoft Visual C++ 2010 Service Pack 1 (09-08-2011) redist from the MS Download Center and put it in the CamStudio directory). It started and ran and recorded fine.

    But...as brought up by others in a couple other threads, the modern CamStudio simply can't find any modern codecs installed on my system on its GUI dropdown list. It can find the ancient Cinepak, a couple of Intel Indeos, MS Video 1 and that's about it.

    The modern codecs properly installed here but not found by CamStudio 2.7 (but can be found & used properly by MPC-HC, VirtualDub, SMPlayer and so on): x264vfw (my favorite), Xvid, ffdshow's encoder & a circa 2003 Windows Media Video 9.

    So, went into the command line app and ran it to see what it detected. Sure enough, it did in fact detect all of those modern codecs in addition to the old ones that could be seen in the GUI dropdown. Setting the command line app's options to choose one of the modern codecs at a time (started with x264vfw), it started to run, then the text stopped (its been 2 weeks since I uninstalled 2.7, forget the exact details). Never produced usable output. Running with one of the old codecs though (i.e. MS Video 1), the command box filled with text for as long as it recorded and it produced usable output.

    Of course, running the command line app gives video without sound, so not really usable, even if it did work properly with the modern codecs.

    So after a few hours of trying to get the modern codecs to work with either the GUI or command line app (uninstall/reregister, only install one at a time, etc. etc.), I uninstalled 2.7 and tried CamStudio_Setup_v2.6b_r294_(build_24Oct2010).exe, as suggested by another thread. Unfortunately, identical problems as 2.7.

    So for the last try, installed the circa 2004 CamStudio 2.0 (Camstudio2-0-w32.zip from Sourceforge). Guess what? It properly detects and can use all the modern codecs (properly) installed on the system here. In addition to the obsolete ones that v2.6-2.7 could only use.

    Here is hoping that future modern CamStudio versions can finally detect & use codecs properly. Any suggestions as to anything I may have overlooked (not detailed above), it would be appreciated. Not really needed here though; version 2.0 detects and uses everything properly without issues.


  • Hmmm, actually, 2.7 eliminated the "missing codec" problem. It cannot see 64-bit codecs, of course, but they wouldn't work on your 32-bit system for any program, so I doubt you've installed any of those.

    I use Xvid every day. Nick uses ffdshow. I cannot imagine why it is treating you like this!

    Please re-install 2.7 and take a look (2.0 and 2.7 can be installed separately, and even run at the same time if you start up 2.7 first...)

    In other words - you experienced an anomaly that is unique to your setup at that time. I'm hoping a re-install fixes it. Also, do install the entire 2010 runtime libraries - it may be needing more than only mfc100 from there.

    Terry
  • Thanks for the reply.

    No, as expected, a reinstall of CamStudio_2.7_r316_setup.exe has not fixed anything. The "missing codec" problem is not eliminated with that version, it has the problem...heh. Can more exactly let you know the only (obsolete) codecs the Options, Video Options, Compressor drop-down list shows, however. Microsoft Video 1, two instances of Intel IYUV Codec & Cinepak Codec by Radius. That's it.

    Of course no 64-bit codecs are installed or running here. If there were, there would be problems running them in other applications here on the 32-bit OS, which there are not.

    As to the C++ runtimes, running recorder.exe through Dependency Walker (http://www.dependencywalker.com/), it only uses three VS2010 files: MFC100.DLL, MSVCR100.DLL & MSVCP100.DLL. The last two I already had in \windows\system32 for other programs here that needed them, thus why I extracted the first one to the CamStudio 2.7 directory. Doing so, no issues running the program, other than the missing codecs.

    But after the continuing failure of 2.7 to find the properly installed codecs, I did as you suggested and installed the entire (32-bit) VS2010 thing (from http://www.microsoft.com/en-us/download/details.aspx?id=26999) instead of just the files it uses (ugh). No difference, as expected.

    2.0 still continues to properly show & use all installed codecs (as noted in my first post), 2.7 doesn't. Oh well.
  • Well, I don't know how many times I need to repeat this - 2.7 repaired the missing codec problem... So, my next suspicion is that you have a shortcut still opening up 2.6b - check the "About" box to be sure. Nobody else but you has reported this problem, so I'm a little stuck without a precedent to compare details.

    Terry
  • No, 2.6 isn't installed.

    Perhaps testers and/or users here are are only using 64-bit OSes? That's my suspicion.

    Output from 2.7's CamCommandLine.exe:

    Valid codecs on this machine:
    0: Microsoft Video 1
    1: Intel IYUV codec
    2: Intel IYUV codec
    3: Cinepak Codec by Radius
    4: ffdshow Video Codec
    5: Intel Indeo(R) Video R3.2
    6: Intel Indeo(R) Video R3.2
    7: Intel Indeo« Video 4.5
    8: Indeo« video 5.10
    9: Microsoft Windows Media Video 9
    10: Xvid MPEG-4 Codec
    11: x264vfw - H.264/MPEG-4 AVC codec

    Only 0,1,2 & 3 show up in the GUI dropdown box, as noted. And also as noted in the first post, only those + the Indeos produce a usable AVI (without sound) when started with the proper command line options (i.e. CamCommandLine.exe -codec 0 -outfile test.avi -seconds 5).

    Instead try to run that with Xvid (10) above, it starts, but unlike the older codecs, it doesn't scroll "nextFrameAt: 21758960, timeGetTime: 21758951, toNextFrame: 9 Sleeping for 9 msec (21758951 - 21758961)" and so on. Instead, get this:

    Using codec: Xvid MPEG-4 Codec
    Detected displays:
    Screen: \\.\DISPLAY1 resolution:1151 x 863
    Creating recording thread for screen no.:0...
    Recording to: test.avi_.avi
    Recording for 5 seconds
    Waiting for recording thread to exit...

    When the prompt returns, the AVI produced is 0 bytes and is unplayable.

    BTW, in order for "-seconds 0" to work, you have to type it in like "-seconds0". With the space, "Expected valid number of seconds to record: 0" pops up and nothing is recorded. Not entirely clear.

    Final testing: sure enough, x264vfw (11) does now produce usable output from the command line option. "camcommandline.exe -codec 11 -outfile test.avi -seconds 5" produces a 252kb H264 file that's playable.

    So there is that. But not usable compared with 2.0's working GUI that provides full sound. GL.
  • No, users are from all over the map - XP, Vista, Win7, Win8, 32 and 64-bit.

    Curious display resolution - those odd-numbers will not work with Xvid or x.264 or Divx, as the first two require multiples of 2 for width and height, and Divx needs a multiple of 2 for height and a multiple of 4 for width. So, full-screen capture would never work here. The command-line interface probably does not throw up error messages about that either. Of course, that read-out could be wrong, too. What are the dimensions of the playable x264vfw video that you managed to get?

    I still say, pull out CamStudio and the runtime libraries, reinstall from scratch.

    I use this version of Xvid by Jawor - http://www.digital-digest.com/software/download.php?sid=1052&ssid=0&did=14

    VirtualDub's Video/Compression tools may come in handy here. http://sourceforge.net/projects/virtualdub/?source=dlp

    There definitely seems to be something wrong with this installation. Yours is an isolated incident, I'm sorry to say. 2.7 is showing codecs.

    See if 2.6c is working - it has the same fix for the codecs:

    http://sourceforge.net/projects/camstudio/files/next/

    It also uses the 2010 32-bit runtime libraries.

    Terry



  • "Curious display resolution - those odd-numbers will not work with Xvid or x.264 or Divx, as the first two require multiples of 2 for width and height, and Divx needs a multiple of 2 for height and a multiple of 4 for width. So, full-screen capture would never work here. The command-line interface probably does not throw up error messages about that either. Of course, that read-out could be wrong, too. What are the dimensions of the playable x264vfw video that you managed to get?"

    The first two codecs work & record without issues in CamStudio 2.0 (and VirtualDub). I use a (high quality) 4:3 CRT monitor, explaining the odd dimensions (which I prefer).

    Output dimensions of 2.7's "camcommandline.exe -codec 11 -outfile test.avi -seconds 5" AVI (x264vfw): 862x864 (0.998). It shrunk the horizontal dimensions by 25% in the playable AVI. No error output.

    However, running CamStudio 2.0's GUI x264vfw dropdown option, it provides AVIs with the full desktop dimensions of 1152x864 (4:3).

    Using (the standard version) Xvid with CamStudio 2.0 (not possible in 2.6b & 2.7), the AVIs it produces also have a proper full desktop res of 1152x864 (4:3).

    "I still say, pull out CamStudio and the runtime libraries, reinstall from scratch."

    Continually reinstalling programs to try to resolve issues is a beginner's solution which is inapplicable here. I've already reinstalled (and tested) 2.7 and provided the results in the post above. I also fully installed the VS 2010 C++ redist pack (inapplicable as all the files 2.7 uses were already installed properly) and confirmed that all the files were properly deposited in the correct locations; results in the post above. No change.

    As mentioned in prior posts, I already have & run VirtualDub with no encoding issues.

    As to CamStudio 2.6c (while 2.6b & 2.7 have the same issues here), I'd rather spend time doing more useful things than seeing yet again if the problem is on my end. Might (or might not) try it later.

    Thanks for your help.
  • Sure, sorry I couldn't solve your unique situation. If you get to the bottom of it, please do let me know in case I encounter this in the future.

    Terry
  • I have since installed 2.6c. As in uninstalled 2.7, downloaded Camstudio-2.6c.7z, unzipped the files (with 7-Zip) into proper folders. Started up Recorder.exe...exactly the same problem as 2.6b & 2.7's video option dropdown. Only four codec choices (MS Video 1, 2 x Intel IYUV Codec & Cinepak Codec), not anything else. While CamStudio 2.0 continues to provide all the proper choices in its video option dropdown.

    In the interest of finding to see what bug outs that dropdown in 2.6+ here, I also changed the desktop resolution here temporarily from 1152x864 (true 4:3) to 1280x720 (16:9, 720p). No change in 2.6c.

    Perhaps 2.6c/2.7 hasn't totally fixed the dropdown issue in all cases. Or (less likely), using the latest builds of VS2010 C++ files here as noted above (file versions 10.0.40219.1) is causing issues where older builds you compiled against do not. Wouldn't bet on it, though, they should be backwards compatible (and no other program here that uses them has issues). Also, if 2.0 also exhibited similar behavior, I'd definitely say its an issue on my end. But it doesn't.

    Also unusual in the code changes you've made in 2.6+ is that is that 2.0 has no issues with original Xvid or x264vfw providing full 4:3 1152x864 output. But 2.7's camcommandline.exe fails to provide output with Xvid and it shears 25% off the horizontal dimensions of x264vfw video.

    Oh well, thanks again; look forward to future versions that may resolve the problems.
  • Yloh,

    There is a new version coming out pretty soon, so keep an eye out for that. I hope what may be causing this on your system reveals itself to the programmer as he works on other issues also being fixed. 2.6b had all the issues you are having, and 2.6c and 2.7 had fixed the missing codecs issue for pretty much everybody, so I can only speculate (not being the programmer) what could be making it fail for specific configurations. Maybe we'll get lucky and something done to the upcoming version fixes that for you. I certainly hope so.

    Meanwhile, the basic functionality of 2.7 is inherent in 2.0 - only a few features are lacking that were added (capture windows, full screen and some other convenient things that were added). I hope in the meantime you can get your work accomplished using 2.0. If you have any questions as to best setups for certain types of projects, I'll be happy to help out there.

    Terry
  • Hello

    I appear to have this same problem of mfc100.dll not found despite following your link above to download the 32-bit "MS Visual C++ 2010 Redistributable Package" where your link points, and installing the software. The error persists after a reinstallation of CamStudio, a reboot, and so on. I use Windows 7 SP1, 64-bit on a dual-core laptop.

    Paul
  • This is 2.7 we are discussing here? (2.6 needed the 2008 version of the MS C++ runtime.)

    I have both versions working on a Win 7 64-bit machine here.

    Terry
  • I downloaded whatever your link said two days ago on your download page at "camstudio.org". Yes, I believe it was 2.7.
  • Try this one in case my version is different somehow from what is up at Sourceforge presently:

    http://screencasttutorial.org/Release_r316.zip

    Terry
  • Also, we could try installing both the 32 and 64-bit versions since you have a 64-bit machine. I happen to have had both installed anyway, so I never saw an install of 2.7 without those both being present.

    http://www.microsoft.com/en-us/download/details.aspx?id=26999

    Terry

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion