Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
minecraft and camstudio problem
  • ok so i downloaded the program and everything was great but i had it open and when i started to play minecraft it was like i had sticky keys i would click in one direction it would go in that direction and then keep going and going until i either smashed my w,s,a,d keys or press escape. i would really like to have this solved because i love the look of the recordings can anyone help? its making me mad. i took a vid of the problem in action but i cant upload it just someone help!
  • Could the keyboard shortcuts you have set up in CamStudio be conflicting with the ones you use in Minecraft? (see Options/Program Options/Keyboard Shortcuts - I think it is the last entry.)

    Terry
  • no i tried that i put them all to none
  • I'm out of ideas, then. Which codec are you using?

    Terry
  • i dont know not the lostless one
  • It is shown under Options/Video Options at the top.

    Please watch this video.

    http://youtu.be/WQ5_6szOf48



    Terry
  • I'm having the same issues with Team Fortress 2. Even if I'm not recording with CamStudio and just have it open, I get the same sort of sticky/laggy key issues. I don't think it's so much the key bindings but rather how resource intensive both games are, I might try lowering some settings and seeing if it helps, but having a total of 10 Gigs of memory (2 of which is an Nvidia GeForce card) makes me think that that might not be the problem either.
  • RAM is not CPU power, though it is certainly helping. The bus could be clogging, or only one of your multiple cores (if you have a multi-core cpu) may be getting used.

    Also, the audio busses often will show clogging if there is any problem - does the sound get choppy sometimes?

    It may help to lower the color depth to 16-bit, if the game will run without needing 32-bit color. (In the Resolution section, under "Advanced Settings" in the Monitor tab on Win7 and perhaps Vista. Change from the Advanced tab directly on XP.)
  • Good point, but my audio seems to be fine (during recording, right?). I have an intel i5 2.5 GHz processor with turbo boost up to 3.1GHz. I can grab video fine from other Non-3d games fine with out any sort of button problems (however I do have audio problems, see my post here: http://camstudio.org/forum/discussion/1232/windows-8#Item_7). Ill try removing all the key bindings, and lowering my games settings a bit and seeing what helps.

    On a side note, I cant change any of the video options for whatever reason, all I can change is the codec being used. I'm using the Intel IYUC codec on my computer, should I use the CamStudio's Lossless Codec? Where can I download that too, because its not in the list of codecs I have?
  • Okay, I figured out the whole video settings thing and I downloaded the codec you recommended on your tutorial and started using it with all the settings you suggested for gaming recordings like you said. That's when I found out that I was getting the Key lag issue even if I wasn't recording. As long as CamStudio was open, I would be getting the weird key problems regardless of if I was recording or not and as soon as I closed CamStudio, the problem vanished. I had also removed all the key bindings too to make sure it wasn't those either, which it wasn't.
  • Well, that's mostly good news! But this keybinding problem is an oddball. Just opening CamStudio starts it going, so it has to be a conflict with the key polling being performed by CamStudio conflicting with the key polling process of the game.

    I'll see if the key-polling can be disengaged somehow by bringing this up with Nick, who will discuss it with our programmers. That may require a programming change as a feature addition (sounds likely...) but if there is another way, perhaps I'll find out.

    Terry
  • Thanks a bunch! It seems to run alongside Minecraft fine on my machine (not to mention that its heavily modded too, the Feed the Beast modpack), So who knows... :/
  • Nick says he is asking the programmer about it this week, so we'll see where that leads us. Probably toward a feature being added to turn off the polling.

    Terry
  • Kay, turns out I am getting some of the key lag in minecraft too making things difficult, this started upon recording but persisted afterwards. anywho, thought that might be some more useful information.
  • Thanks!

    Terry
  • Just to add something to this - I'm also getting the same input issues in Minecraft with Camstudio 2.7 and Camstudio doesn't respond to its own hotkeys. I've also got 2.6b r294 installed and that version works perfectly with Minecraft.
  • Well, Nick is talking with the programmer who worked on 2.7 now, so maybe he will locate what is different between the two versions soon. (I hope!)

    Terry
  • Correction to my previous post - I had 2.7 set to Shift+Home but 2.6b set to Home, that was why I thought 2.7 wasn't responding to its own hotkeys.
    In addition, I get input problems in Windows after using Camstudio to record. Closing Camstudio fixes the problem immediately.

    I'm using Windows 7 x64.
  • DazJW,

    You may have your settings running high (many game recordists do this trying to get smoother videos) - if your "Capture Frames Every" is a lower number than 25, you are likely pushing the processor so hard with CamStudio that the game and even key polling has a hard time fitting their own requests for CPU time in.

    Terry
  • Cool, I'll take a look at the settings and try to lower the Capture frames every X to something higher.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion