Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
Problem with Xvid codec (using version 2.7)
  • Hi all, I'm new here and am a total noob at using camtudio or video recording in general so please bear with me.

    I have a problem recording a video using the xvid codec which I downloaded from Doom 9's forum (Gordian Knot Codec Pack 1.9). It installed a lot of different programs (div x, xvid, ffd). I tried recording using the xvid codec since it seems to be quite highly recommended on here.

    Anyway, it recorded fine and the audio was great but the only problem I seem to be getting is that the video is jerky. The image quality is rather good but the frame seems to freeze for like a second or so before skipping to another frame and so on.. My settings were:

    Set Key Frames every 100 frames
    Capture Frames every 1 millisecond
    Playback rate 1000frames/sec

    Under Xvid configuration:
    Profile @ level AS@L5
    Encoding type: Single pass
    Target bitrate: 8000kbps

    I also set my video to a fixed region of 752x580. In addition, I wanted to point out that when I press the record button, a popup window named "Xvid status" appears but it is totally grey/blank. However, Cam Studio still continues to record and I can playback the video, except that it is jerky/choppy. I use VLC media player to play.

    My goal is really to record high quality videos which run smoothly (hopefully better than Microsoft Video 1) but which takes up less space than Microsoft Video 1 (the files were too huge and would exceed the 2GB limit in just 10 mins or so)..

    Could it be that I should not have downloaded the Gordian Knot Codec pack? Btw, there was also a Gordian Knot Rip Pack but I did not install it. Should I have installed it? I have heard good things about "Jawors xvid" but apparently the link is no longer working.

    I would really appreciate your help on this matter.

    Thanks!!

  • Try setting the quality preset at the bottom to Realtime and un-check the Use B-VOPs item from the "more" button next to the profile.

    Terry

    Here is the Xvid portion of the 2.7 tutorial video for reference.

  • Given the profile options, I don’t think I’d be using L5, although it works well enough. If 720 HD isn’t available, a newer MPEG-4 codec is in order. Fact is, I think I might be trying to track down Jawor’s and set the profile to unrestricted with both B-VOP and packed bitstream DEselected. The 8000 bitrate is more than enough.

    The problem here is that later versions of Cam allow for recording in a range which can’t be easily dealt with, either by players or editors/converters. If a video editor can even open a file with an FPS of 1000, it’s really asking it to do a lot of work to convert it to something useful. Most free editors have a ceiling of 200 FPS and players will struggle with frame rates over 40, although H264 seems to be a bit more tolerant of that than MPEG-4 is.

    I’d first try a test with settings of 40/25 to see how that works. If the jerky behavior is largely gone, you can consider other combination options.

    Ken

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion