Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
RealTek HD Audio does not work
  • I have been using CamStudio for some time now. However, after I got a new Hard Drive I decided to download CamStudio again (as It worked very well last time). Now however, I have discoverd that my CamStudio will not record sound from my RealTek HD Audio Output and Input. I have tried both of these and they don't work as it cannot fnd a line. When I click on "Record Audio from Speakers" I get an error message saying "WaveoutGetSelectControl()failed". This also happens when I ask CamStudio to automatically detect my Audio Line. When I ask to do it manually I am given the following message: "Unable to detect recording line for speakers. Please make sure your soundcard is seleced correctly in the 'Soundcard Device' of 'Audio options for speakers'. The sound used to work when I used my other computer, this computer is the same as the previous one (same soundcard, video card ect.) just a different Hard Drive. I do not know why it is not working this time around, I would welcome any help. :)
  • Try the solution posted in this thread: http://camstudio.org/forum/comments.php?DiscussionID=33&page=1#Item_6
  • I have the same problem. However, I use XP so the provided solution does not work.
  • I also use XP (sp3). So the provided solution woold not work for me either.
  • For XP users:

    1. Open "Control Panel"
    2. Double-click the "Sounds and Audio Devices" icon
    3. Click the "Audio" tab
    4. Under "Sound Recording", hit the "Volume..." button. The "Recording Control" window should pop up.
    5. In the Recording Control window, hit Options, then Properties in the menu bar.
    6. Under "Show the following volume controls" make sure "Stereo Mix" is checked.
    7. Close the Properties window, then make sure "Select" under "Stereo Mix" is checked.
    8. Hit "Ok."
  • Hi Guys,
    I'm fresh caught to CS 2.5. l'm still having troubles with the audio. The sad thing is that it worked for me when using CS 2.5 Beta on smaller clips but l upgraded to 2.5 and l seem to have lost audio. I'm running XP Home (sp3). I followed the instructions above from jmcruz12 (thank you), but to no avail.
    I've even gone back to the beta version - no audio. I admit, l'm confused.Any thoughts?
  • I was able to follow the instructions until step 7; there is no "Select" under "Stereo Mix" in the Recording Control.
  • Same here, no select.
  • YESSSSS!!!!!

    For people using Reltek HD Audio Input you need to enable stereo mix and then unmute it!:

    FINALLY! I HAVE A SOLUTION!

    1. Enter the Reltek HD Audio Manager.
    2. Click on the "Mixer" Tab.
    3. Under the "Record" section you will see a little spanner, click it.
    4. Make sure "Stereo Mix" is checked and click ok.
    5. Then, in the "Record" Section look for "Stereo Mix" and unmute it!

    Problem solved!

    This worked with "Reltek HD Audio Input" on XP sp3.

    I hope this helps, it sure helped me!
  • Unfortunately, this does not seem to work for me. The Stereo Mix was already checked and unmuted in the Realtek manager.

    One question though: is Stereo Mix supposed to show up in CamStudio under Audio option for speakers? Because it doesn't...
  • Actually with this fix Stereo Mix will show up under the record options for microphone.
  • The solution given by JmCruz12 worked for me. Thank you. When I record by mic I will find out if I have to reverse the decision.
  • Hi

    I use realtek too, so I have the same problem. I tried to do your solutions but I have another problem ...
    You solutions are on windows XP, I'm on windows 7. Plus, since I'm French, all of realtek settings are in French, so I'm completely lost in your explainations.

    "1. Enter the Reltek HD Audio Manager.
    2. Click on the "Mixer" Tab."

    please could you post a screenshot of this window ? It would really help me ;)
    thanks.
  • Hi,

    I was having the same problem with Win 7 so I had to do some digging. I did get it to work in the end so I will try to help you. The help for Win XP is close, but Win 7 looks a little different. One big difference for me is, there is no 'mixer' in my Realtek setup.

    I had to go through the Hardware -> Manage Audio Devices. In there, go to the 'recording' tab, select your microphone, and 'configure' it. Setting this up got it working for me instantly. I hope this helps you.
    I hope that Office Word 2007 translates this correctly! I do not speak French, but I will do what I can.

    I took a screenshot, but I do not see a way to post it. Sorry.

    J'esp
  • No need to speack French, I understand English ;) but thanks :D

    To upload screenshot, you can upload on Imagilive and put here the link to the picture.

    I'm trying to do the same as you did, could you explain what you did exactly by "configuring it" ?
  • How was Word's translation? Was it at least close?

    Here is a screen shot of how I got it to work.

    http://www.texturenook.com/index.php?p=1_5_Helpful-Stuff
  • I did that ... it still doesn't work :/
    but thanks a lot for having helped ;)
  • I'm using a USB microphone, and I'm on Vista.

    Go to the Control Panel, Sound.
    On the second tab, Recording, make your Microphone (USB) the default, and it worked for me.

    Thanks so much for the posts in this thread and in the "WaveoutGetSelectControl() failed" thread for giving me hints on how to troubleshoot.
  • that happened to me
    i dont have stereo mix, i have just CD volume, mic volume and line volume
    i use Realtek HD Audio , and i dont found it. Can anyone help me?

    Thank you!

    1x1x1x1
  • ah and i use xp service pack 3
  • Some computer companies like Dell have buckled under pressure from the RIAA to remove Stereo Mix from their machines to help stop people from bypassing their DRM efforts. If you have such a computer, you will have to get an attenuating patch cord from Radio Shack, going from the speaker or headphone out to the line or mic in. Be certain to have all your levels turned way down when you plug this in, and ease the levels up slowly and conservatively, testing until you find out what works.
    http://www.google.com/search?q=radio+shack+attenuating+patch+cord
    http://www.radioshack.com/product/index.jsp?productId=2103841(in-store only)

    Terry
  • Hey guys, for those of you who are still having this problem, Terry and I may have a solution.
    For Windows 7 - http://youtu.be/Cm8zNeHtXeo
    For Windows vista - http://youtu.be/LTtZK6v71zw
  • I have similar problem. I'm using win XP x64 and recently downloaded the latest beta (2.6b) and tried to region record a ytube video with using the speaker sounds. It did the recording, and I heard the sound as it recorded, but at the end, when the flashing finished, I got an "audio failed" error message.

    So I tried it again, but didn't hear any sound and then the same error message. I thought maybe I needed to reboot after installing, so I uninstalled and rebooted, then installed and rebooted. Same problem.

    Then I found there was no sound to my speakers except when booting, the bios controlled "rebooting" message worked, meaning there wasn't a speaker connection problem.

    Long story, I used a previous restore from two days earlier and everything worked. I since repeated all this and had the same results. Even re-installing the Realtek AC97 drivers didn't help.
  • jaf,

    Any idea what is causing the problem? CamStudio works otherwise?

    You may try re-installing the 2008 MS C++ runtime files (not 2010)
    http://www.microsoft.com/download/en/details.aspx?id=5582

    Terry
  • No, I guess I could try re-installing the vs-2008 runtimes, but then I might be breaking other applications. I'm pretty sure I have applications that use the 2008 runtimes and haven't seen a problem, but being a programmer myself, I know how that goes.
  • jaf,

    I've not ever heard of the 2008 versions competing with the 2010 ones, that is, I've never heard of it breaking any other runtime dependent programs. If you find a reference, please do let me know about the instance!

    Terry
  • I have the same problem. Trouble is, though, I was just using it earlier yesterday morning with the same settings, and it did just fine. I have a WINDOWS 7 system, not XP, and I AM USING STEREO, not mic. Can someone help me? Why did it just crap out just now? Everything went fine until this happened.........and for no reason whatsoever! I touched nothing!!
  • AirStyle,

    I take it you mean you have the same problem as jaf.

    Have you tried running the program as an administrator yet? (Right-click on the program icon and select the top choice.)
  • And you are using the "Record from Microphone" choice, not the "Record from Speakers" one, which is temperamental?

    Terry
  • I have had this problem and I finally figured it out. Like others, I have a Windows 7 64-bit with the Realtek Audio for my sound. I had figured out long before to go to Control Panel under Sound and enable the Stereo Mix. With that I was enabled to record the sound from my computer with some of my recording programs, but not with Camstudio.

    I have now found out that it is because of the quality of the sound settings in Realtek Audio Manager. To fix it, this is what I did. Go to your Realtek Audio Manager in the Control Panel and under the Speaker tab, select the default format tab. Change it to the first one on the list, 16 bits, 44100 Hz CD Quality. Do the same under the Stereo Mix tab (or whatever it is called in your setup). Now in Camstudio under Audio Options, set the recording format to be the same as in Realtek, which is the bottom one in the list. Make PCM your compressor. This fixed this problem for me. I may make a video tutorial of this later on. :)
  • I am running a Toshiba Satellite with Windows 7 32 bit and had the same issue. I could not find the stereo mix option no matter what tricks I tried so I went to the Toshiba website and downloaded the latest BIOS and Realtek Audio drivers. As soon as I rebooted the stereo mix option was there and CamStudio has worked perfectly since.

    I would strongly suggest checking the Toshiba site for updates or the Realtek site or whatever your computer or sound card manufacturer is to make sure you have the latest drivers instead of allowing Windows update to leave you with something that does not work.

    If you cannot find the stereo mix option, this is likely the fix you need
  • DoubleYou,

    Of course! I hadn't thought to warn people to use the 16-bit, 44.1kHz settings.

    brendan,

    Thanks for the update on the Toshiba BIOS and drivers - it looks like they decided not to buckle under the pressure from the RIAA.

    Terry
  • I have to uncheck the "Stereo Mix" and recheck it after a restart every time. It a total pain; Is there a way around this?

    I went into sound in the control panel did a test and no sound was being picked up.

    Then:

    1.opened realtek HD Audio manager from control panel
    2. clicked the mixer tab
    4. clicked the spanner under microphone
    5. checked the the box to "Stereo Mix"

    It worked then stopped working after restart. I then had redo the above steps this time uncheking Stero Mix click OK then re-check stereo mix to get it working....

    I have to do this after every reboot

    Any help would be great
  • Is this in XP? If so, there might be another program trying to control your input settings. GoToWebinar will do this if the host un-mutes you (change the setting to microphone).
  • Hi, what is webinar?
  • A webinar is a live presentation where a subject (or several subjects) are usually covered in depth. The word is a combination of "seminar" and "web". We have a 2-hour webinar on CamStudio I gave a while ago at YouTube - here it is!



    (Watch it at YouTube or here full screen at 720p for the best effect...)
  • hi guuys I am using windows XP and I had the same problem but I fixed it. Now a new problem appeared. I can't record sound more than 5 minutes becuase the error "Failed to rename/copy audio file" appears. Why? And how can I fix that?
  • razputin100,

    Take a look where the temporary files are being stored and delete all of those - or change the directory where your temp files are placed to a directory outside the program files folder (like in the My Videos folder, where I have created a "CamStudio Temporary Files" folder just for that purpose). I also, when uncertain whether I've gone overtime or not, COPY the temp files to another folder within that folder called "FailSafe copies" before I hit the "Save" button (after the save dialog comes up after I'd pushed the stop button). That way, if CamStudio crashes when trying to compile the temp files into an AVI, I at least have the raw materials that I can attempt to rescue in VirtualDub later on.

    Let me know if it is something else, though, that is giving you these issues.

    Terry
  • Well it got worse. I get this error after I save my videos no matter how long the video is. But something new appeared. The sentence "File creation error" made me think it is another error, but I think it isn't.
  • razputin100,

    Are you using "Record from Microphone"? Also, where is your temp directory, exactly? Plus, are you certain there isn't a file already with the same name in the folder you are saving to? Sometimes it will not write-over an existing file.

    We'll get this working eventually - 100's of people do use this program, of course! So, it is probably something simple we are overlooking.

    Terry
  • Terry,

    I have done what you said and moved my folder in wich I keep my videos and it worked. The problme is that I need to make a montage and I recorded yesterday around 15 minutes. The problem is that an error says that camstudio can't open the videos wich are in that moved folder. And because of that windows media player can't play those videos too. I think there is a problem too because I changed my losless codec to Microsoft1 after I watched a video on youtube wich was done by you. I will try to put the Losless codec back to Camstudio 1.5.
  • razputin100,

    Please Please Please!

    Do not use the CamStudio Lossless codec (or ANY lossless codec) if you are needing to record videos of any length over 9 minutes. It is a total waste of space to record full-frame recordings in stellar quality for every frame of most videos. You are likely going over the 2-gigabyte file size limit in mere minutes, instead of hours, like Xvid and others would allow you to do.

    Follow my 2012 video linked to in the sticky posts here up top and install Xvid. Microsoft Video 1 is the worst codec imaginable, so I do not recommend that one at all.

    Terry
  • I'm using Vista Home Edition with Realtek Audio, I went into Control Panel, & went to " Sounds " icon, & there are 3 tabs ( Playback, Recordings, Sounds ) select Recordings tab, in this box you will find your , Microphone, Line-In, and Stereo Mix....... for some reason, if your going to narrate a video, select Microphone and "set as default"..... if your recording a video game without a microphone, then in the Recordings tab folder, select Stereo Mix.... now make sure there are green check marks there ........ you will have to toggle between these settings in the control panel.... but it works.
    I have not figured out how to do Stereo mix and Microphone at the same time with Realtek.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion