Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
WaveoutGetSelectControl() failed
  • I get this message when I try to set the recorder to record the sound coming from the speakers. What does this error message mean? I am on version 2.0
  • It means that CamStudio (for whatever reason) isn't able to find the line needed to record audio from the speaker and then generates that error message.

    Compatibility doesn't seem to have anything to do with whether a soundcard is separate or on-board (part of the motherboard).

    There's no programming fix for this as yet, because the source code for that feature was never included in the 2.0 release - which is why it's missing in 2.5b.

    If we can figure it out, maybe we can add it back in a future version, but in the meantime ...

    Try switching to Stereo Mix (or What-U-Hear in some soundcards) as your Recording Input Source.

    In CamStudio go to:

    Options > Audio Options For Microphone > Volume

    Select the Stereo Mix or What-U-Hear option and try it again. You might have to adjust the volume setting as it can be a bit sensitive.

    Also remember to physically remove your microphone from the soundcard if your voice is not required.

    If you don't see Stereo Mix, What-U-Hear or similar, you may need to active that option in Audio Properties.

    Double click Speaker icon in System Tray > Options > Properties > Adjust Volume For Recording > Select Stereo Mix, Mono Mix, What-U-Hear, etc.

    HTH

    Cheers

    Nick :o)
  • I'm getting the same thing in Vista and just used the tip in the microphone settings that you recommended. IT WORKS!!!! Thank you a million times.
  • This Stereo Mix method worked for me, thanks for posting it, I was beginning to think CamStudio had become useless. In CamStudio's Audio Options For Microphone I had to choose "Default input device". I also had to unmute the Stereo Mix source in Volume, as it was set to be muted when it first appeared.
  • Hi. I can't get sound, and I'm trying to use all sorts of things. I have vista.
    I can't see What-u-Hear etc. and when I press the Volume button, nothing happens.
    How can I get sound when recording film!?
  • Hey droote,
    first of all sorry for my bad English. Figured out the same problem as you and was working on it since several hours. I guess I have found a solution.
    Sometimes with Windows Vista you won't see an option for "Stereo Mix". It's not that the option's been left out of Vista, Microsoft just decided to hide it.
    Here are some instructions for enabling Stereo Mix (sometimes also called Wave Out Mix)recording:

    1. Select "Sound" from the control panel.
    2. Select the recording tab.
    3. Right click on the background of the tab and choose "show disabled devices".
    4. Right click on Stereo Mix and click enable.
    5. Make Stereo Mix as your Standard
    6. Now it should work, allowing you to record any sound your computer makes.
    7. Start Cam Studio
    8. Go to Options\ Audio Options for Speaker
    9. Choose at Soundcard Device "Stereomix"
    10. Go to Options and enable "Record audio from speakers"

    After that I still got the error message but I ignored it at this time and It worked !!!

    Try it !!!
  • Woedge

    Thanks a lot for posting that - I tried it on my HP76735s laptop (Vista Home Premium) and it worked perfectly.

    You are a LEGEND!

    I'll make a video for this procedure and put it on my YouTube channel so other non-techie people can see exactly how to do it.

    Cheers

    Nick :)
  • Woedge
    Thanks a million! that worked! You saved my life!
  • Nice, I have been able to get sound now as well. But if I choose "Record sound from speakers" or "Record sound from Microphone" I don't get any output video.

    All seems fine when I record, it displays the region and the size shows up while recording. If I set camstudio back to not to record sound video is recorded just fine.

    Seems like if I record to swf I get both sound and video.

    I tried two different codecs, Divx 6.8 and Xvid MPEG4.
  • Nevermind, it was just WMP classic that didn't want to play the file with Audio. VLC played the file just fine, after a recompression in virtuadubmod the video plays fine in WMP classic too. Sorry for the disturbance. :)
  • I tested Woedge's solution and it also works on Vista Ultimate. How do you guys think it would be best to change to GUI to make this more obvious?

    I could combine all of the record options to the same menu where you just have the ability to select the recording device (ie internal mic, USB mic or the sterio mix). I think this would be a better interface for people with this problem, but it would probably break backwards compatibility.

    I could replace the record from speakers selection with an automatic test to see if it can find an input device that string compares to sterio mix, and then to post these direction if that fails. This seems britle and also possibly not backwards compatible.

    Has anybody has this issue with a computer with XP? If the problem is as simple as Vista vs. XP then I can just add a check to see which version of windows they are using and then display the new GUI or the old GUI. If its not just XP vs. Vista, does anybody know exactly what the difference is so that it could be used to determine which GUI to display?

    Is there another better way that I havn't considered yet?

    Since we've found a solution to fix at least some of the issues, I want to try to fix this in the progam, but I'm not sure the best way. Let me know what you guys think.
  • im using windows 7, on my desktop PC if i
    3. Right click on the background of the tab and choose "show disabled devices".
    i get the stereo mix visable

    but on my latop i only have Line In, and 2 Microphone with show disabled devices enabled!

    what now? lol
  • I followed Woedge's advice, and it solved my problem. Thanks! However, there is now the slightly annoying problem for me that when I play back the video, the audio is much quieter than when it actually occurred. How can I adjust this? I am using a laptop with Vista. I use headphones, but the problem is the same whether or not they are plugged in. I tried adjusting the slider in the levels tab in the properties of Stereo Mix in the Recording Devices list, but bizarrely it always seems to revert back to 20 whenever I change it, hit OK, and check back.

    Thanks to anyone who can help me.
  • Woedge's fix worked for Windows 7 as well.
  • On my laptop and many other computers with a built-in sound card, "Show Disabled Devices" does not work to display Stereo Mix as it is not supported, and the built in sound card can't be upgraded.

    I used the 3.5mm to 3.5mm audio cable that came with my iPod to connect my headphone (out) jack to the mic (in) jack to successfully record the audio from an embedded flash video. I had to record few test clips to adjust the volume level as it is very sensitive with this method. A master volume level at 25 across all devices and applications turned out very clear loud sound without hiss or distortion.

    Also, the wiki http://en.wikibooks.org/wiki/Using_CamStudio was very helpful in getting the audio properly synced to the video. I had very good results with a playback rate of 25 and the Capture Every set to 40.

    Also, to get the "record audio from speakers option", download the older Camstudio Version 2.0 (from http://sourceforge.net/).
  • Hi. I've just downloaded CamStudio and I also get "WaveoutGetSelectControl() failed" when I try to record audio from speakers. I'm running CamStudio 2.0 on XP, and the only options I got in Soundcard Device are "Realtek HD Audio output" and "Realtek HD Audio input".
  • YESSSSS!!!!!

    For people using Reltek HD Audio Input and not able to get any volume, I have a solution!!! You need to enable stereo mix from the Audio Manager and then unmute it!:

    1. Enter the Reltek HD Audio Manager.
    2. Click on the "Mixer" Tab.
    3. Under the "Record" section you will see a little spanner, click it.
    4. Make sure "Stereo Mix" is checked and click ok.
    5. Then, in the "Record" Section look for "Stereo Mix" and unmute it!

    Problem solved!

    This worked with "Reltek HD Audio Input" on XP sp3.

    I hope this helps, it sure helped me!
  • Just had this possible solution for the problem on XP sent in to me by "Steve R" ...

    Control Panel > Sounds and Audio Devices > Audio Tab > Sound Recording box set to your sound card > Start > All Programs > Accessories > Entertainment > Volume Control > Options > Properties > Recording > Select Wave/MP3 and make sure it's not muted.

    Can any XP user verify this works?

    Thanks

    Nick :o)
  • I am an xp user and that's what i get when i try to record audio from speakers. WaveoutGetSelectControl() Failed. How do i record from my speakers?
  • mylexis, which of the solutions from this thread did you attempt? What happened when you tried them?
  • Hi,

    I'm also getting "WaveoutGetSelectControl() failed" when I try to record from Speakers. I really need this function, so Im on the verge of buying some someware to do this, but I'd rather contribute to the author to sort this.

    I'm following the VIsta instructions from Woedge, but I'm using WIndows 7 and I don't get the Stereo Mix option in Recorder Devices. When I right click and select Show disabled devices, no new devices appear. The only one listed is "Microphone - High Definition Audio Device".

    Can anyone offer some advice please?

    Thanks,
    Paul
  • After following the advice from Woedge, it still isn't working for me. I have Vista and my problem seems to be either/or. I either don't have audio or I don't have speaker sound. I've looked across the internet for some tips or tricks and ran across this youtube video that shows how to make it work with Vista. Here's the link: http://www.youtube.com/watch?v=fVTB34O43uw the guys voice is kind of hard to hear, so you may have to turn up your sound. Now I followed exactly what he was doing (which was the same as Woedge), up until you going in "Speakers"- "Preferences"- "Levels Tab" and it seems that I don't have any of the other options he is having. (Oh by the way, I also have Realtek) All I have is something called "PC Beep", and I think that could be my problem... It seems like I need the "Microphone" slider. Any idea what could be wrong?
  • This worked for me on Windows 7 and Vista (both 64 bit & using version 2.00 )
    In CamStudio
    Options
    audio options
    Audio options for microphone
    Stereo Mix

    Use MCI Recording (Box Checked)

    The one side effect I had was the built in mic & the speakers were recorded on my laptop!!

    Hope this helps,
    Jerry
  • Nope, I just think that the camstudio isn't recognizing my microphone while Stereo Mix is selected.

    However, someone helped me with downloading a sound recording program to use (Audacity) for the microphone sound and have CamStudio just record the video and the sound that would be found in the video. The only problem is synching up the two programs (which without any editing experience is a little hard) to make a new video. I don't really want to deal with Audacity but if I have to then thats fine and great.
  • Hello,

    I recently got a new laptop with Windows 7 because the monitor light for my old Windows XP one died, and I ran into the same error message with CamStudio version 2.00. Stereo Mix/What U Hear/etc. didn't show up after showing disabled devices under "Recording devices." Some Web searching revealed that several computer manufacturers (Sony, in my case) apparently have the sound card manufacturers completely disable that function. This is supposedly an anti-piracy measure, but, of course, it also interferes with legitimate uses. This may be one reason why some of us do not have that option.

    The news isn't all bad, however. You can use the trick posted by asg9000 above. There are also some pieces of software out there that may let you capture the audio by setting up a virtual device. Two examples are "Virtual Audio Cable" by Eugene Muzychenko and e2eSoft's "Virtual Sound Card." These are both shareware, however, and the registration prices may be more than the cost of those cables. On the other hand, I read that the cable method may cause some quality loss, but I haven't done any comparisons myself.

    Finally, there's a solution that the CamStudio devs may be able to incorporate into the program. Vista introduced something called WASAPI that handles audio and lets you capture whatever the computer outputs (probably with some limitations). I found a blog by one Matthew van Eerde (http://blogs.msdn.com/matthew_van_eerde/archive/2008/12/16/sample-wasapi-loopback-capture-record-what-you-hear.aspx) with a sample program and code, and it worked during a few short tests on my laptop. Again, I don't know the limitations of this compared to the Stereo Mix method or the other options, but it may be better than nothing.

    I hope this helps someone,
    Dacicus
  • Hi Dacicus

    Thanks for the link to the WASAPI code, I'll check it out to see if it can be used.

    Cheers

    Nick :o)
  • Hello
    I thought everyones comments were helpfull, but for some reason i cant get my volume button to work.I go to record audio from mic options and click the volume button, and nothing happens.
    I have uninstalled/reinstalled several times and still it doesnt work.If anyone could help it would be highly appreciated.
    -thanks
  • minrain,

    The volume button in Camstudio does not work by default.

    You have to adjust the volume manually by going into:

    For Vista:

    1. Start
    2. Search Sound
    3. Hit Enter

    If you are using a microphone:

    1. Go to the Recording tab
    2. Click on Microphone
    3. Click Properties
    4. Go to the Levels tab and adjust the volume

    If you are using Stereo Mix:

    1. Go to the Recording tab
    2. Click on Stereo Mix
    3. Click Properties
    4. Go to the Levels tab and adjust the volume

    Thanks =)
  • Hi;
    first thanks for helping out how to get the sound recorded on videos.
    My problem is now I can't see the recording anymore...
    Or I chose don't record sound and I have video, or I chose sound and I don't have video...
    Can anyonve help me and solve this problem
    Thanks
  • 2PAC-M4K4V3L1,

    When you don't see video, do you at least hear sound?

    Try 2 things - Camstudio lossless codec for video and check "Use MCI for Recording" in the audio settings. PCM compression, 44,100 K 16-bit stereo

    Terry
  • 2PAC-M4K4V3L1 --

    Or you might try running the file created by CamStudio through VirtualDub (free download - just Google the name). When I first discovered and started using CamStudio for screen captures, I didn't have the problem you describe, but later for some unknown reason I did. In every instance VirtualDub has produced a usable file with both video and audio with little if any degradation of video quality. I realize this is sorta ducking the problem, but although I don't know what causes the problem, what I'm interested in is a usable file, and VirtualDub has enabled that result.

    In addition if the need should arise, VirtualDub makes usable files greater than 2GB in size (set video to Direct Copy -- audio is already set that way).
  • Terry,

    yes when I don't see video I can hear sound ;)
    thanks for your help but where can I find this Camstudio lossless codec for video and check "Use MCI for Recording" in the audio settings. PCM compression, 44,100 K 16-bit stereo??

    thank you
  • CamStudio Lossless Codec 1.4 is here: http://camstudio.org/CamStudioCodec14.exe

    A video describing where that setting is can be found at YouTube here:
    http://www.youtube.com/watch?v=XhowEhUPClc
    (ignore the part about using the MS Video 1 codec (a "lossy" codec) - though you might use that one for testing purposes as it is compatible for playback with all windows machines. The Camstudio Lossless Codec, because it IS a lossless compressor (compressor = file size reducer) will give the best results for your masters, though.)

    Let me know if that helps.

    Terry
  • 2PAC-M4K4V3L1

    Make sure you're running CamStudio in XP Compatibility Mode

    Right click Recorder.exe > Properties > Compatibility tab

    Cheers

    Nick :o)
  • Hey,

    Terry I downloaded the lossless codec and saw the video and put the same settings but still I can't have video and audio together, or I have sound and my video is black, or I have video and no sound...
    NIck when I click compatibility tab there is no Camstudio in XP, only 95,98,2000 and NT ... but I use XP
  • 2PAC-M4K4V3L1,

    How about if you set your "Troubleshooting" hardware acceleration slider all the way back up again?

    And have you tried recording in 32-bit color as opposed to 16-bit color?

    This is curious, especially as you are still using good-old Windows XP! You shouldn't have any problems!

    What exactly are you trying to record, content-wise?

    Terry
  • Yes Terry,

    I red that once about Hardware acceleration and it didn't work either :s
    Tried again now and still it isn't helping lol
    I'm just trying to record anything to test video and audio together... so a clip from youtube, or a song + my wallpaper but I hear sound and everything I record is black. If I put it on facebook/youtube than I can see it. But everything was working fine before I had audio+video. Now only one of it...
  • ... Yet it works in YouTube or Facebook with video and audio??? That's just too crazy!!! Has to be your media player or the codecs installed.

    Tried VLC player?

    http://www.videolan.org/vlc/

    Or Windows Media Classic?

    http://www.free-codecs.com/download/media_player_classic.htm

    This sounds like a media player glitch 100%, especially since the videos you create upload and play complete in both Facebook and YouTube!

    Terry
  • Terry !
    Thanks for trying to help so long :P,

    I first tried Media Player Classic because I don't like VLC Player, I had a window that opened when I wanted to read my file with 4 options, Don't use ffdshow(just once or always), Use ffdshow (just once or always)
    I tried both and it didn't work...
    Than I installed VLC it's working I can see my video but in poor quality.So thank you!
    but it's weird I could read my videos with audio before without problems... in Windows Media Player or GOM Player.
    is it possible it isn't working since I installed codecs to read .mkv files?
    thanks again !
  • I need help cuz i get the same wavegetselectcontrol() failed thing, but when i record it records my audio from speakers and mic, i made my own discussion for this, so if anyone can help me, plzzzzzzz, help!
  • I'm having the same problems. I've tried changing my Sound options in the Control Panel for Vista, but I don't seem to have Stereo Mix or any other speaker sound options available - no matter what I do. I only have Mic and Line-In options - I'm on a Dell PC.

    So, my easiest solution was to simply feed my speaker sound into the Mic port of my PC, so my speakers from my PC are directly feeding back into my PC using a Male-Male cable (or whatever you call them!?).

    This works great for, excellent sound and video quality!

    But, I then get another problem (not created from the cable quick fix, it's a general Mic syncing issue) the Video is recorded at a different rate to the video - so I end up with a shorter audio track compared to my video track.

    I've tried changing the options in MCI Recording, but that didn't help the syncing for me. And using the CamStudio syncing option with the delay adjusted is totally useless as the video and audio are different lengths. It would be great if you could alter the audio length in CamStudio directly, to match the Video length - that would be perfect.

    Instead, I had to extra the Audio from the file using Any Video Converter, then slow down the track in Audacity to match the Video length. Finally, I glued the new sound file and video back together using Windows Movie Maker - and all was well (all free software).

    Very frustrating though, the video lost over 3 seconds on a 160 sec movie! That's quite a lot. I'd love to see better syncing in CamStudio, or with simple manipulation options for stretching the audio out to match the video length.

    Keep up the good work!
  • NipponMonkey,

    Did you see this video and check out the accompanying article here on the best settings for video/audio sync?
    http://screencasttutorial.org/18/best-settings-for-camstudio-to-sync-audio-and-video-28

    In a nutshell:

    Since CamStudio does not allow for decimal settings in its setting of “Capture Frames Every”, another factor necessary to consider to stay in sync is the relationship of the “Capture Frames Every” setting to that of “Playback Rate” The two, when multiplied, must result in an even number of 1000 (1000 milliseconds, or one second).

    This limits the available “Capture Frames Every” (CFE) and “Playback Rate” (PBR) settings to the following:

    ( * marks those which are perhaps most practical.)
    CFE PBR
    1000 1
    500 2
    250 4
    200 5
    100 10 *
    50 20 *
    40 25 *
    25 40 *
    20 50 *
    10 100
    5 200
    4 250
    2 500
    1 1000

    Terry
  • Excellent, I thought there must be a better solution!

    25 fps works just about right for me, the video is a little jumpy, but the sound syncs and the overall quality is good enough for what I'm doing.

    I'm still feeding the sound in from the speakers to the mic by cable - but all is good.

    Thanks for the reply.


    *EDIT:
    I just tried 40 fps and the jumpiness has almost gone completely and AVI file is pretty much the same size as the 25 fps AVI.
    40 fps is almost perfect screen casting quality - brilliant.

    Thanks again.
  • NipponMonkey,

    Excellent news! :-)

    If you are not doing so already, setting your screen display settings to 16-bit color rather than 24-bit or 32-bit will speed things up even more, as well as reduce your file size considerably. You will not record transparency in 16-bits, but that is seldom necessary or desirable anyway.

    Terry
  • tbritton,

    My screen is set at 32-bit, I changed to 16-bit like you said, and the file sized shrunk by nearly half.

    It worked great at 16-bit in general, but the flash file I was recording lost some of its image quality when using transparency inside the actual SWF - not window frames. So for what I'm using it for now, 16-bit isn't great, but I'll remember that tip for other projects.

    Cheers
  • NipponMonkey,

    Did you see my "tome-like" work on color bits here?

    http://camstudio.org/forum/comments.php?DiscussionID=457&page=1

    or here:

    http://screencasttutorial.org/16/best-color-depth-16-bit-color-vs-32-bit-color-explained-135

    (also split out the PCM/ADPCM piece to here: http://screencasttutorial.org/54/pcm-or-microsoft-adpcm-which-is-the-best-audio-for-screencasting-139 )

    (also added some codec stuff used in reply to walshlg's codecs observations post to this one: http://screencasttutorial.org/02/optimizing-your-pc-for-camstudio-12 )

    Terry
  • tbritton, the 16-bit quality lose was down to my PC, not CamStudio. I wanted great visuals, so I kept it at 32-bit and found a better way of shrinking the avi file.

    Here's my best solution for great screencasting quality and file size:

    Screencast with CamStudio at 40 fps to ensure good quality video and audio is in sync. Now you have a great video, but the file size will be quite large due to the video and audio quality being set high and the file not being optimized yet. My 2 minute video was over 100mb!

    I used Any Video Converter (AVC), free video and audio conversion software, to optimize the video and sound. Just add the CamStudio screen cast you made to AVC, change the "Profile" settings to "Custom AVI Movie" in the top right corner. Then, in the output video settings, set the frame rate to whatever you like, I stuck with 40 fps, and the video size, I manually entered my custom sized height and width "700x400". I used the xvid Video Codec that was set by default. I didn't change the AVC audio settings, they were set at MP3, 128 bitrate, 44100 sample rate and 2 audio channels.

    Finally, simply click on "encode" and the new optimized video is created.

    My 2 minute video was shrunk in seconds from over 100mb to 4.5mb with barely a difference in video and audio quality - excellent!

    Note: I think I had to install Lame for mp3 conversions for AVC, but I can't remember for sure as I installed it a while back.

    So, for quality optimized screencasting for free, I suggest using CamStudio for the recording and then using Any Video Converter to considerably shrink the avi file size.

    Now I have to optimize all of the videos I've already made!
  • @NipponMonkey

    Thanks for posting your results ... I have a play (and I bet Terry will too :o) with Any Video Converter.

    @tbritton, that "drop your display to 16-bit" tip is a cracker.

    I believe Vista/Win7 Premium users can get the same effect automatically by selecting "Disable Desktop Composition" in the Compatibility tab after right-clicking Recorder.exe and selecting Properties.

    At least I see the same "The color scheme has been changed to Windows Vista Basic" message.

    Cheers

    Nick :o)
  • NipponMonkey,

    You can achieve similar results from the "local favorite" VirtualDub http://virtualdub.sourceforge.net/ (and even batch process, from what I hear!), but it is good to hear another fine review of the Any Video Converter http://www.any-video-converter.com/download-freeware/ .

    I'll d/l it and give it a good looking at based upon your suggestion and success!

    Terry
  • A few questions:

    1) Will AVC also make CamStudio files which are over 2 gigs in size, playable, same as Virtualdub? I have some 4 hour sessions I need to record, and was going to run the huge resulting AVI files through Virtualdub to make them playable and editable. Anyone tried this with AVC?

    2) Where on a Windows 7 computer do I find the settings to adjust the 16 or 32 bit display output? Can't seem to locate it.

    3) Lastly, and I know this is probably asking for too much, is it possible to record BOTH the audio from the computer and the mic at the same time? Seems it's either/or. I moderate online conferences (using Paltalk as the audio platform), and it would be nice if my voice could be recorded as well when I'm moderating.

    Thanks for your help.

    Baron
  • "2) Where on a Windows 7 computer do I find the settings to adjust the 16 or 32 bit display output? Can't seem to locate it."

    On my Toshiba Satellite running W7 Pro there are two ways (and there may be more -- am still not totally familiar with W7):

    1. Right click on blank space on screen and then select Graphics Properties>>Display Settings>>Color Quality. I'm running with a second monitor, so it's possible this way to set has to do with that. I don't remember, but it works on this machine/monitor combination.

    2. Control Panel>>Appearance and Personalization>>Adjust screen resolution.


    ====================================================================================================
    Moderator add on:
    Credits to Terry..!
    ====================================================================================================

    "PROBLEM SOLVED!!!

    Here's the fix: Right click on the MS speaker icon in the task bar, select recording devices, single left click the Mic Input then select the properties button... go to the listen tab and select listen to this device.

    Mic input is now routed into the stereo mixer, and both record in CamStudio.

    (Issue closed)
This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion