Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers. If you want an invitation contact forumapplication @ camstudio . org Sorry for the inconvenience.
File Creation Error. Unable to rename/copy audio file
  • I seem to get the message File Creation Error. Unable to rename/copy audio file. I have all the original/default settings but I enabled auto-pan and it's speed is either 19 or 20. I am only using a microphone to record sound. It seems that anything 4:30 or longer makes this error.
  • Hi Derek

    What version of Windows are you running and where are you trying to save the completed video?

    Is Name of AVI file (in Options > Program Options) set to Automatic file naming?

    Cheers

    Nick :o)
  • Windows x64, and in the Program Files(x86) camstudio 2.6b file, and yes auto name file is on
  • Hi Derek

    Can you change the Auto file naming so it asks for the file name and then save the AVI to somewhere other than C:\ Drive?

    I want to see if it's a permissions issue with Program Files or whether CS actually has the issue.

    Also, if you haven't already can you download and install the latest version of 2.6b (r273) from the CamStudio homepage to test?

    Let me know ...

    Cheers

    Nick :o)
  • Still an issue and i suspect the culprit is the Lossless Encoder since i started using Xvid Encoder the program and encoder has been working better.

    Should probably also mention im on a "Windows 7 Ultimate 64" machine
  • @Derek,

    Can you give us an overview which codec works and which fails.

    Jan
  • This happens if you had muted input devices before recording began. It would be nice to check that in camstudio and warn user. If he insists to record a video with muted input, then there is no need to blend in audio.
  • I believe I found the problem, which I'll list here in case it helps others.

    The default settings for recording (at least on my machine) are 200 fps. This means you'll pass the 2GB limit on avi files quite soon (depending on your recording area). When you pass the 2 GB limit, Cam Studio will keep recording and you'll think everything is fine but when you stop, you will get this error.

    I changed my settings to capture 25 fps and now it takes several minutes to pass the 2 GB AVI limit.
  • John1444,

    Super!

    Reference the following article for more information on best settings:
    http://screencasttutorial.org/18/best-settings-for-camstudio-to-sync-audio-and-video-28

    It was actually the Capture Frames Every being set to every 5 milliseconds that was eating up your file size. But you did the right thing!
    Now, set your Playback Rate to 40 (1000/25 = 40) and your audio will sync fine (use 44 or 22 kHz sampling - 11 khz is broken a bit).
    The Set Key Frames Every setting is good between 5 and 30 or so - up to 50 max, I'd say.

    Terry
  • "The default settings for recording (at least on my machine) are 200 fps."

    We have to make a mental note that we shall not use these setting as default settings and use 25/40 as default.

    Even better is to introduce an additional function that reset all settings. In that case any user can reset to factory settings anytime.
    The current solution -to delete the config file- do the same job but people are mostly told to do such a thing after they asked for help here.
  • Janhgm,

    Excellent ideas. This "Reset to Factory Settings" option could exist in the "Troubleshooting" menu.

    Terry
  • Hi there

    I am trying to use Camstudio v2.6 because version 20 produced errors when I tried to simply record 3 hours. (This seems to be due to a restriction in that version - 20 - of a limit of 2GB maximum file size.)

    However, in v2.6 I get the error mentioned above in the thread title "Unable to Rename/Copy Audio File"

    Is there now a definitive workaround, or is there due to be a fix or patch for this bug any time soon?

    i would very much prefer to use Camstudio opensource than have to rely on free version of Hypercam, so all advice would be greatly appreciated.

    Being an ex-programmer, I know that good and fully functioning software does not simple fold in that way, so hopefully there is a now a simple solution.

    Many thanks!
  • phil,

    It was not a bug in 2.0, but a limitation imposed by our using the AVI file format, which has specifications limiting the file size to 2 gigabytes maximum (video AND audio combined). There is no "workaround", exactly, though some have rescued their files by bringing them into VirtualDub via the video menu setting of "Direct Stream Copy" - booklover has written about this technique in the "Known Bugs and Limitations" thread a few posts down:

    http://camstudio.org/forum/comments.php?DiscussionID=350&page=1

    The issue of merging the .wav audio content back into the video has not been completely addressed with a reported success and method leading to such a success. I would try converting to another container format and then try via some other program to merge the audio back in. Clueless, I am, concerning this one. Please let us know if you meet with success and discover a method that works.

    Terry
  • Thanks for the feedback, Terry.

    I managed to record a sample 3 hour session with Hypercam instead seeing as Camstudio has the limitation. The audio was out of sync later in the recording but I can change the variable so it will work next time, or use virtual dub to line the audio up aftewards.

    Shame about the Camstudio limitation, and the the limitation isn't catered for by the software with an appropriate error message pointing out the limitation. i suppose it's a nice little freebee for those who want to record very short videos, particulary kids who want to put some short meaningless nonesense on YouTube.

    Thanks again for the help.
  • phil,

    Again, the limitation is imposed by the AVI specification, not by CamStudio. This makes me wonder what format Hyperstudio is recording in!

    As to the audio de-sync, try the trick of keeping Hypercam's equivalent of "Capture Frames Every" TIMES the playback rate (fps) summing to 1000ms (1 second). Let me know if that helps you.

    I and most other users of CamStudio use it to record tutorials, Powerpoint and browser-window driven lessons and demos, and sales presentations. I'd guess the minority of users are younger folks, because CamStudio has never been the optimal tool for recording screen-recordings of game play (though the recent discovery of the Lagarith Lossless codec may be changing that...) It was not ever the optimal tool for recording 3-hour webinars or lectures, unfortunately, but that is the AVI max-size issue from what I understand. Audio size, actually, is the most damning culprit in these cases of oversize vids, as uncompressed audio takes up a huge amount of drive space.

    Terry
  • I'll try that, thanks terry. i don't know what hypercam does, but i do know it is one of the few things I've run on my i5 that really uses the cpu, and it seems to create the final file as it is recording.

    I also got a pointer to some more help here.. http://www.hyperionics.com/hc/faqs.asp#SoundSync fwiw
  • So any new insight to shine light upon recovering the video files that had this error?
    I found them in saved folder but nothing can play them.
  • computeruser,

    I've had luck using VirtualDub on the temp avi files, but when you open a video, you must have the checkbox in the lower left corner checked ("Ask for extended options after this dialog") to enable advanced processing capabilities.

    Terry
  • I had this same problem and wasn't able to find the answer. Then I realized that I had my mic plugged into the mic port on the front of my computer and there was another one in the back. I tried the other one and it worked! No more "File Creation Error. Unable to rename/copy audio file" and it creates the video+audio fine. I'm not sure if that will fix the error for everyone, but checking if you have a second mic port is probably worth a try.
  • Hi, I am having this same problem. The curious thing is, it never happened to me before but recently I keep getting this error message. Once I stop recording, and there is that "Compress Video ...%" at the top of the window, it usually stops halfway and sometimes I get the (Not responding) message as well. Other times, it just freezes at a certain % and then after some time, the error message pops up...

    I was wondering what could be the issue? Btw, I am using the Microsoft Compressor which I've read on here is not great but it gives me the best image quality. The fps is set at the highest etc, for the highest quality, but I make sure that the recording does not exceed 2GB.

    Any suggestions please? I was wondering whether my low hard drive space has something to do with it.. I have tried saving to my C drive and D drive but it hangs either way... Any help would be much appreciated, thanks.
  • johnalan,

    Keep in mind that the 2GB has to include the audio (which is the lion's share of the file size in most setups), so do not trust entirely the readout in the CamStudio window when recording concerning file size - that is only the video portion being shown.

    I say that because the symptom you report is quite typical of a crash brought about by an over-2GB file size. This can be mitigated by lowering the quality setting a bit, lowering the playback rate and raising the "Capture Frames Every" setting (ensuring the numbers, when multiplied together, sum to 1000), and increasing "Set Keyframes Every" upward to 100 or 200. I also recommend Xvid at quality setting of 1 (as I mention in all my recent videos).

    Here is the 2.7 tutorial video I made a little while ago - perhaps that will have some info useful to you as well. The "Show More" region beneath the video has useful links (to Jawor's Xvid and Sizer, etc...)

    Terry

    http://youtu.be/WQ5_6szOf48

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion