Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

[Req] Recommended settings for recording for 90 min.

edited April 2011 in Support
Hi, I'm having trouble when recording long sessions. I'm aware of the 2giga limitation so I'm asking what settings would you recommend for recording a presentation that lasts 90 minutes on a 1280x750 screen. Is it even possible?
Thank you
«1

Comments

  • edited April 2011
    wallace108,

    I would use CamStudio Lossless Codec, cut the audio to 22MHz (in other words, do not use MCI to record) and use MSADPCM. You may have to fight some audio sync issues later, BUT recording using MCI will make for full-size (16-bit, 44.1MHz sample rate) CD quality files. Very large! Perhaps VirtualDub can fix the sync problems later.

    Or Install the AC3 encoder using the K-Lite Codec Pack. MP3/LAME caused sync to drift.


    You can install using either the K-Lite Full or Mega Codec Packs.
    Full: http://www.free-codecs.com/k_lite_codec_pack_download.htm (be sure to select the "Full" one)
    Mega: http://www.free-codecs.com/download/k_lite_mega_codec_pack.htmI

    Capture as small a window as you can get away with. Lower your display settings to 640X480 so that "full screen" takes far fewer pixels, and the player you are using sizes itself to fit properly (will require testing with that player).

    Set these video settings:

    Set Keyframes every to 100
    Capture Frames Every to 100
    Playback Rate to 10

    You should experiment beforehand.

    You could also try
    Set Keyframes every to 100
    Capture Frames Every to 50
    Playback Rate to 20

    I once experimented with an extremely high setting for "Set Keyframes Every..." setting it to 200. I got very small file sizes that way... but it made me nervous!

    See this article: http://screencasttutorial.org/18/best-settings-for-camstudio-to-sync-audio-and-video-28/3

    Let me know what you come up with!

    Terry

  • Hi Terry, thanks for your reply. Funny I was just watching all your videos in a row when I got it :)
    I will certainly give your settings a try and see what I can come up with.
    Thanks again for helping
    Mike
  • edited April 2011
    wallace108,

    I appended the above post with the suggestion to use MS ADPCM as a trial also, as it works well with 22KHz audio files.

    Keep us posted!

    Terry
  • Excellent! I'll start with some tests ;)
  • wallace108,

    So, we're going for 5400 seconds (90 minutes) under 2GB. I'm doing some trials also.

    Terry
  • Good. Let me know if you're using 2.0 or 2.6. I know you have them both installed :)
  • edited April 2011
    wallace108,

    I'm doing my first test using 2.6 with 22KHz MS ADPCM audio.

    By the way, here is an article on that:
    http://screencasttutorial.org/54/pcm-or-microsoft-adpcm-which-is-the-best-audio-for-screencasting-139

    Using the 100/100/10 settings in the video, with CamStudio Lossless 1.5.

    I'm 2900 seconds in right now, at 204.5 MB, so I probably am going to overshoot the mark!

    Terry
  • Ok, after 30 min. I got a 4+ gig video file AND an audio file. Camstudio said it could not join them together.
    The video configuration was: CamStudio Lossless Codec v1.4 (quality 70), 100/50/20.
    Audio: PCM 22050 at 16bit
    No joy.
  • edited April 2011
    wallace108,

    The audio is what ate it all up for you - you'll have to compress it.

    Use CamStudio 2.0 to be on the safe side for this long recording test. I just had a crash at 277MB video and 226MB audio (with MS ADPCM) using 2.6 - your audio was likely much larger.

    Did you find the temp files? Mine were in my Windows directory in the Temp directory. I could not open the .avi with VirtualDub - which surprised me. The crash was an "exception error" thrown by v2.6r294 - I'll try again with V2.0, same settings.

    More testing! Definitely we'll have to go with 100/100/10, I think.

    Terry
  • Actually my audio file was just 138+ mb. I couldn't open the avi file either with VirtualDub .. hmmm ..
    I ran another test of 15 min with TechSmith Screen Capture Codec at 20/50/20 but Camstudio 2.0 didn't even save the file ...
    I guess it's not going to be easy...
    I have to go now ... I'll resume my tests in the morning. I wish you better luck.
    Mike
  • wallace108,

    There was a memory leak being discussed a while back that was fixed in 2.6 r273 (so, I think it was persistent back to v2.0), so I'm going to try that version for some tests.

    You can download it from this link if you want to try it.

    http://sourceforge.net/projects/camstudio/files/CamStudio 2.6 beta/CamStudio_Setup_v2.6b_r273_(build_05Oct2010).exe/download

    Terry
  • edited April 2011
    wallace108,

    I succeeded in recording a 90-minute recording, using the above-mentioned Version 2.6, r273.
    The temp video was a mere 154MB, with the audio portion hitting 254MB.

    The successfully combined and saved AVI file is 391.3MB - quite comfortable!

    Here were my settings:

    Display settings - 16-bit display,
    Full Acceleration (I didn't remember to set it lower) - Keep in mind that CamStudio will get only a black screen from many media players (including Windows Media Player) if the Acceleration setting in the Troubleshooting tab is not set lower than maximum (-3, disabling directDraw - XP, of course).

    Region: 640X480

    Video:

    Set Keyframes Every... = 100
    Capture Frames Every... = 100
    Playback Rate = 10

    Compressor - CamStudio Lossless 1.5 set to 6

    Audio
    22K 16-bit Mono
    MS ADPCM at 22K 4-bit Mono

    I set the "Automatically Stop Recording After..." setting to 5400 seconds and went to eat dinner. I came back as it had just finished up - asking me where I wanted to save it! Hurray!

    Now to tweak this result to go after some better quality settings or a larger region recording.

    Another thing I noticed today that is broken in r294 was that the correct readout for MS ADPCM is not present - it gave me a 22KHz, 16-bit Mono option, where MS ADPCM uses a 4-bit sliding "word" to compress the audio, so it should have read 22K 4-bit Mono. I'm avoiding r294 for anything but bug-testing for a while!

    Terry
  • edited April 2011
    wallace108, I did another 90-minute take with a widescreen region of 856X480 with the exact same settings otherwise, and still came in with the temp video under a gigabyte in size (938MB) with a temp .wav file of 231MB. These combined into 1.1GB result - a surprising amount of growth from not having increased the region by THAT much! 1270X720 may be out of the question, I believe. <img src="http://terrybritton.com/CamStudior273_90-MinRecording.png" /> I'm going to try another one later, and will be going for 1024X768 by seeing how the AC3 codec compares with the MS ADPCM one. If I can get the audio teeny, it may squeeze in there. Terry
  • Ok. I did another attempt. This time with Camstudio 2.6 r273. Region: 1190x733, 16 bit res. Camstudio Lossless codec 1.5, 100/100/10, Microsoft ADPCM 22050Hz, 4 bit, 90 minutes.
    The resulting video file was 2.2 gig (wouldn't load in VirtualDub) AND a 4.3 gig sound file. Don't know what I'm doing wrong.
    Mike
  • edited April 2011
    Mike,

    Most likely 1190X733 was too large a region size. However, I am not sure why yours wouldn't load into VirtualDub. I just performed the same basic test as you did, but with a 1280X720 screen, which resulted in a 2.6-GB video file. I also used 11KHz audio and MS ADPCM, which resulted in a 116-MB .wav audio file.

    Perhaps the secret to getting it to load into VirtualDub is to leave the save dialog alone and NOT try to save it (leaving it up there), then opening the tmp file in VirtualDub before the program crash can damage it. That's just a guess, because that is exactly what I had done.

    VirtualDub gave three errors, the most damning of which was the lack of keyframes (warning that seeks would take a long time). Indeed they would!

    Working slightly differently from booklover's technique, rather than set VirtualDub's Video menu to "Direct Stream Copy", I went with "Full Processing" so I could re-compress the video (as CamStudio Lossless as a second run) and checked "Force Keyframes" and put 100 in the box.

    I then went to the audio tab and loaded "other from file" to get my .wav file in there. I was truly amazed to see it synced up just fine!

    I saved as AVI (F7) and the video worked in Media Player, AND the seek time was pretty darn fast for a 90-minute video! This resulting video was 2.9-GB in size.

    I'm doing one next with the "Set Keyframes Every..." set to 200. That drastically reduced my file size in tests in the past. I'll let you know how that goes.

    Terry

  • Thanks Terry. Probably you're right: the region I choose is too large. I'll go with the 1280x720 screen and try to replicate your results.
    Thanks
  • edited April 2011
    Mike, Here's the error box from VirtualDub I received when I opened the temp AVI file. <img src="http://terrybritton.com/CamStudio2GBVirtualDubWarning.png" /> I'm not certain what "Keyframe reconstruction was not specified in Open options", so I'm investigating whether I could have saved a step somehow next. [Edit - There is a checkbox in the lower-left corner that says "Ask for extended options after this dialog". I think the top item, "Re-derive keyframe flags" is likely appropriate.] I'm running that test I suggested above with "Set Keyframes Every" set to 200 right now, so I'll let you know how it goes. Terry
  • I'm doing the same (but the video res is back at 32). As soon as I'm done I'll post the results.
    Mike
  • edited April 2011
    Mike,

    Have you set up your audio to capture via Stereo Mix to get the sound from these presentations you are recording? I have a video on doing that :

    Windows XP:



    Windows 7 (with mic also, but mic is optional):



    I hope that's helpful as well.

    Terry
  • Well the audio part was easy. First I set "record audio from Microphone" and then in the "Audio options for microphone" i chose StereoMix. I did a little test and everything was fine.
  • edited April 2011
    Mike,

    Excellent news on the audio!

    Did you see my edit above? It pertains to that last VirtualDub warning message: "Keyframe reconstruction was not specified in Open options".

    There is a checkbox in the lower-left corner when you open a video that says "Ask for extended options after this dialog". I think the top item, "Re-derive keyframe flags" is likely appropriate.

    By the way - on my most recent test (the 1280X720 one I had worked out the VirtualDub procedures with), I had checked the setting in the audio settings, "Interleave Every" and set it to every 100 frames. That may have helped keep my audio in such good (spot-on) sync.

    Terry
  • Good to know. Of course if I can get the .avi file to open/load in VirtualDub :)
  • Damn! After 90 minutes of recording I screwed up! You are right. When it asks where to save the file I checked the temp folder and there they were a 4+ gig video file and a 180+ mega audio file. I should have moved them to a safe folder and later import them into VirtualDub. Instead no, I tried to save the recording from the regular save dialog box, of course it didn't make it and so CamStudio erased the files from the temp folder.
    Back to square one. At least now I know what to do.
    Mike
  • Mike,

    While the save dialog is open, that's when you should leave that open (left alone) and open the file from VirtualDub, then add the .wav file and save it. I could not move the file out of the temp folder because Windows said it was in use (CamStudio had it still).

    Why was your file 4 gigs? ...oh, wait - you had gone back to 32-bit video - though I think that doesn't matter that much for smaller videos, for large ones like these, it should add up quite a bit. Mine was 2.6-GB, 90-minutes on the nose. (I used the "Automatically Stop Recording" feature set to 5400 seconds.)

    I also had set CamStudio Lossless' settings to 9 (for best compression).

    My most recent is almost done (using SKFE set to 200). I'll let you know what happens!

    Terry
  • I repeated the same procedure. This time I saved both video (4+ gig) and audio (119+ meg) files in a different directory. Unfortunately VirtualDub on trying to load the avi file returned this error message: <i>Couldn't locate decompressor for format CSCD (unknown). VirtualDub requires a Video for Windows (VFW) compatible codec to decompress video. DirectShow codecs such as those used by Windows Media Player, are not suitable.</i> Mike
  • edited April 2011
    Ok. I was using VirtualDub x64. I downloaded VirtualDub x86 and it does load the avi file but subsequently it crashes with this error message: <img src="http://img856.imageshack.us/img856/5398/screenshot022c.jpg" />
  • edited April 2011
    Mike,

    Yeah, I was afraid 4-gigs would be pushing even VirtualDub a bit too far.

    I've had two successes now with files under 3-GB in size (both videos were 2.6-GB). I used that checkbox at the bottom of the open dialog and checked the Keyframes item, then added the .wav file from the audio menu ("other audio from file").

    I had forgotten to set compression in BOTH the audio and video before saving last time - this time I am setting the audio compressor to the MS ADPCM 11KHz setting (like the original was) and set the video compression to CamStudio Lossless at 9, and forced keyframes (checkbox at the bottom) with a setting of 100.

    The last one was perfect sync. I hope this one does also. I'm going to try some other compressors before dumping this file. (The only difference with this one was using a SKFE setting of 200 - it did not lower the AVI file size, however - in fact, it was 10 Megs larger!)

    You can embed an image by using the regular HTML img src=" style syntax.
    (I changed your code so it would embed)

    Terry
  • I'll give it another go with the 16 bit resolution (and all your settings) and will keep my fingers crossed :)
  • Even with 16 bit res the result was the same. The temp video file was 4+ gig, it wouldn't load in VirtualDub if "Re-derive keyframe flags" was flagged. It did load when the previous box was not flagged only to crash later with the same error message I posted above.
    Enough for today. This is getting tiring :(
    Mike
  • Mike,

    Well, I don't get it, but perhaps there is much more motion in the graphics you are recording as tests, so CS Lossless is not able to do much in the way of compressing it (CS Lossless is made for presentations where there is little change from frame to frame, as with slide show presentations or tutorials on how to use software, for instance.)

    I used a long webinar on Internet marketing as my test case, and 90-minutes came out pretty consistently to about 2.6 GB with those settings. Just to reiterate (and make it easier to find for myself!):

    CamStudio:

    Video:
    CamStudio Lossless Codec set to 9 - Best Compression
    "Set Keyframes Every..." set to 100 seemed to work very well.
    "Capture Frames Every..." set to 100
    "Playback Rate" set to 10
    Display color depth at 16-bit
    "Troubleshooting" tab at "minus-3" -- "All directDraw disabled"

    Audio:
    11KHz or 22KHz 16-Bit Mono
    Compression with Microsoft ADPCM set to same (11KHz or 22KHz but 4-bit Mono)

    In early tests, I had "Interleave" unchecked.
    In later tests, I tried "Interleave" checked and set to interleave every 100 frames

    Screen sizes tried:

    640X480 - fit easily... no crashes
    856X480 - fit easily... no crashes

    1280X720 - Average 2.6-GB temp file - crashed CamStudio, but rescued via VirtualDub
    Must load video into VirtualDub BEFORE hitting "Save" OR "Cancel"

    More on VirtualDub below.

    Terry
Sign In or Register to comment.