Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

CamStudio doesn't work correctly in Win7 64b

Hello,

Main problem is that it doesn't record video when audio is activated to record too, everyone player only play this audio but no video. It happens with all codecs I have.

Other problem is that video recorded (without audio) with lossless codec 1.5 appears with purple colour.

Any ideas?

Thanks!

Comments

  • Nobody? :(
  • Re-install the runtime libraries for a start.

    Get them for 32-bit XP, Vista or 7 here:

    http://www.microsoft.com/download/en/details.aspx?id=5582

    (This is the one you will need - the 2008 version - even if you have a 64-bit machine)

    Terry
  • It doesn't work neither :( I'm hopeless...

    Thanks anyway!
  • edited February 2012
    Well, try the 64-bit version of that, then, if you have a 64-bit machine. I don't believe I had to, but now I don't remember.

    http://www.microsoft.com/download/en/details.aspx?id=2092

    However, this might be merely the player you are using. See the following thread (which is the only other place I've seen this problem discussed.)

    http://camstudio.org/forum/discussion/comment/3569#Comment_3569

    Terry
  • Yes! It's a player issue, I'm using Media Player Classic, MPC Home Cinema, VLC,..., all last versions, but only working with Windows Media Player :/ .

    It would be ok that fix it in newer version!

    Thanks!
  • edited February 2012
    Ashe,

    I think you'll be very happy if you install ANY version of Xvid out there and use that. It plays well with all the media players I've used. I use Jawor's Xvid due to the optimizations he has added to his profiles (and always use the HD720 profile, pretty much...)

    http://jawormat.republika.pl/xvid.html

    (Install one with 32-bit binaries, as CamStudio needs the 32-bit ones. Media players like the 64-bit WMP can use the 64-bit ones, but most players are 32-bit programs.)

    Be sure to configure it with quality 1, and under the "Other options" button at the bottom, uncheck the option to show the "Display encoding status" window.

    Terry

    PS - It is not a "bug" in CamStudio, per se, but in the media players that do not recognize the CamStudio Lossless codec and several others in the AVI-1 container we are still using. We are thinking to make Xvid become the default codec instead of the current one, which now is Microsoft Video 1. Even more importantly, we are moving to using AVI-2 as the container in the future, which will overcome several problems (like the 2-GB file size limit we currently have.)
  • edited February 2012
    Thanks but same problem with Xvid 32-bits, when audio is activated only working with WMP :( I think that problem is in my system... the fact is that player try to play video but suddenly it's minimize playing only audio.

    On the other hand, what do you mean with quality 1? Or is it 100? :)
  • Quality - Ahh - I get your confusion. In the Video Options dialog there is a slider for "quality" but I believe that only applies to Microsoft Video 1 - not sure really! I do know, however, that it has no effect upon most other codecs. That one I'd set to 100, for sure!

    On the other hand, in Xvid it has a quality slider that I slide all the way to the left for a quality of 1 (it defaults at a 4, I think - totally unnecessary for most uses.)

    I'm surprised only WMP is able to play your videos made with Xvid. I play those using VLC, WMP, Realplayer, the HP Movie Player, Quicktime, and Vimeo and YouTube love them as they are native h.264 MPEG-4 files like they like to get. Perhaps the playback codecs were not included with your installation? (You have to specify that, I think.)

    Let me know what happens!

    Terry
  • I have only xvid and ffdshow installed. How I say, only WMP plays video if audio is recorded, if not, all players play video.

    Thanks!
  • edited February 2012
    Try running the video through any-video-converter and convert it through their "custom MPEG-4" converter. That created a video that opened in every player I had, whereas Quicktime and Realplayer choked on a recent video I made that had CFE=100 PBR=10 (don't know if that was why). I converted to be at 30 frames per second and all players worked.

    http://www.any-video-converter.com/products/for_video_free/

    Terry
  • Try Uninstalling CamStudio and Microsoft Runtime Library And Reinstalling CamStudio And Microsoft Runtime Library. hope this helped you :)
Sign In or Register to comment.