Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Lossless codec not showing up

edited January 2010 in Support
I installed the lossless codec fine, by using the method.
But it will not show up in my video codecs list in camstudio.
im in windows 7 64 bit


  • uh bump?
  • Hi!

    I think, you need to install .Net Framework.
  • which version?
  • I am also using Windows 7 (64 bit), am unable to successfully install the lossless codec, I have tried installing the .net framework (the latest version available from Microsoft, version 4.0.30319), and I have verified that the "camcodec.inf" file is located in my c:\windows\system32\drivers area post-install.

    I still do not see the lossless codec showing up in my list of available codecs (under Options -> Video Options -> Compressor section).

    Any other suggestions for how to get this codec successfully installed?
  • i really wish he would update it, or at least tell us what is the problem
  • The codec did not show up for me, either, until the next day when I opened the program, there it was miraculously. I am using XP.
  • Hello!

    I found a solution to that problem.
    It is a 64-bits issue.

    1. Install codec normally (if not done yet).
    2. Extract the codec archive, and copy this file "camcodec.dll" to this location: "c:\Windows\SysWOW64". You will need administrator rights (Windows will prompt you).
    3. Start or restart Camstudio, or any other video program, and check if codec is visible now.

    If it is not sufficient, you can try to make some registry changes:
    Create a pure text file, using Notepad.
    Paste this text:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
    "camcodec.dll"="CamStudio lossless codec [CSCD]"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]

    Then open (run) the file.
    You will need administrator rights (for example, run Regedit in administrator mode and import the text file in it).
    Finally restart camstudio.

    I hope that will help.
    Maybe the codec creator will fix the installer.
  • moisamva,

    Brilliant! Thank you!

  • thank you very much !!
    It was very helpful !! :)
  • and no need to reboot :)
  • I followed each of the steps moisamva gave in June and they work flawlessly with Windows 7 64 bit. The lossless codec now shows under the options ---> Video options --- Compressor list. These instant solutions are recommended to everyone.
  • In using Windows XP, after unzipping the file, the install instructions say to right click on the camcodec.inf file and click install.

    But you'll see 5 files listed. Camcodec, Camcodec.dll, copying, install, readme.

    The first file, Camcodec, seems to be missing the .inf extension in it's name.
    Right click on the Camcodec file name. You should then see the install option there. Click install and you should see it being installed. Then you can find it listed in the list of codecs in the Video options section under the Options tab.
  • George, most likely you have your folder options set to hide common extensions. Switching that instead to show all extensions might cause the .inf to reappear.

  • moisamva , you said to "extract the codec archive" in step 2. What's the codec archive, and how do I get to it??? Can you all please put this in layman's terms. I don't understand!
  • Actually, I need help with ALL of step 2. moisamva said, "Extract the codec archive, and copy this file "camcodec.dll" to this location: "c:\Windows\SysWOW64". "

    What's the codec archive, how do you I get to it, how do I extract it, and where is that location that I'm supposed to copy the file camcodec.dll to???
  • @EagleScoutMike

    Download this file:


    Extract the content of the zipfile into a folder somewhere using your preferred unzip software (7-Zip, WinZip, WinRAR, etc.)

    Then follow Moisamva's instructions. Job Done!

    BTW, huge thanks to Moisamva for that solution, I'll get the installer amended as soon as possible.


    Nick :)
  • I tried that just now, but my saved videos still aren't showing up in the CamStudio folder. I know they are in that folder because I can see them when I save a new video, but I can't see them when I actually go into it. Also, I know the videos are saved on my computer because when it finishes a video, it pops up the CamStudio Player and I can watch my whole video on it. But, I can't get back to it or anything after that.

    Does anyone know how I can get to the videos in that folder??
  • edited January 2012
    Videos are never made to be invisible - they are somewhere you haven't looked yet!

    Set "Name of AVI File" under Options/Program Options to "Ask for Filename".

    You may have your videos sitting either in the program folder or in the temp folder you selected under Options/Program Options/Directory for Recording (which selects where the temp files are kept - finished files end up there also in 2.6 r294 if you don't specify "Ask for Filename" in the other setting.)

  • Or, if you're using version 2.6, you can go to the Program Options menu and tell the program where to save the video files. I have a directory/folder named CamStudioData where ALL my videos go. Be sure to save CamStudio after you tell it which directory so it will remember it when you open it again.
  • edited January 2012
    Hello Nick. We are waiting for fixed installer during half year. :O If you plan for double waiting, it is 1 year for simple repair. @-) Why that? You promise, but nothing in progress! :-W
  • Thanks to moisamva the solution worked great
  • I have 64-bit windows 7 as well and am having the same issue. The lossless codecs (1.5 that came with v2.6b r294 and 1.4 I downloaded discreetly) are not shown in the Compressor list of the Video options under Options. I have followed moisamva's instruction and the first one (copying the camcodec.dll file to location: "c:\Windows\SysWOW64" and restart CS) failed. I want to move on to the second suggestion, but am not familiar with what to do with Notepad.

    I copied and pasted the following: "Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
    "camcodec.dll"="CamStudio lossless codec [CSCD]"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]

    and what to do with this document? What to save it as? Or keep it open? The instruction just said "open(run) the file" after copy and paste, but how do I open(run) it?

    Thanks for your input, anyone.
  • I would like to know, too.
    I'm nervous about editing the Registry.
    Somebody, please help.
  • @TeaSipper

    I don't have 64-bit Windows, so bear with me ...

    Did you reboot your machine after you copied the camcodec.dll?

    Regarding the registry entries, I tried to post instructions but run out of space here.

    Download them here:


    I take no responsibility for any issues caused doing this.


    Nick :)
  • Hi All,

    I had the same problem as described in this thread and followed moisamva's instructions on Windows 7. I am however using a work computer which does not allow changes to the registry. So I figured out another way to make the same changes to the registry which doesn't require so much technical knowledge. I wish I could simply post an attachment here, but unfortunately I'll just have to write out instructions to re-create what worked for me:

    1. Download the latest Codec.
    2. Extract it from the zip file.
    3. Double click camcodec.inf or drag it to notepad.
    4. Find the section that looks like this:


    HKLM,Software\Microsoft\Windows\CurrentVersion\Uninstall\camcodec,DisplayName,,"CamStudio Lossless Codec"
    HKLM,Software\Microsoft\Windows\CurrentVersion\Uninstall\camcodec,UninstallString,,"rundll.exe setupx.dll,InstallHinfSection DefaultUninstall 132 %12%\camcodec.inf"

    5. Add the following two lines:

    HKLM,SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc,"camcodec.dll",,"CamStudio lossless codec [CSCD]"
    HKLM,SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32,VIDC.CSCD,,"camcodec.dll"

    6. Save the file.
    7. Right click on the file, click 'Install'. If you've already done this (e.g. before reading this post), dont worry - you can do it any number of times.
    8. Start CamStudio. You should now see the Lossless codec listed.
  • In addition, I might note that I have done this using CamStudio version 2.6 **c** - a seemingly much more stable version of CamStudio available at


    To get this working with Windows 7, I also needed to download
    - msvcr100.dll 808 Kb
    - mfc100.dll 5.23 Mb

    I did this by downloading and installing the Visual C++ Redistributable:

    [choose which URL depending on your computer's architecture]
    (x86) http://www.microsoft.com/download/en/details.aspx?id=5555
    (x64) http://www.microsoft.com/download/en/details.aspx?id=14632

    Then I searched c:\windows for those file names and copied them into my CamStudio folder - and all works beautifully.

    I have tested this on both Windows XP (x86 architecture) and Windows 7 (x64 architecture).

    Hope this all helps.

  • Thank you, Nick and Andrew.

    Nick, I closed and re-opened CS before confirming the codec isn't there. It still isn't there. And I don't think I will try your suggested instructions due to my unfamiliarity to registries thing.

    Andrew, what is the notepad saved as at 6 of your instructions? No title is fine? Also where is it saved? So many questions to be answered for this newbie. Why do I need "Visual C++ Redistributable"?

    I'm not trying to be intentionally sternly difficult, but just don't want to mess up with my computer with possible risk factors around uninformed of. Is there a better workaround way without technical knowledge involved for newbies?
  • edited February 2012
    Hi TeaSipper,

    You should be editing a file, not creating it (see step 3) - so that should answer your questions on what name the file should be and where it should be located.

    Good question RE the Visual C++ Redistibutable - the only reason I mention this is that when I started up CamStudio verion 2.6c is that I received error messages telling me that those two DLLs were missing, hence a need to get them from somewhere.

    After following the steps in my first post - you could try running Recorder.exe and see if that works. If you receive the error message like I did (regarding one of those DLL files being missing) then you also will probably have to download and install the Visual C++ Redistibutable pack.
  • Thank you, Andrew. I did follow your instructions posted earlier. And sorry I mis-read your post and didn't actually think.

    A surprise is that after following your instructions, my CS has lossless codec 1.5 embedded though the one I downloaded and used in following the instructions was CS lossless codec 1.4!! Big smile on my face!

    Thank you very much, Andrew.
  • andrew_camstudio
    Thank you, your instruction is very helpful!
Sign In or Register to comment.