Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

How to get sound from the actual running programs (not from the microphone ect.)?

edited September 2012 in Common Tips & Tricks
I can't figure out one simple thing: how can I record not only video of what is happening on the screen but the audio as well?
I mean I want the sounds I hear from the computer to be present in the record.

How can I do this?

Comments

  • This is discussed in various places around the forum, but the primary issue comes down to whether you have Stereo Mix available on your computer -- or not. Many do not.

    I have videos on how to do it with Stereo Mix at my channel in the CamStudio playlist.

    https://www.youtube.com/playlist?list=PLA57A11C0D77BBF9B&feature=plcp

    If you do not have Stereo Mix, then the only way is to get audio from a line-out or speaker-out jack into a line-in or mic-in jack via an attenuating patch cord. Radio Shack sells one for a reasonable price: http://www.radioshack.com/product/index.jsp?productId=2103841

    Let me know if you need more help.

    Terry
  • edited September 2012
    Terry, thank you for the links.

    I've being found similar tutorials; your one is better than others, but there are still questions left.

    First of all. The thing that is most unclear for me.
    As I've already mentioned, I need NOTHING from microphone. Only the output which computer gives from the running program.
    Than why do I even have to deal with any setting related to microphone? I beleive, for some reason I actually do have; but from my (uneducated) point that seems unlogical.
    Looks like there is some crucial misunderstanding which many people have.

    Okay, that's just a remark.
    Let's go to the deal.

    I've looked into "Sounds and Audio Devices", I do have Stereo Mix in "Capture" section and I checked it in.

    I have two sound cards: Realtek, which is onboard, and Creative Sound Blaster, which I use solely for microphone (microphone port somewhy doesn't work in the onboard one so I had to insert a standalone one). I have the output sound (to the speakers) from Realtek.

    So, next I've chosen "Creative Sound Blaster" as a sound recording default device (which I damn still don't understand why I have to deal with).
    Then in CamStudio's "Audio Options for Microphone" I chose "Default Input Device" (I could've "Creative Sound Blaster PCI" explicitly as well) as well.

    I have "Record Audio from Microphone" option set.


    And it still doesn't work - no sound on the captured video :(

    I also tried to change default audio device in "Capturing" to "Realtek HD Digital Input" and to "Realtek HD Audio Input" but nothing helps.
  • edited October 2012
    Set it not to the default device, then, but to the Stereo Mix instead.

    BTW - although it SAYS "Record from Microphone" it really MEANS "Record from input sources" - wording is antiquated!

    You may not be able to route the Creative through Stereo Mix without doing some settings changes. Stereo Mix gets its sound from whatever the system considers the system speakers output to be (not necessarily what they really are), so you have to make certain something is plugged into those system speakers for it to work (speaker or headphones) on many systems, particularly RealTek, which employs auto-jack sensing.

    Select Stereo Mix explicitly in the drop-down list in the "Options for microphone" region.

    Terry
  • Terry, thank you alot. I finally made it work.

    The essential were two things:

    1. I tracked the exact port where the speakers were plugged to. It happened to be Realtek HD Audio Input (I used Realtek's audio software tool which shows plugged sound hardware).

    2. In Camstudio's Audio Settings for Microphone I explicitly chosen Realtek HD Audio Input (instead of default device) and pressed the Volume button.
    In the opened dialogue I unchecked Mute flag on Stereo Mix (that's the reason why I didn't have sound, I suppose; I additionally had to make settings for Stereo Mix visible in Options menu of the Recording Control dialogue.

    After that it started to work.
  • 1234ru,

    Well, that's certainly good news! Let me know if any other issues come up, and check the other recent threads - many are discussing some key issues.

    Terry
Sign In or Register to comment.