Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Need help with recording LPs

edited October 2013 in Support
I want to start doing my own let's play channel over at youtube but I have a few problems with Camstudio, firstly it's version 2.6B (Camstudio 2.6B) that I got a couple years ago. Main issue is after 10-15 minutes upon saving/stopping the recording Camstudio would crash/not save because there was a error with the sound clip so it canceled out, other issue it tends to lag and audio at a point would either go ahead or behind the video.

Atm the only 2 video options I use which are CamStudio Lossless Codex v1.5 with the sittings as follows.

"Quality is at 100% and Set Key Frames are at 200, Capture Frames are at 5 with Playback Rate at 200 and Auto Adjust is unchecked"

and another is the Xvid MPEG-4 Codec with the same exact settings only it won't work/record unless I set the Set Key Frames to 50 even the default player/recorder pop up won't work as it keeps repopping up. Atm I wanna start LPing a few Gameboy games VIA my PC which is Windows XP, also when I was testing a bit the online game lagged and the audio was messed up while it was recording so had to cancel and mess around a bit.

If anyone could help me out in getting Camstudios to record games OK I'll be grateful. Again wanna do LPs of video games/Roms so if anyone could help me get the right Codec/sittings that would be great, altho I can't pay for anything tho.

Comments

  • edited October 2013
    If you use any lossless codec, with audio, expect only about 7 minutes of recording time before the size limit kicks in and CamStudio crashes. (A file size limit of 2GB is a component of our still using the AVI-1 specification - moving up to AVI 2 ASAP).

    Xvid gives you much, much more time. Set Key Frames should not impact your recording AT ALL... so that is an odd thing to hear. I think personally that you are pushing the processor with CamStudio too hard and leaving little CPU left over for the game, but if it works...

    See this explanation of Capture Frames Every and Playback Rate as well as Key Frames if you want the technical background...

    http://screencasttutorial.org/18/best-settings-for-camstudio-to-sync-audio-and-video-28

    For Xvid or x264vfw, and several other modern codecs, you MUST keep the width and height both even-numbered values in pixels. Otherwise it will offer to use the "default compressor" (which has been Microsoft Video 1 for ages, but that is changing soon.) This usually means that using the Fixed Region setting is required. I always use either 1280x720 or 1920x1080 for the standard HD formats.

    For XP with Stereo Mix, this article covers engaging Stereo Mix. You can include your mic in the Stereo Mix in the Playback Devices section by enabling (checking) the microphone and setting its volume slider to pass it along to Stereo Mix.

    http://screencasttutorial.org/15/set-sound-from-stereo-mix-what-u-hear-in-camstudio-2-5-26

    Terry
  • To Terry:So does MCI record my voice through the speakers or whatever it uses to record the sound from the game I'm recording? Because I would like to record my voice as I play whether then after I recoord, live reactions and all and if I do blind LPs.

    Watching the second video now, the only mic I have is VIA my webcam as a mic I did have (a one ear set) went missing, so I can record my voice but need Audacity to record through my webcam's mic, so if there's a option to record my voice through the speakers alright if not I can use the record through mic option.

    Altho in the audio options for speakers SoundMAX Digital audio is the only sitting in the mic one it also has that but the option for the default input, also appears my sound Properties doesn't even have Stereo mix in it but I do have Audacity tho so that's good.
  • Yes, MCI gets whatever the system audio settings are set for. But to save space, I'd perhaps consider unchecking that, selecting PCM and 16-bit 44.1MHz MONO (give it a try at least...)

    If Stereo Mix or "What U Hear" or whatever your soundcard is calling it is engaged as the recording device, then you can go to playback devices and check the microphone to include it into the mix.

    Also, on some older XP machines, the "Record frm Speakers" still does work (though some service pack damaged it on most. We're trying to get that working again for a future release so you do not need to use the Stereo Mix.

    For now, most people have to use Stereo Mix with the "Record frm Microphone" option.

    If it has Audacity that's great, but it still needs to get the audio frm the system somehow, so see if it has something akin to Stereo Mix in there. And try the "Record frm Speakers" option just to try it out.

    Let me know if any of that works!

    Terry
  • To Terry:I do "not" have Stereo Mix I just told you that doesn't show up "SoundMAX Digital audio" is the only option there for the speaker option, the mic setting has a "default sound devise" option added but no Stereo Mix I don't think it's on my PC as I can't find it.
  • edited October 2013
    Yes, I know you just told me that. I meant see if the SoundMAX drivers included anything similar. If not, you are out of luck except to use an attenuating patch cord between the speaker or headphone-out jack and the mic or line in (I've only seen them in mono). Here's the one Radio Shack sells: http://www.radioshack.com/product/index.jsp?productId=2103841

    And here is a video on how to build your own:
  • To Terry:Ah OK, but that would take more time. XD I might try if I can't get it to work.
  • edited October 2013
    See if the "Options=>Record frm Speakers" option works. You never know - it might. Usually doesn't on modern machines, though. That tech depended upon a "hook" into the system that most computers no longer support.

    Terry
  • To Terry:OK but when I try testing the game's sound (as Camstudio is running) is well, sounds like it's being played slowly and skipping a bit it's not even music like that, any idea how to fix that issue? On my sound settings I have the Wave, SW Synth, CD Player, Mic, and Line In at 100% are they affecting how Camstudio records the sound?
  • edited October 2013
    Those are the output settings. Go into the Options/Properties in your audio settings and see what you have in there. Get there from the audio control panel tab. On XP, <i>similar</i> to this video (start at 1 minute 5 seconds, except you'll want your microphone un-muted rather than line-in as I show in the video):
  • edited October 2013
    Also, if you are pushing CamStudio really, really hard with capture frames every at 5 and playback rate at 200, then you are probably leaving no CPU power left over for the game. Try lowering it to CFE of 10 and PBR of 100, or CFE of 20 and PBR of 50. If the game is what is stuttering, this might help cure that problem.
  • To Terry:My mic is never muted I have all unmuted and the bar at the top, also mine is called vol control not master control if you I can email screenshots of it. I'm all fine with getting the sound with Audacity and adding it in Vegas (I have Vegas pro 9 so editing the sound/my voice to the recording isn't a issue as I know a quick to it).
Sign In or Register to comment.