This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

"CamStudio could not record the AVI file using the current compressor. Use default compressor?"

edited July 2012 in Support
I get this using Xvid. It doesn't always happen. If I screw with the quality slider, eventually It will record. I did notice this happening after I installed the DIvx package. I wouldn't think Divx would be a problem, however. Any ideas what this might be and how to fix it?


  • This usually come as a result of the width and height not being even numbered values. An odd-numbered width or height will not work. Divx actually requires a width that is divisible by 4, in fact. Xvid only wants them both divisible by 2.

    I use Region/Fixed Region to ensure my size is right.

  • Well, that was it. I'm glad it was an easy fix. Which makes sense for both because Divx was doing the same thing. So I'll be using the Fixed Region from now on. Thank you, I appreciate the help.
  • pfcande,

    Good to hear!

  • I've had the same problem while trying to use the jawror xvid 720 that you recommended Terry.

    It looks like the /2 does indeed solve it
  • Mike5,

    Yes indeed! :-)

  • I use x264vfw and fixed region size 640x360. The message appears after about 1h30 of recording. What should I do?

    Sorry for the spelling, i'm French.
  • redsix,

    How strange for it not to happen until 1hr30 into the recording!

    I've never seen that before... usually this is due to the mismatch of the codec with the dimensions, and appears right away.

    Can you try Xvid and see if it happens with that one as well?

    Another thing to try might be trying an 854x480 or 856x480 recording to see if it still happens, in case it is trying to do too small a size for the internal profile settings.

  • Terry,

    I tried with a size of 854x480, 856x480 and Jawor's Xvid. I have the same result.
  • With the compressor Microsoft Video 1, I have no problem.
  • Just a couple thoughts....

    Using MV-1 at 640 x 360, you should get no more than 13 minutes of recording before you hit the limit, so there’s really no way to do a direct comparison. You can get approx. 2 HR 20 Min at 640 x 360 using x264, assuming you’re using single pass CRF with a quality setting of about 12 (set on the codec UI and NOT Cam’s), and since you’re having a problem long before that, there’s something else going on.

    I’d try doing a test at full screen, making sure that the output is set to AVI, without conversion.

  • redsix,

    The problem I'm having is that I have no precedent for this behavior. This being the first time I've ever heard of such a problem occurring forces me to consider the possibility that it is an isolated incident having to do with something else running on that computer.

    This is especially true considering that both Xvid and x.264vfw are doing the same thing - they are quite independent projects, though their aims are similar and based on the MPEG-4 standards.

    I'm stumped!

    As Ken pointed out, the MS video 1 codec would not allow an hour and a half, so it may not be a fair comparison. The two gigabyte file size limit would be reached far before then using that codec.

    You can try the optimizations discussed in this article (though specifically about preparing for the challenges of streaming video, the principles apply to recording as well.)

    If all is a wipe, try the OBS software perhaps. It can do good screen recordings and is easy to use - and streams as well. It is written to withstand the rigors of recording games. There are videos mentioned on the page on using it, and my channel has several "get started" videos specifically about using it to record.

    CamStudio is much easier to use when you can get it working, but we may be up against an insurmountable issue here, and I do not mind sharing with you the OBS solution. (It is entirely free and open-source as well.)

  • Terry,

    Yes, with MS video 1 I can not record 1h30 but I have no the error message.
    I'll try OBS.

    Thank you.
  • With OBS, I can not stop recording automatically. I prefer camstudio. I'm sad.
  • edited July 2014
    I'm completely boggled by this. You only have the error message after 1hr:30m, with either codec, using the auto-stop feature. How many seconds have you set it to record? (I'm wondering if it is in the timer code that the number is too high...)
  • edited July 2014
    I made several tests and every time the error message appears at 1h24 of recording with or without auto-stop feature. In Video Option, I set the quality at 100 and gauge Time Lapse at all at right. I have not changed the configuration of compressors.
  • I'm notifying Nick to ask the programmers to look for some code that might be kicking in. The error message, as I said before, normally appears immediately upon starting the recording due to the width and height not being even numbers. For it to appear at the 1hr24m mark makes me think it is an error firing the wrong error message!

    That this happens with the older version as well shows it might be something hanging around since the big rewrite was done. Perhaps use the legacy version 2.0 or 2.6 r 294 (that last one may have the one-pixel-over bug in the fixed region, where you'd need to purposely put in the even dimension you desire minus one for it to work...)
Sign In or Register to comment.