This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

CamStudio 2.7.2 r326 Is Now Available To Download

edited October 2013 in Announcements
You can now download CamStudio 2.7 from the CamStudio homepage.

Please refer to this forum post for more information on the bugfixes and new features as well as CamStudio's future.


Nick :)


  • Another Milestone! :-)

  • Hi is this CamStudio 2.7 download okay for windows 7
  • edited June 2016
    Yes, gravillep. It is working fine on my Win7 64-bit windows. But the web-installer seems to be having problems. Get it here in the meantime till we fix this:

    [URL removed due to unintentional Google Chrome red screen - CS download on the homepage working]

  • @gravillep - we're aware of the issue and we're on the case.


    Nick :)
  • Thank you Terry this new zip works okay from my Drive C:\The installer seems to stop at 93% compleated for some reason on the first exe
  • ...i attempted to download the "CamStudioCodec_1.5_Setup.exe" and the anti-virus program used here indicated: "There is strong evidence that this file is untrustworthy" ...the anti-virus program used here is "Symantec" and the warning also indicated: "Symantec has known about this file approximately 1 month" and is being listed in their category as "Malware"... so, what's the story? is what "Symantec" is indicating true? is there a "zip" file of this file available? has anyone else experienced this problem in downloading the file? thanks in advance for your reply and info...
  • That Babylon Toolbar could be doing it not sure I have had problems with it before.
  • The Zip file I got from Terry is working brilliently though seems a lot of the bugs are gone with this 2.7 Version love it :-)
  • @ScootCoot1948, that's got to be a false positive as VirusTotal only shows 2 out of 46 AVs detecting it.

    But thanks for letting me know - I will follow up with that and get it fixed.


  • Hi,
    The web installer hangs at 93% as mentioned in a previous comments. I would like to suggest to add the link to the zip file in the download section. I don't see the need of looking into a forum if this a bug. Thanks.
  • @anahuacv The installer is being worked on as I type as not everyone is experiencing errors but it's possible it's linked to a 2nd run of the installer.

    Did the installer freeze the first time you tried to install 2.7 or had you done an install before?

    Also what Windows OS are you using, your internet connection and country location?


  • I experienced this. First time web installation went OK. The app worked OK except that I wasn't recording audio. After a few recordings the app stopped responding and subsequent invocations got me nothing. I uninstalled and a few files were left behind. When I attempted to delete them manually I was refused since they were still in use. A reboot later I was able to manually remove them. All subsequent attempts to use the web installer hung at 93%.

    I installed the zip but it took several reinstalls before the recorder would run; player and producer would run but not recorder. Unzipping a few more times into different locations eventually I got recorder to run.

    Now I'm back to not being able to record audio. My mic works just fine; I used it for recording in other apps. The settings under Options->Audio are correct.
    Any known gotchas?

    thx, --emk
  • Forgot to mention my environment: Win7; RealTek High Def Audio devices; Comcast cable; USA Pacific.
  • Hi Guys

    We think the 93% installer bug has been fixed. Please redownload and install and let me know if there are any issues.

    Thanks for your patience.

    Nick :)
  • That install went well and recorder and player both work. Here's hoping it continues to work.

    Any clues or pointers about the audio issue I asked about above?

    thx, --emk
  • @emk Can you create a new thread in Support and give as much information as possible about exactly what the issue was, your Audio Settings, etc.


    Nick :)
  • tkrtkr
    edited February 2013
    Still have problems with installing file from CamStudio
  • As of 2:30 PM Central Time the installer stalled at 93%. Terry's download worked just fine. I am running Windows 7 64bit.
  • edited June 2016
    @tkr are you downloading this file:

    [URL removed due to unintentional Google Chrome red screen - CS download on the homepage working]

    You might need to CTRL+F5 the CamStudio homepage to make sure the link is correct, or indeed use the link above!

    Post how you get on ... at least 4 people have contacted me saying this installer works


    Nick :)
  • Nick,

    The installer worked for me this time, and was fast! Oddly the previous, broken one was only 621 kb in size, while this working one is 1.1 mb. So, the prior one may have been a corrupted/incomplete upload to the server.

  • Still working on the RealTek audio issue. (@nickthegeek: By "Support" do you mean the 2.6 Beta Support forum?) Turns out RealTek is a known issue with some posted workarounds.

    However, I'm back to my original, original problem which preceded even the 93% installer problem, which is that after recording a few times, recording quits working. I've rebooted this time rather than attempting an uninstall/reinstall and recording still doesn't work. No flashing region corners; no file to save when I press Stop.

    Is this a known issue? Any clues?

    Win 7.

    thx, --emk
  • Also help doesn't work for me. I get 4 tabs opened in Chrome like this:
    Obviously a URL parsing (or lack of protection against parsing) problem...
    Win 7; Chrome.

  • edited February 2013
    This is not a known issue. Definitely uninstall and reboot before re-installing. You may want to remove any profile or .ini files in the hidden folder at Users/(username)/AppData/Roaming directory.

    and CamStudio.cfg if present, then restart and re-install.

    Make hidden folders visible frm the top left of any folder view from the Organize dropdown, selecting "Folder and Search Options" and then the View tab, selecting "Show Hidden Files" frm the Hidden Files and Folders section.

  • Follow up:
    (1) It appears that I have to run CamStudio as administrator (Win7)
    (2) Settings for RealTek HD Audio: (Brendan Sept 2011)

    All good for now. thx, --emk
  • @emk Glad you got it sorted.


    Nick :)
  • Hello all. We have an issue where we need a stand-alone installer on a computer that is not and cannot connect to the internet (government stand-alone system). I downloaded the zip package from above but got some errors about files not being installed? If anyone could offer assistance, it would be greatly appreciated. Thank you!

  • edited February 2013
    @itbedave Do you have either the 32-bit or 64-bit Visual C++ 2010 Redistributable from Microsoft installed on your system?

    If not, that could be causing the error. (32-bit) (64-bit)

    If you don't have direct access to the Internet to do download them, speak with your IT department and they should supply it to you as all MS stuff is normally OKed.


    Nick :)
  • No - but are you saying we NEED it? Or having it installed might cause problems? Thanks!
  • From what I've gathered, you NEED the 32-bit version for CamStudio to work.

Sign In or Register to comment.