This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Visuals don't get recorded but audio does.

edited May 2009 in General Discussion
First off, I am NOT re-recording a video. I'm just trying to record my screen.

All the .avis are giving me a black screen in Windows Media Player, and when I play them in Winamp, no video dock appears (when a video file is played in winamp, a separate video window pops up), and similarly when I use VLC, no video appears. By default, VLC's interface is a 360 x 140 window. When an audio file is played, it stays at that size. When a video file is played, it expands to fit the resolution of the video. When I play CamStudio's videos, VLC stays at its default audio playing size.

This makes it seem like the .avis don't even have the video attribute/encoding or something. If the .avi WERE a VIDEO file, a video dock would have appeared in Winamp and VLC would have expanded its size, EVEN if what was recorded was a black canvas.

I am using Vista 32bit, and an integrated graphics processor. The advanced settings button that should let me turn off Hardware Acceleration is GRAYED OUT, so I can't access that, so I'm not sure if my problem has anything to do with Hardware Acceleration (I did some googling and saw a couple mentions on that).

I converted one of the .avis to flash, .swf shows both visuals and audio but the video is crappy, and swf.html doesn't display anything. The new .avi that resulted from the conversion is just like every other .avi that CamStudio has generated for me. The .swf is probably crappy because the .avi I converted was recorded on a 1024 x 700 area, I have a feeling it gets better on a smaller area. But I don't use .swf anyway, I'm only interested in the .avi, which doesn't work for me regardless of how small the recording area is.

I know there's another discussion out there with this same problem, but there has been no help given. I think the problem lies with my machine, but I'm too tech-challenged to know what the problem is, and I'm really hoping someone more knowledgeable in this area can help me out!

I've tried HyperCam as well with EXACTLY the SAME problem. The help at HyperCam is no use for this problem at all. The help team seems to think that this problem can ONLY arise when users try to re-record another video (which HyperCam does not support). Already 3 people have posted in their forum with this problem and the universal response from the help team was to automatically ASSUME that the users are doing something out of their control, and direct them to the FAQs under "re-recording another video", and then they can wash their hands clean of the problem and pretend they've done their best to help. =(


  • Hi there

    You should only need to disable Hardware Acceleration if you're trying to record a video player in another Win32 player, like WMP or VLC or possible if you're using a lower spec machine to record videos.

    (Incidentally, you should look into whether you're using the most up-to-date versions of your graphic card driver or whether it's just the one that came with Vista)

    CamStudio doesn't run "natively" on Vista which *can* cause this "black screen" error.

    Try right clicking each EXE and select:

    Properties > Compatibility > Windows XP SP2

    Also tick the 'Disable Display Scaling At High DPI Settings' checkbox

    Then click Apply > OK

    Let me know how you get on.


    Nick :o)
  • Hey, thanks for the reply! =)

    I did what you said but still the same thing in WMP, Winamp, and VLC :(

    Could it be my graphics card not being a dedicated one? It's a "Mobile Intel(R) 965 Express Chipset Family" and the driver is up to date. Sigh. I hate that my laptop has an integrated graphics "card"!! I can't play games properly either =(.
Sign In or Register to comment.