Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

CamStudio 2.7 Bug Reports and Installer Issues

edited February 2013 in Support
Please post 2.7 bug reports and installer issues here!



  • edited February 2013
    The installer is currently providing no way to opt-out of piggybacked software. The linked image [1] shows a page of the installation wizard asking for permission to install FantasiGames. Fantasti Games does unwanted things to the end-user's computer such as overriding the web browser's default search provider. I have not clicked the 'Next' button, as I do not trust that the software will remove cleanly.

    The EULA for FantasiGames grants itself permission to install other 3rd party advertising software, collect user data including personally identifying information (Privacy notice, section 2, bullet 3), and change terms at any time.

    Internet Explorer's smartscreen filter is currently advising users not to run CamStudio's installer because of malicious software. [2]

    [1]: http://i.imgur.com/hPLbU8T.png
    [2]: http://i.imgur.com/wtsMDvE.png
  • What you missed is that the custom installation allows the un-checking of both check boxes, which effectively installs CamStudio alone. We sure got a bunch of doozies with this advertiser - FantasiGames, Delta Search - ugh!!! This could not be worse.

    (Check your inbox here also.)

    That is VERY bad news that the smart-screen filter is nixing this software. So is some other anti-virus, identifying it as Adware and refusing to install it. (post below)

  • Selecting "custom installation" and unchecking both boxes looks to me like it would still install FantasiGames.
  • That is not how it reads to me at all. Checking asks to set and keep, un-checking consequently asks it not to.

  • Unchecking those boxes does not result in any prompt to opt-out of the installation on my computer.
  • avira anti-virus scans the installer after downloading and states it has adware/installcore.gen
    sorry but things like that i delete straight away, the only other option is to dl the rar file that is provided in the other thread which works file.

    sorry Terry if the adware is intentional but i don't think your doing yourself ant favours with it
  • edited February 2013

    Un-checking the boxes is the opt-out itself. It then goes on to install only CamStudio. There is no further prompt - the check boxes are all there is, so un-check them and you should be fine.


    As per Nick's post on the future of CamStudio,


    we added an advertising supported installer in order to raise funds to pay for programmers to fix the remaining bugs and then add features (like AVI-2 spec compliance to overcome the 2-gigabyte file size limitation). Donations have been very thin, so this was a way to speed up the development to make the program better for everyone.

    See here if you absolutely do not want to use that installer:


  • edited February 2013
    Denied by SmartScreen Filter...picture says it all...

    Also Producer Help may be missing, as it wasn't in the Zip alternative.

    Sorry to see the damage to your rep.
  • I downloaded the software last night and it worked perfectly. Clicked on it this morning and it started redownloading again, then half way through the download said theres a problem deleting a file, searched for said file but its non existant, what should I do?
  • I'm not clear what you are meaning - do you mean it installed on one machine fine, but when you tried to install it on a different machine using a copy of the installer it stalled?

    You should not be needing to install it twice on the same machine, of course. There is a program icon in the CamStudio 2.7 folder that should have been added automatically to your programs list from the Start button/All programs area.

  • Only 2 piggyback software packages have been offered to me. The dealply offering does allow an opt-out, but the FantasiGames offering does not. Unchecking one box implies that the user's home page will be left alone, and unchecking the other implies that the default search provider will be left alone. Regardless of those checkboxes' status, there is a statement reading, "By clicking "Next" you agree to the License Agreement".
  • I stand corrected, then! Thank you, Kitir, for bringing this to our attention. I'll notify Nick of this at once, as he is the one dealing with the advert-supplier.

  • @Kitir every application offered should have an opt-out function, can you email me privately at support @ camstudio . org and I will try to get this sorted out. Also let me know your country and I will try to duplicate your results.


    Nick :)

  • edited February 2013
    @MrGadget, yeah I've confirmed that.

    Thanks for bringing it to our attention, I'm on it.


    Nick :)
  • When I download the 2.7 download from the site and select "Run" nothing happens after that. I have unblocked it and even ran it as Administrator. When I click on the download and select RUN nothing happens after that. I am on Windows 7 and am using the XPS Dell Laptop. Can anyone assist me?
  • H2K,

    Did you delete your original download and try to download it again? Sounds like the download was corrupted somehow. Check your inbox here.

  • hi all, i have a problem with the installation... i downloaded the installer, it start as normal and i uncheck the delta toolbar. after i press next and it appear the page with the grey progress bar moving... it stuck there forever doing nothing... it is a know error? thanks for the help... i'm running win7 x86 and i execute as admin as well...
  • tondo,

    It sounds like you received an older version of the installer, possibly because the old link that was on the CamStudio.org page was still in your cache. Empty the cache and try again, or get the file from my website for the time being:


    We have dropped the advert-supported installer for now, and are looking for better methods to do something similar that works smoothly and does not trigger adware alerts on some browsers and antivirus programs. (nor get stuck like you have!)

  • DelDel
    edited February 2013
    Windows Vista. Downloaded latest version today: CamStudio_2.7_r316_setup.exe and CamStudioCodec_1.5_Setup.exe.

    During program install all seems fine until the last step of the install when I elect to launch the program which generates error:

    "Recorder.exe - Unable to Locate Component: This application has failed to start because mfc100.dll was not found. Re-installing the application may fix this problem."

    I un-installed the program and then again downloaded the file but same result.
  • edited February 2013
    You likely need this
    Older computers had the 2008 version of this file installed. You need the 2010 version for 2.7 as it was compiled using Visual Studio 2010.

  • Wanted to install CamStudio2.7r316.exe on Win7, unchecked the 3rd party apps, but the installer froze. So I tested including the 3rd party apps, installer went through the process completely. Unfortunately though, one of the 3rd party apps, going by name BrowserProtect.exe, is detected as Virus/Malware by Trend Micro (TROJ_SPNR.0BBC13). I would urge you to stop using that 3rd party crap in your install routines. It seems you really don't know what you could cause to other people with that.
  • edited February 2013
    You have our oldest download of the program there. We have removed the advertising stuff entirely. It was definitely a mistake to go with the company who approached us, as you'll see several posts here of folks having problems like this.

    We still want to earn some advertiser-supported installer revenues so we can pay programmers to make CamStudio better, as donations have fallen off sharply. If you know of any reputable companies who offer such an installer we'd sure be happy to hear about them!

    Here is the most reliable place to get CamStudio from:


    Here is the current download link:


  • When running this new version in a VMware Windows XP environment I lose the ability to double-click open files/folders after I have pressed the record button. Closing CamStudio returns the ability for me to double-click open files again. Just opening CamStudio won't cause this problem, its not until I hit record. This was not an issue I had previously with 2.6b.
  • Glad you guys removed the troublesome adware! I just got the app yesterday and it seems to be working fine so far. HOWEVER, I am new to this sort of thing, and I noticed that the Help link on the app's Help menu window doesn't work--I get 4 things, in this order:
    (1) this error message: "This webpage is not found / No webpage was found for the web address: file:///C:/Program / Error 6 (net::ERR_FILE_NOT_FOUND): The file or directory could not be found."
    Followed by (2) a couple of "Oops" messages from Chrome, and (3) an apparent effort to load something unloadable--tries to open something and can't get there, resulting in (4) "No data received / Unable to load the webpage because the server sent no data.
    Here are some suggestions: • Reload this webpage later.
    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data."

    What is going on? Should the help file have downloaded and if it didn't, how can I get it?
    Do you have any kind of user guide? Or just the FAQs?

  • Here is a video explaining how to move the files from a 2.0 download into 2.6 or 2.7.

  • can anyone help me. my minecraft controls mess up when i have it and camstudio up
  • On Feb 18, TerryBritton wrote:

    You likely need this
    Older computers had the 2008 version of this file installed. You need the 2010 version for 2.7 as it was compiled using Visual Studio 2010.

    Hi Terry
    Downloaded the file but it didn't solve the mfc100.dll error. Still giving the same error prompt. However, managed to fix the error using some 3rd Party app DLLFixer or something like that (can't really recall). Works fine now.
  • haizal,

    That's interesting! Perhaps your file was replaced by an older version, or de-registered somehow.

    Anyway, glad to hear you've got it up and working!

  • edited March 2013
    Terry, I see this folder in my program files under CamStudio 2.7, called help.chm: (mk:@MSITStore:C:\Program%20Files%20(x86)\CamStudio%202.7\help.chm::/) - but it still doesn't show up on the Help menu. I watched the video on moving help files from 2.0 to 2.7, but since I don't have 2.0 and those are in folders, it didn't help in my situation. Got other ideas for connecting it to Help?
Sign In or Register to comment.