This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Divx doesnt show in compressors

edited May 2009 in Support
When i installed divx codec, it doesnt show in my compressor options. It finds everything else but that. PLz help me & get back to me on this. Thx


  • If you're using CamStudio 2.0, try reinstalling it.

    If that doesn't work or you're using 2.5b, shut down CamStudio, rename all the INI files to INI.OLD and then restart it so it has to recreate them all from scratch.

    Does the codec appear now?


    Nick :o)
  • I'm having the same issue. The Divx codec does not appear in my Compressor options.
  • Must of had a temporary lapse of sanity...

    I reinstalled Divix, but just the Codec and all systems go.. So if anyone else encounters this issue try installing just the Codec and disabling the other list box options when you install.
  • edited May 2009
    reinstalled it, doesnt work, changed the ini file, still doesnt work. Is it because i'm using divx 7?
  • It shouldn't make a difference.

    The only other thing I can think of is to install another codec and reboot in the hopes that it will force a "refresh" of the codec list.

    Also, have you tried downloading the 2.5b to see if that is able to see DivX? You don't need to install that, just extract and execute.


    Nick :o)
  • I am having this problem too and it is driving me nuts.

    I have tried the following without success:
    - reinstalling CamStudio 2.0
    - running CamStudio 2.5 (from a separate folder)
    - Shutting down Camstudio and renaming all the ini files, then restarting.
    - Reinstalling Divx with just the codec and the other options deselected
    - Reinstalling Camstudio
    - (rebooting various times in between)

    None of these things made the DivX codec appear in the Compressor list.

    I am using the free version of DivX on a brand new clean installation of Windows XP Pro.

    Am I missing something obvious here?
  • I installed XviD hoping that it will force refresh codec list. XviD shows up but HuffYUV still don't. I tried a fresh 2.5 b 1 from a different location.
  • I also tried this:
    - 2.2.0 installed
    - 2.2.0 listed OK in CamStudio
    - 2.2.0 dll in syswow64 and system32 replaced by 2.1.1 dll
    - the huffyuv disappeared from CamStudio list

    I use Windows 7 x64.
  • edited January 2011
    If you have your screen resolution in 16-bit color, DivX will not show in the list (because DivX requires 24-bit or 32-bit color). The same effect happens with other codecs that require 32-bit screen color. See below.

    Don't forget that DivX also requires your region dimensions height must be divisible by 2 and width must be divisible by 4. There are other codecs that require those be divisible by 2.

    From my post at :

    Some Codec-specific observations

    ffdshow requires very specific sizes to work. Width must be a multiple of 2. Height must be a multiple of 2. Any color setting works (16-bit, 24-bit, 32-bit)

    DivX needs to be in 24-bit or 32-bit color mode, so you’ll never get great speed out of that one. If possible, go for 24-bit (32-bit only includes the 8-bit transparency channel, which is not useful for most screen recordings. See "Best Color Depth? 16-Bit Color Vs. 32-Bit Color Explained!" at ) Width must be a multiple of 4, height must be a multiple of 2.

    CamStudio Lossless needs even numbered dimensions for uploading to YouTube, otherwise skewing occurs. (Likely taking place during YouTube’s codec conversions). There are also some even-numbered dimensions that YouTube dislikes. Works with 16-bit, 24-bit and 32-bit color.

    In VirtualDub, Xvid says “No Known Restrictions”, but I’ll bet you need to be even-numbered dimensions like with CamStudio Lossless for successful upload to YouTube. (Not tested yet)

    Microsoft Video 1 – no known restrictions, but huge file sizes even at lower “quality” slider settings.
    BTW – the “quality” slider only works with codecs that do “lossy” compression. It does nothing with lossless compressor codecs like CamStudio Lossless (or so I’ve heard…)
    There are others, but I’ve never seen them mentioned around here, nor do I know whether they work with YouTube:
    Huffyuv – 24-bit color only
    Intel Indeo Video R3.2 – Valid Depths: 16-bit and 24-bit
    LEAD MCMP/MJPEG codec (VFW) – Valid Depths: 24-bit
    Cinepak Codec by Radius – No known restrictions
    New Soft H.263 Codec – Valid Depths: 24-bit
    VP70 General Profile – Valid Depths – 24-bit and 32-bit
    MSU Lossless – no known restrictions, but no longer works with YouTube (amazing lossless compression, though!)

    “Sizer” is the best tool for setting up window sizes when using the 2.6 beta’s Region==>Window setting.
    I have it load at startup now (choice available during installation), as I use it several times a day, it is so darn handy!

    (Frustratingly, it doesn’t work with Google’s Chrome browser window, though it does show you what size you are re-sizing that window to when you drag the lower-left corner out…)

    Keep in mind that if you are using CamStudio 2.5 beta (for the Region==>Window selection) or early builds of 2.6beta, there is a persistent off-by-one-pixel issue that wanders among the various region settings - adjust accordingly after testing to see if you have that issue. If you have one of these versions, 2.5b for instance, you must set the window size one pixel less than the desired setting. Similar fixes for the other issues in other versions. The latest build has this issue repaired.

  • I have tried both versions of camstudio and the xvid codec still isn't showing up. I've essentially tried everything danm did with no luck, an addition to having my color setting to true (32 bit), and I even tried adjusting for the one pixel off issue, which did not solve the problem.
  • Sorry, Yashendwirh - it is working just about everywhere else.

    What operating system are you using?

    Also, see this thread I just posted a minute ago.

Sign In or Register to comment.