This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

CamStudio 2GB AVI limit: how to fix it?

edited December 2013 in Support
Hi. I have a problem with an AVI of 2.3 GB; i already searched on the forum but i haven't found the solution.

If i open the video with Media Player i can listen the audio but i can't see the video.
If i open the video with VirtualDub, it shows: Invalid AVI file: LIST chunk <4 bytes.
If i open the video with VirtualDub doing "ask for extended options atfer this dialog", and then i tick the first two, it shows: AVI Import Filter error: error (?) (800440c7).
I have tried also with Media Coder and other programs like that i've read about on this forum, but nothing works.
I tried too with FFmpeg on ubuntu but no solution.

Do you know a way to fix this problem or i've to delete the file?
Thank you

ps. sorry for my bad english


  • edited December 2013
    I've used the extended options for VirtualDub as shown in this video (jump to 6:24):

    Check only the first box for the initial run.
    If that does not work, try checking the one to its right, and perhaps the 2nd box.

    It sometimes doesn't work... When it doesn't I hang onto the file hoping to find a solution someday, but I haven't yet!

    Here is another video (with great music!) that shows how another user did it:
  • Thanks for you reply.
    I've tried both but i can't import the video in VirtualDub: if i check the first one of extended option i still get: Invalid AVI file: LIST chunk <4 bytes.
    If i select only the 2nd one i still get: AVI Import Filter error: error (?) (800440c7).

    The same for the second video, i can't import the video in VirtualDub. Can you help me?

    Thank you
  • That is all I know concerning fixing broken videos. I've heard of people having better luck with MediaCoder, but you tried that already and said it did not work on this one.

    Anyone else with some help here?

  • edited December 2013
    Just remembered I had another person post with a new fix I haven't tried yet.

    Also see this post to fix things VirtualDub cannot, using FFMPEG:

  • already tried with did not work. i get some errors
Sign In or Register to comment.