This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

CS crashes when exporting to MP4 format, and my cursor looks weird

edited January 2014 in Support
I just downloaded CS a few days ago and have been playing with it for a few days. I have been able to make it work, but have a few issues I can't work out. Fair warning: I am not a super techie with this kind of thing, so bear with me if I don't provide everything necessary the first time, or ask a silly question.

First, whenever I try to record a video and export to the MP4 format, CS crashes at around the 95-97% mark during the export process. The file actually appears in my export folder, but it is all black. It plays (the play bar at the bottom progresses through the length the video was), but the screen is black. I have been able to record in the AVI format just fine, and then convert the file using a converter, but that's just one extra, and annoying step. Any thoughts?

Also, regardless of the file format I choose, my cursor always looks odd (see the black marks on it here? I haven't changed ANY of the cursor settings, or added any enhancements to the way the program installs. This is just the way it appears. Have you seen this before? Any fixes?

Here are the stats of my computer I can think to post. If you need more to diagnose the issue, just let me know:

- Version of CS - 2.7.2 build on mercurial release r326
- Windows 7 - 64 bit
- i7-3615QM Processor @ 2.30 GHz
- 8 GB memory
- The codec I downloaded was on xvid's website ( CS lists it as "Xvid MPEG-4 Codec" on the video options screen, though I've had the same experience using the Microsoft 1 codec that comes with CS
- Video options are set to capture frames every 2 milliseconds, and playback at 500 frames/second with the auto adjust and lock capture and playback rates boxes checked
- Xvid settings are set to "Xvid HD 1080", with single pass encoding. Target equalizer is set to 1.00 and the quality preset is set to "General Purpose"
- Recording region is set to "Window"
- I am recording audio on my microphone



  • First, try "realtime" in the quality preset, and uncheck "B-VOP's" in the "more" box next to the profile settings window. You could try changing the quantization type to MPEG also from the default H.263 while you're in there. Those steps are supposed to help a bunch with high-motion recordings, but I don't know if it will affect your mouse cursor. I've only ever heard of this happening once before.

    The MP4 converter may still be having issues. It actually is just running an AVI recording through ffmpeg automatically, so...

    I don't know why you'd get a black screen from it, though, when the same region does fine in an AVI. You're doing a 1080p region, so it should not balk at that other than to tax your resources a bit. Does it give you any grief with a 720p recording?

  • Ok Ran a test video at 720p Still crashed CS when exporting to MP4. The black screen I was talking about appears in the MP4 file that appears in the folder even if the exporter fails, so my guess is that it's an incomplete file, somehow.

    I also tried the setting changes you recommended, and none of them fixed the way my cursor looks, along with a few different combination of those settings. I thought it might be due to a setting I have that puts a shadow under the arrow, so I turned it off on my Control Panel, but there was no change.

  • By the way, my apologies for posting this in the Announcements section. I meant to throw it in the support area...
  • edited January 2014

    Here is an article I posted on my site on optimizing for video. The first few steps alone may fix your cursor. It might be Aero alone doing it. (In fact, this article should be posted in the sticky topics up top!)

    Yes, anything you find in that temp folder is an incomplete file. It can be retrieved by VirtualDub sometimes - see this video on that:

  • I have had a similar problem. I record a movie (using v2.7) and when I stop, it starts converting and immeditately pops up a message saying "Failed to start MP4 Converter" - but continues converting until it reaches 95-96% complete and never finishes. If I OK the pop-up, it stops converting immediately and the AVI disappears; if I wait till it gets stuck at 95-96%, and copy the AVI before clicking OK, I get a usable copy of the AVI before it disappears. However, whilst the AVI plays in Windows Media Player, it does not play in Player.exe (which just says it can't play it) or PlayerPlus.exe (which shows a black rectangle of the appropriate size for the appropriate duration). Unsurprisingly, I also can't convert the AVI to FLV. I've only tried the Xvid and Microsoft Video 1 codecs, but they both have the same result. (I can post more details of configuration if that helps, but playing on Windows Media Player would seem to confirm that it can record using my settings.)

  • Not so sure that capturing the AVI at 2/500 is a reliable way to archive a video file. One simple test would be to leave as an AVI and try uploading to Youtube to see if their MP4/FLV converter can handle it. I have my doubts.

Sign In or Register to comment.