This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

General Recording Issues

edited March 2014 in Support
EDIT: Changed instances to 'frm' per an earlier post.
So, I managed to install CamStudio. I am able to record video. I am unable to capture audio frm any source... Speakers, headset speaker, laptop mic, headset mic, nothing. My goal is to have the mic audio and program audio record simultaneously... the end result is that I would record Let's Play videos using this software. How do I best accomplish this?

In the meantime, I have had some very erratic results in attempting to record testfiles for audio checks... Changing precisely no video encoding settings of any kind in the process, I have recorded three videos... The first was 900MB for just under 2 minutes of mute video. The second was 1.2 GB for 90 seconds. The third was 23.4 MB for 60 seconds (and choppy as hell). I have no explanation that I can offer for these wildly different results, since as I mentioned, nothing changed with the video codec. The only change between the second and third recording was that I switched the "record audio frm" checkmark option frm mic to speakers (which gave me a WaveoutGetSelectControl() error dialog box), and also failed to record any kind of sound at all.


  • ...okay, so... it's been two weeks, and I haven't seen any response not only to this post, but to any post in that time. Is anyone still here?
  • Some good starting points can be found in Terry’s video found in this thread:

    There are other usable codec and settings options, but I think you need to get Cam functioning at some level before exploring these.

  • Yeah, I saw that. The video recommends switching to the Xvid codec in the Compressor bracket of the Video options. I'd be more than happy to do that if the Xvid codec was an option I could select. All I have are MS Video 1, two copies of Intel IYUV Codec, something called Cinepac, and CamStudio Lossless 1.5. I have used the installer for the 64-bit version of that, I have installed K-Lite... nothing makes this option appear. What have I missed?
  • With your version of CamStudio, you need to have properly registered 32 bit codecs on your computer to have them show up on your dropdown list. Here are links to MPEG-4 and x264 codecs mentioned in another thread:

    The first one (MPEG-4) can be used with the settings mentioned in Terry’s tutorial, and the second is 264, which seems to be quite tolerant of a 25/40 setting in Cam, assuming you’re just trying to wind up with a playable raw AVI.

  • edited April 2014
    Okay... got the video codec installed. Now, instead of recording video and no audio, I record a black screen and no audio. On three separate tests I got the same result.

    As a secondary issue, I have installed Voicemeeter, and when I switch to it or to any other device in the Audio Options for Microphone, click OK, and then return to view the settings to ensure they kept, it always reverts to Default Input Device.

    EDIT: Didn't realize the playback function in CamStudio was just giving me a black image. THe actual AVIs are encoding video properly, though I need to do more tests to determine viability with gameplay. Still no audio.
  • Assuming that other settings in Cam are being maintained, we can probably eliminate trying the “run as administrator” approach as a solution (both VoiceMeeter and Cam recommend doing that). My guess would be that VoiceMeeter is causing the problem, but since I use “stereo mix” to record, I have no way of checking. If you choose “record frm microphone” with VoiceMeeter disabled and with the specific device selected, does Cam save its settings? (even though no sound is actually recorded) If so, it’s a VoiceMeeter issue. One experiment might be disabling VM and trying VB Cable (frm the same site) to more simply replace stereo mix, which I assume is missing on your computer. This program seems to be the loop component which VM uses, but it might cause less disturbance to the process.

    Both VoiceMeeter and VB Cable may turn out to be very useful programs, but we haven’t yet seen reports on how well they work in combination with other programs.

  • edited April 2014
    ...Okay... I am really confused, but I found a partial solution...

    I have a mic built into the laptop, and there was a setting that was separate frm the normal Windows sound manager that had muted that so I didn't get echoes transmitting through when I spoke in some programs. It turns out muting that in the way that I did muted all recorded mic sound.

    So, I've reset that and found a way to disable the echo. So I now am able to do a recording with video and mic audio.

    To clarify something I said before, I noticed this after I installed VM, but was experiencing it before. Now that I have worked out the mute issue I'm able to put better words to what is going on. No matter what device I select to record frm, it reverts to recording all sound frm the laptop mic, even if I have a USB headset plugged in and am able to use that same device for other things. It's a selectable device, but it keeps going back to Default. And it seems that Default is Laptop Mic.

    Short version is that I still cannot record program audio directly frm a program. Technically, I can record it as it comes out of my speakers or headset, along with every sound my fingers make typing, pressing the mouse buttons, dragging across the mousepad, the computer fan, the hard drive spinning, etc. Laptop mic is truly a thing of evil.

    EDIT: Found out I can record frm headset mic by changing the Windows default mic to the headset mic. This is still really inconvenient, and inexplicable. And still cannot record program audio.
  • Have a look at this short tutorial which Terry posted on Youtube.

    It’s worth a look (note the settings at the 6 min mark), but the problem with Cam’s settings reverting once they are set is a puzzle. Obviously, one must make sure that the “options/program options/save settings on exit” is checked , and it might be worthwhile trying the “run as administrator” choice is made, just to cover all bases.

    One option might be to download a different version of CamStudio. I’m still using 2.0 and find it rock solid in terms of settings and basic function.

  • Tried that... Unfortunately, again, since my laptop mic is inside the laptop, enabling the "Listen to this device" setting means that every sound made by the computer, including my typing, the speakers, the click of the mouse buttons, the fan, loops back through the mic and makes a nasty squealing sound which is not conducive to the environment of recording. In the sound mixer menu, the slightest tap or drag anywhere on my laptop maxes the sound pickup meter.

    Tried the same thing with the USB headset mic, and while it didn't pick up everything the way the laptop mic does, it picked up enough that the speakers looped feedback into my ears inside three seconds.

    So, as hopeful as I was, Stereo mix does not appear to be the answer in this case.
  • I managed to get a successful test recording.

    I got the VB Cable and ran that through VoiceMeeter. It now picks up my audio and the program audio, at a relatively minor processor cost.
  • I do understand the problem with the mic. The tutorial dealt with recording BOTH frm the system and mic., which is exactly what you would be doing with a built in mic and virtual cable in place. Most systems auto detect the presence of a microphone, so one can’t “listen to it” when it’s not plugged in. In your case, it’s always there, so you need to select away frm what’s shown in the video.(which is why I pointed to that part), BUT that does not change the fact that you need to select “record frm microphone” in Cam and find a replacement for the missing “stereo mix”. The issues here are whether the virtual cable program successfully replaces stereo mix, and why Cam is not holding its “audio options for microphone” settings. It needs to maintain those to work. I doubt that any problem has to do with the presence of a virtual cable, which leads me to believe it’s a problem with the version of Cam which you have installed. If your computer has the option of using an external mic, you could try plugging one in and selecting away frm it to see if that makes a difference.

  • Sorry I've been missing for the last several weeks - I'm in a transition situation on the homefront here as I become "caregiver" for my ailing mom. Finally have stuff moved.

    Thanks for jumping in and helping to solve this, Ken!

    Reth - As you have witnessed, the audio stuff requires some steady nerves and a lot of trial and error testing. Glad you have it going! Could you make a video of how you did it?

Sign In or Register to comment.