This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Camstudio no sound recorded or just my voice

edited May 2014 in Announcements
Video is just great as I have H D and go full screen. I have a Usb Logitech headset with mic. When recording I get the
sound which I use is Skyrim You Tube any file. When I replay I get no program sound and sometimes My voice. I have tried everything for settings but must have missed something. In options I use the headset for sound and I just downloaded the drivers for Realtek sterio mix. I just wish I could send screenshots of everything for your insight. Any help would be wonderful. Thank You in advance. Gene


  • Make sure you are using "Record from Microphone" and select Stereo Mix when you want to use that. Another great alternative is Voicemeeter, which is discussed in the sticky threads above.

    See the links in the About section for the following video in the show more area for codec and other links that are useful:

    This is a 10-minute version of the above:

    Also, see this video for many important bits about recording system audio.

  • Hi Terry I have gone through everything. I even went through the videos and stopped at each new screen and brought up my screens right next to yours and they all were twins except for the playback screen Just above this. If I make the speaker the main and the headset secondary I loose all audio including you and I and the Skyrim when I went to it. If I reversed It I got video both yours and the Skyrim but would not record the sound. Another thing when I select audio Headset it would not stay selected. Please help Gene
  • Made a mistake so to clarify I meant audio instead of Video in my last post where I said " "If I reversed It I got Video"
  • Stereo Mix and perhaps Skyrim have to have the default audio playback set to the analog speakers (not the headset, that won't work - not any USB device - it has to be the analog jacks on the back of the unit).

    There is an alternative to Stereo Mix called Voicemeeter that I recommend highly. It is much more flexible as to where the sound is set as defaults for playback, etc. See this for more information and download links.

    I have a few videos on using Voicemeeter on my YouTube channel as well.
  • Hi! Terry I'M still fighting the Good Fight. I have downloaded the Voicemeeter and for some reason in camstudio I cant get a selection to stay in the option for mic. Whatever I select Virt. cable high def mic. and any other it just goes away when I select O K and go back into audio options options for mic. it is gust as if I never selected anything. I did get a new headset set with mic. that I could plug into another set of Green and red ports. I look forward to your reply. Thank You again Gene
  • edited May 2014
    Set Voicemeeter as the default recording device in your system audio settings and you won't need to change CamStudio. There is a bug that is keeping CamStudio from saving the selection in the audio settings, hopefully to be fixed very soon.

  • Terry! I have success everything works except. When I did all my troubleshooting I used a demo from Skyrim and all was good when finished. Then I wanted to put it to good use by using steam to Skyrim to use my real time Video Audio and comments when it went from steam, Play Skyrim continue with my last save all was well but when I closed the file and all other programs after stopping recording with cam studio and trying it out it was good until it got to the Skyrim everything went black. Just like steam is the culprit. when I was using the demo it did not go through Steam. Any suggestions? thanks for the success. Gene
  • Not sure. Going black is often from the media player - does using Windows Media Player or VLC work, showing even the black section?

  • Happy Memorial day! I hope you take the day off and don't expect an answer right away. I have tried Media player and VLC and both get same results. It works through steam I get to select continue and works fine while I record as if normal, but when I play the recording and select play the recording goes black. I have even tried to get around it by using Task manager and restart the program as I can sometimes and it goes black. is It something I am doing or does it not work 2 levels down? Gene
  • Gene,

    What dimensions are you using for the recording region?

    Nowadays, 1280x720 (720p) works on just about all machines.

    Are you using Xvid?

  • I am using xvid and Full screen 1680 x 1050 Gene
  • That may be considered an odd size by the player. Try doing a video at 1280x720 and see if it works ok.

Sign In or Register to comment.