This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

crashes for non-admin user

edited August 2009 in Support
OS: MS Windows XP Pro w/SP2
CamStudio version: 2.00

I tried it on my own workstation first, and it worked just fine.
Then, I installed it on one of my users' workstations, and for me (logged in as admin), it worked fine there as well.

However, when they tried it with their user account logged in, after the initial recording was complete, she clicked stop (or F9, whatever) and it crashed when it started the SWF conversion.

So, is there some file or folder or registry entry that non-admin users need special permissions to in order for the SWF conversion feature to work?

Here are some screen shots of the error messages involved...

Any ideas?

p.s. I've already run this past Nick, and he was stumped.



    Today I verified two more points...

    1. The non-admin users are able to save in avi format.
    It is only when they try to save to SWF format that CamStudio Producer crashes.

    2. It is indeed an admin/non-admin issue.
    When the user's account is in the local administrators group, CamStudio works just fine for them to save in SWF format.

    Any ideas yet?
  • edited September 2009
    Is it possible that the Flash browser plugin is restricted to local admin access only and that SWF Producer (for whatever reason) is trying to access it?
  • Hi, Nick.
    Sorry I haven't been in here for a while.
    No. That can't be the issue, because the non-admin users are able to use the Flash Player when browsing websites just fine.

    Any other ideas, anyone?

  • I saw the same issues you did. I even saw the latest version of producer crashing even when running as an admin. I was able to get it to work by saving the video as an .avi, closing recorder, opening producer, selecting the saved .avi and then converting from there. There is definitely something funky going on there. My guess is that it has something to do with the permissions on the temporary folder, but I'm not sure yet. For now you can try this workaround.
  • I had the same problem with 2.5 and I am using under Admin privileges. It would give that message everytime I click on the Video set-up and eventually crash the CamStudio.

    I think the codec or codec package you installed is causing it. I removed the K-Lite codec package I installed and it does not crash. I tried this numeruos times just to see if I can replicate the problem and this seems to be the problem.

    I then tried to reinstall the K-Lite codec package with just the DivX video codec and MPEG Layer-3 and LAME 3 audio codecs and so far it does not crash.

    So I am guess too many video codecs are somehow interfering with CamStudio ...shrugs
  • We have the same issue with converting to SWF via SWF Pproducer.

    The workaround we found was -
    On SWF Producer, choose your file, Convert to SWF:
    Unchecking "Add Preloader + Progress Bar (Flash 5/MX Only) under the General Tab > Behavior

    The only thing is that I can't figure out a way to always keep this unchecked. Is there a command in the ini I can add to keep this setting?
Sign In or Register to comment.