This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Error Recording AVI!

edited September 2009 in Support
All has been good, then today NOT! Trying to record Video and need help!
Keep getting; "Error recoding AVI File using current compressor. Use Default Compressor?
Tried reinstall and no go. I Run Lossless Codec with normal 20/50/20 settings on Region.
Also, if I click default compressor it resets to Microsoft Video 1, still no go.
Regards, Ed


  • Hi Ed

    I think you need to double check the recording width/height dimensions are divisible by 2.

    happyguy49 had the same problem when using the DivX codec in this thread:

    Also check the YouTube video in '49s comment as well.


    Nick :o)
  • Hi Nick and thanks for the response.
    yes, I had read the thread you provided above before posting this thread and checked the width & height (720x480) before trying to record.
    I still get same error. Anything else to try? Regards, Ed
  • OK, just deleted all CamStudio files and reloaded everything, including lossless codec.
    Now I'm getting error message; "Specified device handle is invalid" and the error
    message "Error recoding AVI File using current compressor. Use Default Compressor?

    Yes, I watched and attempted all in the above video tutorials. HELP!!!!
    Regards, Ed
  • Make sure you don't have GZIP compression selected. Go into video options, click Configure, and then select the top radio button (all of this is assuming you are using the CamStudio Lossless codec.)

    However, for a better compression rate, I'd suggest you check out
  • So you completely reinstalled the program, and now it still won't run?
  • Hi jonny,
    Yes, complete reinstall and No I do not have GZIP selected. I have been using CamStudio for awhile and never had a problem.
    Just don't know what to do now as I need to generate several videos, like yesterday.
  • Well, the fact that you completely reinstalled makes it seem like it might be a problem outside of CamStudio. However, in case it's not, I have a newer build (2.6) that you could try. There's always a chance that it could have bugs, but it's worth a shot.
  • I have no problems with other programs and used Camstudio2.5 only about 10 days ago.
    I am trully lost for thought here.

    Yes, I'll try anything at this point. How do you suggest sending the new build and what codec/settings do you suggest?
    Regards, Ed
  • edited September 2009
    Okay, sorry for the delay. Here's a link to my build:

    I haven't tested it on any other computer, but it works on mine. I packaged ffdshow in with it, which provides support for a lot of different codecs. The best I've found is H.264 Lossless.

    Hopefully it works. I'm going out right now, but I'll be back in a few hours so if you have any problems I'll try to troubleshoot them with you then.

    Good luck!
  • Thanks a heap jonny. I'll work on it and get with ya later!!
  • Hi Jonny,
    OK, here we go; Steps taken: (XP Operating System)
    1) Created new folder in Program Files named CamStudio2.6.
    2) Unzipped package into new folder and extracted files.
    3) There appeared 2 extracted sub-folders (named 2.6x and ffdshow.exe)
    4) installed ffdshow using install wizard
    5) Clicked on Recorder.exe and created shortcut.
    6) Clicked on shortcut or Recorder.exe directly and now get this error message;
    "This application has failed to start because mfc.100dll w2as not found. Re-installing the application may fix this problem"

    I re-installled it all and still get the same error message. Help!! I'll check back time to time.
    Also I can call you by phone if that will help any. Just let me know. I really appreciate the effort.
    Warm regard, Ed
  • Alright, seems like you just don't have all the dependencies installed.
    I packaged a bunch of DLLs that you might need. You probably don't need all of them, but I just wanted to be safe.
    Extract all the files so that the DLLs are sitting in the exact same directory as Recorder.exe.

    Okay, hope that works. Let me know if you have any more trouble.
  • Oops, I just tried the release that I uploaded and it seems to be recording black. I'll see if I can fix it. However, you can still see if it solves the other problem that you were having.
  • Alright, it was just a stupid mistake (note to self: Don't put important function calls inside an ASSERT. ;)

    Alright, so I uploaded an updated build. Here's the link:
    That should fix the black problem, and hopefully your main problem as well.
  • Also, every time you open the application, before recording, it seems like you have to open Video Settings and then click OK, otherwise it gives you the same error as you are having now. I'm going to try to track that down.
  • Hi Jonny. I'm back now and see you've been busy. lol!
    Ok, so do you want me to download the new file and dll files or just the new file?
  • OK, Downloaded the new 2.6 file along with the Dependencies and placed them all in the same file. (named Duh.. CamStudio2.6).
    The Recorder now opens, but; when I attempt to record I get the error message "CamStudio recorder has encountered a problem and needs to close".
    Maybe we are almost there. Ed
  • I also uninstalled and reinstalled the new 2.6 file and Dependencies. Still No Fix :(
  • Which codec are you using? So far I've tested this build on two different Windows 7 computers, and one XP computer (running in a virtual machine), and it seems to be working differently on every single one of them. :P On XP ffdshow isn't working, so perhaps you could try a different codec if that's what you are using.
  • Oh, and this might be a stupid question, but have you tried using CamStudio 2 yet? It's definitely the most stable of all the releases.
  • Hi again,
    I was using 2.0 originally, then switched to 2.5 and both worked fine once I figured out the settings and such. I had not run my 2.5 version for about 2 weeks but when I did yesterday the problem arose.

    To answer your questions: (1) no I have not tried the 2.0 version again and really wish I didn't have to and, (b) I left the codec on the ffdshow you added. You know what, I'll try another codec (Lossless1.4) and see what happens.
    Are you out of thoughts for a fix?
  • Ok. Tried the 2.0 version and still get the message; "Error creating AVI file".
    So, it appears the problem is, as you suggested earlier most likely outside of CamStudio. So, where and what is causing this problem.
    Any thoughts/suggestions at all? Ed
  • Hmm... so, everything was working fine, and all of a sudden CamStudio stopped working. Did you make any significant changes with your computer around the time it happened?
  • edited September 2009
    I'm trying to think of why a program would fail to create a file, and the only thing I can think of is either the program doesn't have the proper permissions, or there's not enough disk space. I know that with Vista and onward permissions were a lot more strict, but I don't recall it ever being a problem before then. XP and 2000 seems to let anybody do anything. Plus it would be weird for permissions to change like that out of the blue.

    Not enough space makes more sense, because it's something that would just happen seemingly out of no where (it's happened to me before :P), but I doubt that's the problem, because you'd have to be _really_ low for you to not be able to create a single file.
  • No, no major earth shaking changes. I try new programs all the time. You know, add delete. I also run a Registry cleaner from time to time,, but that never caused a problem before. Now I did update (service Pack 3) not to long ago and I think after I used Camstudio the last time as well.
    Could it possibly be in conflict with XP Service Pack 3 for some unearthly reason?
  • Well, Service Pack 3 is known to have some issues. I'll get a Service Pack 3 installation running and test to see if it works.
  • edited September 2009
    I don't remember any specific errors with CamStudio and XP SP3.

    There was one problem to do with a screen being black when recording, but that was to do with ZoneAlarm (ForceField?) - not SP3 itself.

    Can you actually generate a recording with the Microsoft Video 1 codec?

    If not and the location of the Temporary Recording Directory is set to your Windows temporary folder, try changing it to somewhere else, like a "D:" drive.

    Also (and I know this is dumb) does the user account you're using on your machine have admin rights?

    If not, try logging in as the local administrator and making your user account an admin.

    Any joy?


    Nick :o)
  • No, I cannot generate a recoding with anything. I have tried every codec suggested.
    I have also gone through multiple installs of versions 2.0, 2.5 and 2.6 with NO FIX.
    I get the same error message(s) with all of them.

    I hope to work with a computer guru friend later today , but shy of him coming up with some
    fix, a full system reinstall of XP and the works may be all that's left. It seems The only thing that
    still bothers me is, it seems I would be having other problems beyond CamStudio if I have a major system file corruption problem.

    Thanks for all the effort, Ed
  • What do you have your audio options set to? I seem to recall running into this problem when using Recording Format options.
  • Yeah, I just tried with XP SP 3 and it works fine, so it's something else on your system that is messing up. Very strange indeed.
Sign In or Register to comment.