This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Extra long avi files

edited September 2009 in Support
CamStudio 2.5 works great. I'm using the lossless codec and the videos I make are great quality.

The only problem is the output avi file that I get. If I make a video that is 15 seconds long, for instance, the output file can be 3 minutes long. The first 15 seconds are what I've recorded, but the remaining time is just garbage.

Can anyone help?


  • Could you post what your video settings are?


    Nick :o)
  • Sure thing.

    CamStudio 2.5

    CamStudio Lossless Codec v1.4
    Quality: 100
    Algorithm for Compression: LZO
    Level 9
    Set Key Frames Every 200 frames (grayed out)
    Capture Frames Every 5 milliseconds (grayed out)
    Playback Rate 200 frames/second (grayed out)
    Auto Adjust (checked)
    Arrow on farthest left side of dial

    I have everything maxed out, which I probably don't need... but I have tried with various video options and always get the junk at the end of the avi file.

    Thanks for your time.
  • I tested these settings on my system and did not see extra garbage at the end of the file. What program are you using for the video playback? I tested both the player that comes with CamStudio as well as Windows Media Player. I tested with CamStudio 2.5 on Windows XP as well as the latest development build on Windows Vista. Is there anything else unusual about your setup that could be causing problems?
  • 200 fps! That's beyond overkill. I'd go no higher then 20 or 25 at the most.

    Capture Frames Every 50 milliseconds
    Playback Rate 20 frames/second


    Capture Frames Every 40 milliseconds
    Playback Rate 25 frames/second

    I'd lower the keyframe rate to 100 as well. You can use the slider to adjust the Capture and Playback Rate, but you will have to uncheck auto-adjust to have the keyframe rate to differ from the Playback Rate.
  • BleeBlap:
    I have Windows XP and am using Windows Media Player 11.
    I can't think of anything else that would cause problems.

    I have tried your adjusted settings and tested in both wmp11 and camstudio's player.
    No difference, still junk. The last thing you see is me hitting stop record, and then there's stillness for about 75% of the avi file.
  • edited September 2009
    What Region option are you using and what resolution are you recording at? Also, what is the file size of the recorded video?
  • brandished:
    I always use window. The resolution of my desktop is 1280x800 at highest color quality.
  • edited September 2009
    Hmm... That resolution should be ok. I'm not sure what would be causing this based on your settings.
  • edited October 2009
    Can you try renaming your INI config files in C:\Program Files\CamStudio and then restarting CamStudio?
Sign In or Register to comment.