This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Lossless codec not showing up



  • andrew_camstudio, thanks a lot for posting that.

    Can anyone let me know on this thread or message me directly via the forum if this works, please?


    Nick :)
  • Glad to help all. Enjoy! :-D
  • edited February 2012
    A word of caution: don't use the CamStudio Lossless codec if you ever plan to edit the files with Adobe Premiere!

    Even with the manual 64bit registering method described above, Premiere will not be able to correctly import any file encoded with CamStudio Lossless. Only the audio track will show up. You have to resort to the Lagarith or UT codec instead.

    Bye, Malte
  • edited May 2012
    That is true about Premier and other Adobe products not recognizing CamStudio Lossless. Of course, since it is lossless, you can convert to Lagarith or UT without any damage to your quality.

    What other codecs play well with Premier, Sirblackadder? Anyone? (Perhaps this should be in a different thread...)

    * For those not familiar with UT, it is a YV-style codec, like huffyuv, which is probably why Premier recognizes it.

    Version 11.1.0 released


  • edited February 2012
    For me, Lagarith works just fine. File sizes are a bit humongous at times and encoding may take awhile on lower-end systems, but all in all, directly recording to Lagarith is a time-saver in my workflow since "CamStudio -> Lossless encoder -> VirtualDub to Lagarith -> Adobe Premiere" takes longer than just "CamStudio -> Lagarith -> Adobe Premiere"

  • By the way - I, while being an idiot, actually bought Camtasia after first encountering the hourglass bug in CamStudio. The TechSmith codec does a fantastic job in keeping file sizes small, so after coming back to CamStudio due to audio quality issues in Camtasia, I thought: well, let's just use the still installed TechSmith codec in CamStudio.

    Baaaad idea. The videos look perfect in Windows Media player, but become ugly in Adobe Premiere. You get choppiness, ghosting, partial invisibility of newly added content inbetween keyframes and a slew of other strange visual effects.

    Hence, there really are only the two major options Lagarith and UT codec as lossless codecs in CamStudio, if you plan to edit your videos in Adobe Premiere. I tried both with equally satisfactional results.
  • Interesting, Sirblackadder.

    Both Lagarith and UT are derivatives of Huffyuv, aren't they? Anyway - this is great to know that these produce success in Premier, etc.

  • I had the same problem, on windows 7 64bit, and moisamva instructions to register the dll by hand worked perfectly, thanks.

    Just one note: I had to install version 2.6c, it would not work at all with version 2.6b

    A question: why is codec 1.4 downloadable standalone, while codec version 1.5 is part of latest camstudio?
  • Just a legacy thing on the 1.4 codec, for people with 2.0.

    2.6b needs the 2008 version of the Microsoft Visual Studio C++ Runtime Libraries.

    2.6c uses the 2010 version, which comes pre-installed on many Win-7 machines in both 32 and 64 bit versions.

  • I have tried everything mentioned above concerning the issue of the codec did not show up for me either. I started off using ver 2.0, here no codecs, uninstalled the program.

    Downloaded CamStudio_Setup_v2.6b_r294_(build_24Oct2010) along with latest codecs, could not get the "Options, Video" to see if any codecs were available.

    Tried the regedit suggestions, still a no go.

    Tried adding mfc100 and msvcr100, still no codecs so uninstall that version of the program.

    Then tried ver. CamStudio_2.6b_r264_build_14july2010. tried everything again, still could not get the "Options, Video" to see if any codecs were available.

    Rebooted and shut down computer several times during these steps as well.

    Tried going back to CamStudio ver 2.0, now can get passed "Options, Video and see No Compressor available now. Still no codecs.

    I am running Windows Vista Ultimate.
    Hope the following can be of help as well:
    OS Name Microsoft Windows 7 Ultimate
    Version 6.1.7601 Service Pack 1 Build 7601
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name ArgyleBill-PC
    System Manufacturer nknow
    System Model Unknow
    System Type x64-based PC
    Processor AMD Athlon(tm) 64 X2 Dual Core Processor 6000+, 3000 Mhz, 2 Core(s), 2 Logical Processor(s)
    BIOS Version/Date Phoenix Technologies, LTD 6.00 PG, 8/8/2008
    SMBIOS Version 2.5
    Windows Directory C:\Windows
    System Directory C:\Windows\system32
    Boot Device \Device\HarddiskVolume2
    Locale United States
    Hardware Abstraction Layer Version = "6.1.7601.17514"
    User Name ArgyleBill-PC\Argyle Bill
    Time Zone Central Daylight Time
    Installed Physical Memory (RAM) 4.00 GB
    Total Physical Memory 3.87 GB
    Available Physical Memory 1.44 GB
    Total Virtual Memory 7.75 GB
    Available Virtual Memory 5.55 GB
    Page File Space 3.87 GB
    Page File C:\pagefile.sys
  • I have posted a video showing the results between CS 2.0 and 2.6, r294.
  • Moisamva,

    Thanks for the great solution on how to install the codec in 2.6v. Worked perfectly!

  • Argyle_Bill,

    That is indeed very, very strange. The CamStudio 2.0 version requires nothing to run as it is all self-contained in its own folder! And the 2.6b r294 example not even showing its Video Options panel is entirely odd. Search here and I don't think you'll find other examples of this error! So, I'm stumped. Perhaps one of the programmers will see this and make a comment.


    Glad Moisamva's approach is working for you, at least!

  • I think I might have the problem for me, but not the fix, please help.
    I do not have a c:\Windows\SysWOW64 on my drive. There how do I edit the following since there is no Wow6432Node, WindowsNT, or Drivers32 in my registry:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\drivers.desc]
    "camcodec.dll"="CamStudio lossless codec [CSCD]"
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32]

    Mine is like this:

    Even if I edit the solution to match mine i get an error after trying to import the reg file
    "The specified file is not a registry file. You can import only Registry files." the file name is codec.reg and was created in notepad.

  • The CamStudio 2.0 was installed as a sub-folder under "Program Files (x86)" on my computer. I did try the portable version of "CamStudio Portable 2.0" and it is in it's folder, but still has the same issue on my computer.
  • Argyle_Bill,

    If it doesn't run at all with any version, something is very broken.

    The SysWOW folders are on Windows 7 machines only, I believe. So, that fix is not for your case - but you shouldn't even need that fix, as this is deeper than codecs simply not appearing - your entire video options panel is broken! Have you re-installed the 2008 MS C++ Runtime Libraries? That might be something that will work.

  • edited December 2012
    Here is a video by b0otable showing how to fix the installer for Win7 64-bit systems.


    Edit by Nick: now that I have a Windows 7 64-bit laptop I was able to test Andrew_CamStudio's solution and following b0otable's video I can confirm it worked on my machine.

    Here is a direct download for the 64-bit version of the camcodec.inf I used on my machine

    Rename the current camcodec.inf to camcodec.inf.old, then download this to the camcodec folder and rename it to camcodec.inf.

    Right click > Install as normal.

    Please note, this is only for Windows 64-bit users and I have only tested this on Win7 64-bit - I don't know about Windows Vista 64-bit.

    Also I take no responsibility if this screws up your machine.
  • Well I've been through this whole thread and tried it all and still can't get the codec to show in video options. After trying everything here with the camcodec.dll file and nothing worked, tried to get k-lite codec to show up and, after downloading k-lite, I copied all of the .dll files to the sysWOW64 folder and nothing is showing up. I have about 5 hours into this so far and I'm out of ideas. I would like to somehow get xvid mpeg4 into my video options. I'm also running windows 7 64 bit. working with camstudio 2 6b
  • edited December 2012
    Cam is a 32 bit program, so you need properly registered 32 bit codecs to get it to work. Get the Xvid MPEG-4 codec at:

    You can get x264 at:

    Both of these work well with CamStudio. The Cam lossless does not. You might consider what you’re getting with K-lite and whether you really want all that stuff on your computer.

  • Thanks Ken I'll give these a look. But getting the codec on my machine hasn't been the issue. It's getting it to show up in video options I'm having problems with.
  • edited December 2012
    Well I thought that fixed it but I was wrong. I finally got the xvid mpeg4 to show up in video options but when I set it and went to record a movie I got an empty box that said "xvid status" "not responding" I went ahead with the video actions anyway and when I stopped and tried to play it back I got a black screen for the entire video.
    I guess now I have no choice but to go shopping for alternative software.
  • Following up on Ken's post, as a test I downloaded and installed the "32-bit & 64-bit binaries (EXE installer for 64-bit systems)" on Jawor's website

    Direct Link >

    As well as x264vfw using the provided link.

    Both are now showing in Video Options.


    Nick :)
  • Nick: We should acknowledge the fact that getting a codec choice to show up in the dropdown list is a step short of getting the codec to work constructively with the software. The poster noted that he is using Win 7, so we can assume that the issues we might see with dll’s and Vista would not be a problem, although they can’t absolutely be eliminated.

    The acid test here is to first try a test using the MSV 1 codec with 2.6b. If that doesn’t work, I’d try a 2.0 install and give that a go. I’d have to think that, at that point, the thing will be working.

    I do have my doubts about the 2.6 versions. My 2.6c will work perfectly fine with a given codec and setting and then throw up an inexplicable error message when repeating the same task.

    If we assume that both the x264 and MPEG-4 codecs have been properly installed (registered), and the program isn’t working using those codecs, I don’t see how we can get around the fact that the program isn’t getting usable information from the computer’s graphics processing. We’re seeing more threads concerning the problem with Cam “crashing” upon beginning the capture process, and that would seem to be related to this issue.

  • Hi Ken

    Agreed. I have done a few test recording using XVid (HD 720 Home profile - all other settings default as recommended by Terry) which seems to record absolutely fine on my system, although the audio is a bit funky sounding which could well be my internal mic.

    The preinstalled Win7 that came with my laptop (Acer V3-531) already had the VS 2010 C++ 32-bit and 64-bit runtime files installed so I didn't need to install anything else.

    I just installed 2.6c then followed the instructions and video in this thread to get the CamStudio Lossless Codec, x264vfw and XViD installed and running.

    The tests I did were using a fixed region of 639x479 counteracting the missing pixel glitch (which we're still looking into BTW) and video-wise at least are fine.

    (^= the missing pixel glitch and recording dimensions indivisible by 2 or 4 are the number 1 and 2 reasons for CamStudio "crashing" on recording start)

    If I can grab an hour or so do some other tests with different codecs and upload them to YouTube.


    Nick :)

  • I’d agree that the fact that the program doesn’t work can be explained 90% of the time by the fact that the pixel dimensions aren’t even numbers, but the fact that there is ANY mis-communication between the program and the processor (resulting in the need for a 1 pixel correction) suggests that the problem may extend beyond the obvious. The fact that, if the dimensions are deliberately set to odd dimensions, Cam 2.0 and 2.6 versions react so differently is puzzling, and why 2.0 would, in some cases when using Lagarith, correct the recording area to even numbers, and in other cases default to MSV 1 without the familiar “use default compressor” notice, suggests that the program is reacting to codec presets, although not in any predictable way. If we can believe that some have experienced crashes upon starting a capture using 2.6 versions, and if those crashes occur even when using a codec which allows captures using odd dimensions, I don’t think it’s unreasonable to assume that the program isn’t getting any useful information from the processor at all. The fact that there is a known problem involving detected dimensions, requiring a correction, seems to me to be too much of a coincidence to think that the error in the information flow is anyplace but here. At its worst, this condition suggests that Cam won’t work at all on some computers, as they exist and as the program is currently installed.

    I have yet to see a post here, in which a user has experienced a crash upon start involving 2.6, where the poster has come back and said that he/she has figured out what the problem was and that it had been fixed. I would hope that anyone who has such an experience would come back and report the outcome.

  • I'm also having a problem getting certain codecs to show up in the menu. I'm not worried about the CamStudio lossless, but I'd like to try using DivX and it doesn't appear. (On the other hand, XviD did appear after installation, but I'd like to avoid it because of its annoying window that it opens whenever it starts up.) I checked the Windows Registry, as was suggested above for installing Cam Lossless, but I found that DivX was already in there, so there was nothing to fix on that front.

    I'm using Windows 7, CamStudio v2.6. Thanks!
  • Many thanks for all the advice given here. I followed many steps on my Windows 7 64bit system and finally edited Registry to make the changes and the Lossless codec came up and worked like a dream. I am now posting my raw video onto YouTube and very happy with the outcome, rough as it is: (hope it works)

    Particularly thanks to TerryBritton and b0otable for the last mentioned instructional video. That cinched the deal and made certain that all was working as it should be.

    Will now look to what bmoreken has just posted to see if I can get other decent codecs working on the system. For example none of the k lite stuff will show up.
  • edited January 2013
    x_loto and ilox,

    As to Xvid and the annoying window that it opens whenever it starts up, you get rid of that in it's configuration area by clicking on the "OTHER OPTIONS" button at the bottom of the preferences dialog box and un-checking the box next to "Display encoding Status".

    DivX gave me too many problems and freezes to trust it again, but the 2.6c version (and soon to be released 2.7 version) shows all the codecs. Look in the "Next" folder at our SourceForge site. That version unzips a folder and does not use an installer. Just run recorder.exe.

  • edited January 2013

    I noticed your video was skewed. This usually is due to the dimensions not being even-numbers for the width and height, as YouTube creates an MPEG-4 version of your video, and it will mess up the lossless codec-recorded vids if they aren't already compliant. The lossless codec is VERY simple, and will allow un-even numbers for the width and/or height. I have a video that shows how to straighten it up for re-uploading to YouTube once repaired here:

    Keep at it! :-)

Sign In or Register to comment.