This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Can't get CamStudio codec to work in various media players

edited May 2008 in Support
I've installed the CamStudio codec and Camstudio and the included tools can save and play using the codec, but I can't get encoded movies to open in anything else like WMP or Media Player Classic, or for that matter Windows Movie Maker. What's the best and easiest way to extract key highlight clips for, say, usability study results.


  • I just did a test, and found that videos with the CS-codec is decoded by ffdshow on my computer, and the video played in all the players you mention. So, you can try installing ffdshow:

    Note: During the installation you can select what ffdshow is to decode. Check the box for CamStudio.
  • This does not appear to work for me. I guess I will be extracting stills and audio clips as video is not possible for me.
  • Honestly, I don't know what is the problem. Try downloading Gspot, and open a videofile there: (No installation required, just unzip the file and run the program.)

    Gspot will tell you if the proper codec for the video is installed, and if you click the number 1, right beneath "MS A/V" at the bottom, you'll see what it is that is decoding the video (and audio). It will not help in and of itself, but perhaps it will give another clue as to where the problem lies.
  • edited May 2008
    I shall have to give this a try. To date, usually the file will open, but I only get audio. Only the player packaged with Camstudio actually wants to give me video.

    OK, it's working now. I had a codec pack installed and, as usual, it was wreaking havoc with video management. I'll just have to use VLC for the odd stuff and FFDshow for everything else.

    Thanks for the guidance on this issue. Windows Movie Maker still doesn't like it, but I can see it in WMP, and that's a sure start.
  • Run the file through Virtualdub with Direct Stream Copy enabled, this will produce an OpenDML (AVI 2.0) compliant file. Nothing to do with codecs as every Windows PC has Microsoft Video 1.
  • Nothing to do with MS Video 1, as walkerbl used the Camstudio codec. It also appears that the problem was a codec pack (see post above yours), and that uninstalling this fixed walker's problem.
  • I had a CS user contact me via the Helpdesk and this looks like it might be the answer.

    He uses CS on Vista (bear with me) and ran into the familiar problem of not seeing any video in Windows Media Player when recording audio was enabled.

    He ran the file through Virtualdub Direct Stream Copy which fixed the problem.

    He told me "I've spent a couple of days investigating the AVI header that CamStudio produces and have found that the STRN chunk of the header breaks Windows parsing. CamStudio places a file name in the STRN chunk and it seems to be the tilde character at the start that produces the problem. Note that this also stops Windows from producing a thumbnail during file opening."

    I've put out a project on a couple of the freelancer sites to fix this and a couple of other glitches (Recording Audio from Speakers and Vista compatibility) so hopefully if I can find a suitable programmer they'll all be fixed soon.


    Nick :o)
  • i have the same issue on Vista :-(

    i was able to record sound alone correctly and video alone correctly
    but not together and not with the suggested codec on your site.
    (also, no thumbnail videos when i recoreded audio and i was unable to view
    the video with WMP / WMP-classic )

    i worked-around it by downloading k-lite full pack

    and used mpeg-4 / h264 / h263+ to recored video and MP3 for audio
    CM internal player can play it. WMP can not BUT vlc can play it so i set it to default
    still, Vista was unable to generate a thumbnail for those videos

    i upload those videos to and it works fine :-)

    one last issue,
    no video annotation in vista. i see a black box with no video
    all other applications has video working fine. even in flash.
Sign In or Register to comment.