This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Cursor appears as blue processing circle, not arrow

edited September 2010 in Support
Whenever I record my screen, I see the cursor just fine. I have the cursor settings to use the actual cursor and highlight it in yellow. However, when the video is completed, it shows not an arrow, but the blue "processing" circle, although it is highlighted. I've tried changing every setting I could find.

I'm using CamStudio 2.0 (I've had trouble with 2.6beta stopping after about 9.5 mins, but that's another issue).


  • Nevermind, I found the solution. I had the switch on the mic "off" yet had CamStudio set to record audio. When I turned both on or off it fixed the cursor issue. Well, now if anyone else has this problem, they'll know the solution. :)
  • jrothra,

    Thanks for catching this - I'd count that as a "bug"! I'll make a mention at the sourceforge bug reporting site for the programmers to be able to find (in case they miss your post here).

  • Terry,

    Now I'm really baffled because I tried recording and the problem reappeared. My "solution" didn't work, either. I checked to see if there were other programs running, and nothing was running that wasn't running every other time when the cursor was correct. In fact, less was running, this time.

    I tried these settings:
    - Record audio, mic turned on
    - Record audio, mic turned off
    - Do not record audio, mic turned on
    - Do not record audio, mic turned off

    All gave the the same result. I tried restarting the system, but after rebooting, then starting only CamStudio 2.0, the same circle/hourglass issue occurred. Very odd.
  • jrothra,


    Come to think of it, I recall having this happen to me once as well, but the issue went away permanently. Now if I could only remember what I did (if anything) to get it to act normally...

    I'll arrange a visit to a hypnotist, but in the meantime, try "hiding" the camstudio.ini and/or camdata.ini file in the program's folder by renaming them as camstudio.old and/or camdata.old and try it again, perhaps. If I remember correctly, the program will create fresh versions of those files when you start it up. There could be some corrupt character or data in there, just possibly.

  • Terry,

    I tried that and it worked -- kinda. The first video was fine. But when I did a second video, it went back to the "in progress" circle. Looks like I'll have to do this every time I want to record a video (which is a pain in the neck since I may take 4-5 or more tries to get a 10 min. tutorial video completed with as few errors as possible).

  • edited September 2010

    Do you have any themes running as your desktop background? That may be what I did to eliminate the issue, was to turn off all custom themes and load in a standard one. Something about themes is wandering around in my head, so that may have been it.

    I also vaguely remember having some program running in my tray that might have been the trigger, but I do not remember now what that program was. I do remember uninstalling some program and having issues go away, but that was a while back so I'm not getting all the details to come back to me.

    I'll keep trying to remember all of what happened. I can only get a hypnotist to see me in six months on my health plan... so hopefully I will remember before then. :-|

  • There are no themes running and the only programs running are the defaults for the computer, Firefox, and my antivirus/firewall (I tried disabling them, but no difference made). The randomness of this problem (seems to stop and recur for unknown reasons, all under the same conditions) makes this very baffling to me.
  • jrothra,

    If you are using Windows 7...

    Nick mentions somewhere else here in the forum recently a way to turn off desktop enhancements in Win7...

    [Edit: Ah! Found it! "@tbritton, that "drop your display to 16-bit" tip is a cracker. I believe Vista/Win7 Premium users can get the same effect automatically by selecting "Disable Desktop Composition" in the Compatibility tab after right-clicking Recorder.exe and selecting Properties.

    At least I see the same "The color scheme has been changed to Windows Vista Basic" message." ]

    I cannot help but wonder now if this is a compatibility mode issue. What operating system are you running?

  • I'm running Windows 7.
  • I tried that workaround and it didn't work. However, I did checkmark "Run as Administrator" and that seems to be working . . . so far.
  • jrothra,

    No kidding??? I didn't expect that one. "Run as Administrator" does make sense for it to write .ini files to the Program Files(x86) folder, I suppose. (I'm such an XP user...)

    I hope that one is the key! Please do let me know.

  • It wasn't. I just tried a test tonight and the same problem all over again. It's getting VERY annoying.
  • I also encountered this problem when recording a dosbox session. I used a blank cursor for the hourglass as a workaround. (Go to mouse settings->cursor and change it there.)

    A blank cursor can be found here:

  • What version are you using? I just tried dosbox and I got normal cursor. It should not be an issue if you are using windowed mode of dosbox. I don't know if it is the case for fullscreen.
  • jrothra said in the beginning:

    "I'm using CamStudio 2.0 (I've had trouble with 2.6beta stopping after about 9.5 mins, but that's another issue)"

    Nils did not stipulated which version he used.
  • I believe "9.5 mins" issue was related to leaking DC handles and is already fixed for quite a while.
  • I used Camstudio 2.0 and Dosbox 0.71 (windows).
    All in Windows XP SP2.
  • 2.0 is badly outdated
  • There's another thread on this topic: Hourglass Cursor Not Pointer/Hand etc

    I posted a possible solution there.
  • edited February 2012
    I may have found a way to diagnose the existence of the bug while recording. See here:
  • edited February 2012

    I'd sure like to know which precise "Wildly play[ing] around with video, codec, audio and cursor settings in CamStudio until the bug eventually disappears" actually worked! :-)

  • edited February 2012
    Man, I don't have the slightest clue.

    In another thread, somebody hinted at changing audio properties but I found that to not work reliably. What I do is

    - change video codecs back and forth, together with frame rate settings
    - change audio settings, specifically recording device, bitrate, and the MCI switch
    - set cursor to custom (from file) without actually chosing any cursor and back

    At some point during these modifications - not reproducibly though - the correct video codec will show up in the CamStudio monitor during recording, from which point on everything works as expected. At least on my system, the bug will not re-occur before eventually closing down CamStudio.

    Be warned: it may take multiple of these settings changes (in the higher single digit area) to make the bug go away.
Sign In or Register to comment.