This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Hourglass Cursor Not Pointer/Hand etc

edited September 2010 in Support
Camstudio is fantastic, thanks- great contribution.... BUT...
Help. Trying to use Camstudio on a fairly new machine. (Windows 7, HP intel i7 Nvidea).
Have tried uninstalling and re installing and have tried everything mentioned in support queries containing the word 'cursor' eg sound settings.

I still have an hourglass (wait) cursor instead of pointer in the output (not whilst recording). This will confuse users in the tutorials I'm trying to write. I can turn on highlight options no prob but always in the finished vid the cursor is an hourglass. Grrrrr.


  • Help- anyone know how to fix this?
  • OK. After tearing hair out (not got much anyway), changing themes to be most basic etc I thought about the guy with the similar problem who'd resolved it by turning on his mike. I'd tried all variations of this yesterday I thought but who knows: I took out all audio connections (jacks etc) and checked "do not record audio". Now it seems OK.
    Hope this help someone else. take care. Dan
  • danofweaver,

    Sorry I hadn't gotten to you in response, but I didn't have an answer for you (I was stumped) -- though now I DO with your reminding me of that audio quirk!

    Thanks for mentioning it. I'll keep it in mind and pass it along to the programmers as well.

  • I'm the guy who fixed it by turning on his mic. However, the problem is back and this time turning on the mic isn't doing it. I tried setting it not to record audio with the mic on and off, then told it to record the audio with the mic on and off. No matter what I get the hourglass/blue circle instead of the standard cursor. Now I'm baffled as to (1) why the fix worked before but not now and (2) if there is something else involved.
  • I also tried the "mic" trick, but that didn't help.

    What worked for me is changing the video codec in "Options -> Video options" from "Camstudio Lossless" to "Microsoft video 1" and back.

  • webflow,

    "What worked for me is changing the video codec in "Options -> Video options" from "Camstudio Lossless" to "Microsoft video 1" and back. "

    That did the trick??? I wonder why that would do it?

    Anyway... thanks for the tip - I'll keep that in mind for next time I see this cursor issue coming up.

  • I've had this problem intermittently, which is really annoying. I found one solution that works just fine. Go to options, cursor option, and then click on the "Use cursor from file" radio button. Click the folder icon. By default it should open "C:\Windows\Cursors" for windows users. If not, browse there. Selection your cursor of choice. I use aero_arrow.cur. It's the default cursor, sans big drop shadow. There are other decent cursors in that folder as well. Once you choose to use a custom cursor, the problem goes away. Hope this helps.
  • Thomas,

    Excellent! And thank you for the tip on the aero_arrow.cur.

  • I may have found a way to diagnose the existence of the bug while recording. See here:

    And BTW, playing around with settings actually does work although I doubt that it's exclusively related to the audio settings. However, you may have to commit multiple settings changes until CamStudio eventually gets back to normal operation.
  • Sirblackadder,

    Have you tried using the aero_arrow.cur or another custom cursor? If you had and it didn't work, that would further confuse this issue and complicate it even more!

  • Hi Terry. Yes, using a custom cursor reliably works, no problem there.

    However, I find this workaround not suitable in some occasions where the viewer is supposed to see changes in cursor appearance due to my actions.

  • Sirblackadder,

    I totally agree that not seeing the custom cursor detracts from the teaching environment. I just wish we could figure out why this is an intermittent problem.

  • edited March 2012
    I just encountered another very strange cursor effect in CamStudio

    For my presentations I often use a screen annotation tool and, after extensive testing, decided to go with Presentation Marker.

    When in annotation mode, Presentation marker will show a custom cursor (a pen, brush, or else) which is reverted back to a normal cursor when exiting annotation mode.

    This all works seemingly fine as long as you don't watch your recorded videos. Here's what happens on my system:

    (1) CamStudio will not record the correct cursor but just a dot with the annotation color that you selected in Presentation marker.

    (2) CamStudio will stick with this cursor regardless of whether you are in annotation mode or not.

    I got a related error in ZoomIt. There, in annotation mode, a simple plus sign with the currently selected annotation color is displayed as the cursor. CamStudio not only records this plus-cursor but the regular arrow cursor attached to it as well. At least, with ZoomIt everything changes back to normal when you exit annotation mode.

    May all these kinks be related?

    Bye, Malte
  • I've no idea how Presentation Marker is writing to the screen - try toggling that switch in CamStudio's Options | Program Options that says, "Capture Transluscent/Layered Windows" to see if anything changes.

    This somewhat seems to be related to video card drivers, though. That is, CamStudio records some people's cursors just fine (like my two machines do) but some machines really make mincemeat out of the whole thing.


Sign In or Register to comment.