This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Camstudio version 2.6b release 294

Camstudio version 2.6b release 273 is released on Sourceforge on 5 October 2010.
(Updated on 27 Oct with r294)

Due to some uncontrolled Source Force 'newest file' behavior we were not able to let SF points to the newest release.
You can find newest release here:

Please use this discussion to give us feedback that is only related to the things that are new or changed compared with the V2.0 version
We know that some things in Camstudio v2.0 that need improvement.


  • edited October 2010
    Nice, this version doesn't have the off-by-1 resolution size bug like the other betas did. My ffdshow installation isn't showing up in the video options' compressor selection though. Autopan speed adjuster seems a bit quirky as well.
  • @phosgram,

    Input like this is what we need.
    With ffdshow there is an allow and a deny application list. Check if recorder is on the list. Program was named previously vscap.

    "Autopan speed adjuster seems a bit quirky as well" How more quirky. What kind of behavior do you get.
    (I can not remember that something is changed with panning there but I must check.)
  • mltmlt
    edited October 2010
    yeah... autopanning dialog tends to reset speed value text to 0. I temporarily fixed it in my branch. It is only visual issue though, it sets it correctly.
    Also autopanning jumps a lot. I am not using autopanning much personally other than while zooming, however it behaves differently in this case. I think it would be nice to change "maxpan" parameter to resistivity, i.e. panning speed should be proportional to distance & inverse resistivity provided some threshold to begin panning.
  • Hi Janhgm, I checked my ffdshow's DirectShow control "don't use" setting and didn't see vscap listed, I didn't see any of the other exe's CamStudio comes with (Player.exe, Recorder.exe, etc) listed either.

    The ffdshow version I have installed is:
    ffdshow tryouts revision 2065 Aug 30 2009 22:07:49 (msvc 2008, x86, unicode, r)
    If that helps. This is the first CamStudio build I've tried that has the issue.

    As for the "Autopan Speed" adjuster, mlt is correct, it was a visual bug, when I left clicked on the slider and dragged it would show updated values, but as soon as I released the left mouse button it would drop to 0. However, if I closed the Autopan Speed dialogue box and re-opened it, it would show the updated value.

    As I was reviewing this, I noticed a few other minor issues:

    I spoke to soon on the off-by-1 bug, while "Region", "Fixed Region", and "Fullscreen" all seem to work correctly, "Window" is still adding 1 to the X an Y values. A 800x600 resolution window will produce an 801x601 capture area.

    Also, the "Tools" menu has a grayed-out "CamStudio Movie Player" and "CamStudio Movie Player 2.0" options that don't work. Similarly, if "Options>Program Options>Play AVI" has the "Use CamStudio Player 2.0" checked, a "Error launching CamStudio Player !" warning pops up. If "Use CamStudio Player 1.0" is checked, everything seems to work just fine.

    Lastly, forgot to mention this earlier, a blank "filename.xnote.txt" file is created in the same directory where an AVI is saved. I'm not sure if this is intended behavior or not, but it might be confusing to new users.
  • Rename your PlayerPlus.exe to PlayPlus.exe to fix player.

    Yeah... something definitely should be done about +/-1 pixel :-) Also if I drag capture region, I get distorted video. So it further changes rectangle when dragging.
  • edited October 2010
    Hi Phosgram,

    Thanks for your report and valuable comments.
    I just checked and noticed that this happens with "window" selection but also 'Select Screen' with (both are using the same logic.).
    I thought I had covered this. Must assume that there are somewhere still a few height/width modifiers operational.

    Also, the "Tools" menu has a grayed-out "CamStudio Movie Player" and "CamStudio Movie Player 2.0" options that don't work.
    No idea why this is. Now idea how this was showed when version 1.0 was released. Must check
    "filename.xnote.txt". Caused because I use Camstudio mostly with xnote to store references to time and frames I'm interested in.
    I have some plans to use this file as some kind of recording specific log file. See it as an future recording specific metadatafile so we know more about which version is used, how a recording is made and which events occurred when.
    If it occurs that this file is empty we can instruct CS to remove the file for us.
  • Still doesn't support ffdshow though, since it doesn't appear in the codec list choices.
  • I get the following error message when I tried to launch the recorder. Can anyone tell me how I can go about correcting it?

  • The side-by-side error message as regarded a previous release was discussed in the following thread, which is now on page 3:

    I don't know if it contains a solution, but it would be worth reading, I'd think.

  • Just released r294 on Sourceforge.

    Only a few minor changes.
    * Region 'Window' and 'Select Screen' in case of multiple screens now calculate the pixels correct either.(but it still fails on my multiple screen system)
    * Temporally and final files are now created in the directory you have specified in "Directory for recording"
    * Log file ....xnote.txt is renamed to ....txt and shows now besides xnote information also the version and release number of the executable.
    * Inside the code 'Playerplus.exe' is now invoked instead of 'Playplus.exe'. So it will startup. (My personal opinion; Don't use it at all. On can better use player.exe or use local player.)

    BTW. Changed title of this discussion...
  • edited October 2010
    Downloading latest community build now, portable version soon!
    Portable version up!
    As always, it's in the downloads page.
  • @Supanut,
  • Janhgm your welcome.
  • See this page of screen shots I just added to my hosting to compare the odd variations of codecs appearing (all are installed on the same machine!!)

  • hmmm
    I while ago I also had the impression that I did not got all installed codecs in the codec selection list. Happened after I installed an additional set of codecs.
    As far as I'm aware I did not even touch the code for this selection function and I believe it is some library function that auto read all available codecs.
    I did not checked it as Terry did with previous versions of Camstudio.

    Did you created you overview of available codecs on the same day?
  • Janhgm,

    Yes - those screen shots were all made the same day in the same hour. Very revealing that something odd is going on.

  • It was still an issue on the list of things to explore. Your work shows that we must explore why this is behaving so strange.
  • HI all

    here Some Bugs I found on v2.6 R294:

    * If opening an AVI with VLC ( the image has a wrong color map. (With Windows Media player this doesn't happens)...It is a codec problem?

    * I like to use a default folder for records ... but when closing and reopening Camstudio it forgots the specified path and it wants to save on the program folder

    * [Bigger bug] If Menu/Region/Fixed Region
    Enable "Drag Corneds to Pan"
    Then recording and changing the region position the AVI will be wrongly saved (happens also if moving the region during a rec pause).
    The image will be aliased streatching the image on a diagonal. This happens with all the players I used to view the AVI.
    The problem grows after every region moviment is applyed.
    (The problem doesn't happens if panning the rectangle automatically: Options/Enable Autopan)

    The problem is similar to what I see at this link (Sorry but I haven't found another way to post you any image):

  • Russell78,

    The Drag Corners to Pan issue MIGHT be a hangover of the old measurement error issue that has plagued several iterations of CamStudio (in 2.5beta it was the Region/Window setting, in 2.6 r264 it was the Region/Fixed setting under by one, so you had to compensate by adding one to the setting to get what you desired). But thank you very much for catching this one - I'll verify it on my machines and submit it to the Sourceforge bug registry.

    VLC has had issues with CamStudio for quite a while, though I do not understand the particulars of why.

  • edited March 2011
    This is the issue I'm having with CamStudio 2.6b. Every video I record is like this. This did not happen with the previous version. I'm what's known as a Let's Player on YouTube (basically I play games and provide commentary over them), so I chose to try and record footage of a game I wanted to try and LP. However, I encounter this bug. I'm using CamStudio ver. 2.6b, with the Lossless Codec version 1.5 which was installed with it. Recorded fullscreen. I enabled autopan, as Russell78 suggested, but that didn't help. Also, my audio did not record for some reason, even though my microphone was selected in-program and plugged into the computer while I was recording. I'm going to try using a previous version. I don't wanna play around too much with the codecs because I'm not very tech-savvy.

    This is the video I just tried to record. As Russel78 stated, the screen seems to be stretched diagonally, distorting the video. Also, for me, the colors are distorted too.
  • edited March 2011

    Which revision of 2.6b did you use? r264, r272 or r294?

    In one of those, full-screen was giving problems. Can you try setting fixed region to the same size? Also, if you still get skewed video, try adding or subtracting one to the width and height - that fixes an old problem that used to plague the Region/Window setting, but now may plague the Region/Fixed Region setting instead (so for 640X480, enter 639X479, for instance, or try 641X481 - the "window" bug fix may have thrown off the "fixed region" setting) For wide-screen videos in YouTube, using 856X480 works well with all codecs, it seems, but you may still have to experiment with adding/subtracting a pixel from the settings.

    I am sorry, but this has been a busy season for our programmers, and one has disappeared mysteriously (and we worry a bit!) Eventually all these bugs will be squashed, and you are being very helpful by helping the programmers pin them down.

    Even though you do not feel very tech-savvy, I still recommend you install and use the Lagarith Lossless codec if your videos are shorter than 9.5 minutes (assuming 16-bit audio). It requires no special settings to work - just select it and enjoy good frame rates and adequate compression for many applications. This is much, much better for game recording than CamStudio Lossless Codec, which was designed only for mostly-still screens.

    I cannot imagine why your microphone is not being recorded. Are you using Stereo Mix for the source? (from the "microphone options" settings?) There are two videos in this playlist that discuss using Stereo Mix.

  • edited May 2011
    The Region==>Window setting in 2.6b r294 is exhibiting the "Return of the Added Pixel" issue that plagued 2.5b.

    To get around this using Sizer ( ), for a 1280X720 desired capture window, set Sizer to set the window size to 1279X719 and you'll be OK. The resulting recording will be at 1280X720.

  • Every time I try to instal the camstudio 2.6b it indicates- unable to execute file camstudio 2.6b/recorder.exe. Create process failed; code14001. The application has failed to start because the application configuration is incorrect.
    What to do?
  • edited May 2011

    Two questions - what operating system are you using, and did you try running the installer by right-clicking and choosing "Run as Administrator" from the resulting menu if you are in Vista or Win7?

    Third - do you know if you have the Microsoft C++ runtime files installed?

    2008 version

    2010 version

    Don't worry - we'll get you running. I can't think of one time it hasn't been something simple like those items above.

  • I'm using Windows XP. At the time of installing the OS I kept the password for Administrator blank. Now, while trying to install Camstudio 2.6b it does not accept any password. What to do now ?
    MS C++ runtime has been downloaded. Thanks for the advice.
  • SChaudhuri48,

    Camstudio installs into its own directory and has no bearing upon passwords, so there must be something else going on. This entire situation indicates something odd going on that likely happened before you tried to install Camstudio. If you search here, you'll see this was the first time this error message ever was delivered while trying to start up CamStudio. I have a bad feeling that your hard drive is beginning to fail.

    In XP, there is no "run as administrator" choice. That didn't emerge as a problem until Vista.

    I recommend you un-install Camstudio and start over with the original again. It will all be in its own folder, so you can troubleshoot from there.

  • Also, I recommend against using full-screen captures with most codecs.
  • Try 1280X720 using the fixed region method, and set the left corner to 0 and the top to 100 and you should be ok.

  • Hi, I'm having the same installation problem with "CamStudio_Setup_v2.6b_r294_(build_24Oct2010).exe" as SChaudhuri48.

    I'm using XP SP3, have administrator rights and have installed "vcredist_x86.exe" - Microsoft Visual C++ 2010 Redistributable Package (x86).

    When I try to run Camstudio from the Start Menu, I get the message box:
    "C:\Program Files\CamStudio 2.6b\Recorder.exe
    This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix the problem."

    Would it have anything to do with some missing dll files? The readme file "Readme_Camstudio4Xnote_v26r294.txt" mentions 3 files but this appears to relate to Xnote only.

    Should I try installing an earlier version of Camstudio? If so, which one?

    Regards, KingT
  • KingT,

    I don't know. This is odd to be creeping up all of a sudden with two instances of the same issue all at once that never came up before in my memory.

    Try installing one of the earlier bulds, perhaps, like r264.

Sign In or Register to comment.