This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Waveoutgetselectcontrol() Failed

edited August 2008 in Support
I get this error when trying to Record Audio from Speakers. HOWEVER, please look at the below, as my problem (I believe) is different then the 'norm'

1. I am using Windows Vista (No surprise there)
*2.* I have no "Stereo Mix" or "What-U-Hear" options (Yes, I have Show Disabled/Disconnected Devices)
*3.* In Record Audio for Microphone options, I can click "Volume" but NOTHING happens. At all.
*4.* I am using headphones, but they are treated as speakers, hence why I need to record audio from Speakers. I CANNOT record by Headphones because then no audio comes out (Trust me, I've tried re-arranging and reconfiguring every possible option and outlet to get it to work and nothing happens)

If needed, I can provide screenshots of my audio options.


  • Hi OdinReborn

    Yeah, please post links to as many screenshots as you can take on your audio options.

    I'll take a look.


    Nick :o)
  • When I do this as instructed...

    Options > Audio Options For Microphone > Volume

    ... nothing happens. Nothing opens up. It's like the button has no purpose.

    I'm using Windows Vista Business Edition (32-bit). I've tried it with UAC both on and off; no difference.

    Any ideas?
  • Denegar

    I'm guessing this is because the locations for certain functions in Vista are different to XP, which CamStudio was written for.

    So you'll need to change your volume in the usual way in Vista (right-click speaker icon in system tray > Recording Devices > double click Microphone > Levels tab


    Nick :o)
Sign In or Register to comment.