This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

YouTube Glitches

edited January 2012 in Support
Hi there! I've tried everywhere else, so you guys are my last resort. :)

When recording with CamStudio, my videos look fine on Windows Mediaplayer, VirtualDub or Windows Movie Maker, but when I upload it to YouTube, it's full of glitches. The colors run down the screen, sprites and such don't update (when King Graham in King's Quest (lol) moves across the screen, an after-image will remain, so it'll look like there are two of him), and sometimes the audio will click or pop. The funny thing is, these glitches are intermittent. Sometimes I'll have a problem (more often than not), and sometimes everything looks fine.

I've tried all different codecs, and none of them improved the situation. I'm using XVID now. I also tried using HyperCam, and the problems occur there too, so this is not a CamStudio-specific problem. Hopefully, someone here will be so inclined to help me anyway. It's not a post-editing problem, as I've uploaded raw footage and gotten this problem. I even tried, at someone's advisement, to use Any Video Converter to convert the file into an MPEG4. I still get glitches, but they look a bit different.

Is there any way to eliminate or at least minimize these glitches? I can provide a link to an example if you like. Oh yes, and I'm using Windows Vista. Thank you so much for your help!

- Amy


  • Bueller? Bueller?
  • Hi Amy

    Some questions ...

    1) Which version of Camstudio are you running? (Check the Help > About box for specific information)

    2) Are you running Windows Vista 64-bit?

    3) Are you running CamStudio in XP Compatibility Mode or is it running "natively" on the system? (i.e. You installed it and it just runs as any normal piece of software)

    4) What are the video codec settings you're using in CamStudio *and* the actual codec settings (in the codec's configure screen)?

    Take screenshots of the various bits in CamStudio and upload them to or similar, it'll save typing :)


    Nick :o)
  • Hi Nick!

    Thanks so much in advance for any help, whether fruitful or not. This has been plaguing me since July of last year!

    1) Version 2.0

    2) Yes, Vista 64-bit.

    3) The latter. I haven't tried compatibility mode. Might this work?

    4) Codec settings (both screens):

    Thanks again!
  • Hmm, I'm not sure that the old 2.0 version of CamStudio runs correctly on Vista 64-bit.

    Could you try downloading the latest 2.6beta build, record a 30-sec test video using your settings and upload it to YouTube so I can see it?

    Also, you *might* need to install Celtic Druid's 64-bit Xvid codec from here:

    Let me know how that goes


    Nick :o)
  • Urghh! Bad news. I downloaded 2.6, but it won't even start recording. I double-checked that I had set it up just the same as the 2.0 version. I tried all the different region settings, and I never get the flashing rectangle (when it is set as not hidden), and on the status screen, I get all 0's (for current frame, for example). So it's not recording, yet the record button is "depressed," and I can "stop" the recording. The status window also states that it's recording with MicroSoft Video 1, when I had it set to XVid. (By the way, I did download the Celtic Druid codec, and thanks for that, but I'm not sure if it's even showing up in the CamStudio codec list, as it appears in the list exactly as it did before install... I figured it would show up as "XVid codec 64-bit" or something, not just "XVid MPEG-4 Codec.")

    Thank you so much for all your help so far!

    - Amy :)
  • I first got steered to CamStudio by Youtuber Aulddragon, who referred me to this video by Lateblt on "How to make Let's Play Videos:"
    Lateblt did Let's Plays of a number of the old Sierra games (such as the Quest for Glory series). His instructions on the video above are for Windows XP; however, TBritton's instructions (here & on YouTube) on how to record both gameplay audio & narration in Windows 7 are quite helpful. I'm using CamStudio 2.0 without any problems on my Windows 7 64-bit computer, so it should work on Vista 64-bit as well.
    I use the CamStudio Lossless Codec 1.4 myself; however, my Let's Plays are almost all of old DOSBox games (a different codec might work better with newer games with more animation, especially if you can keep the episodes fairly short).
  • Thanks, but all that is not a problem. I tried all those codecs and I still get the glitches in audio and video. The vids play absolutely fine in Windows (Media Player, VirtualDub, Windows Movie Maker, etc.). They only appear full of glitches when viewing on YouTube. Since everything works fine for everyone else, I'm wondering if it's a graphics card problem on my computer or something.

    By the way, I am also playing old DOS games too, as well as Amiga games and Indie remakes. My username here is the same as my YouTube name. :)
  • Catherine, just a wild guess: Are you DosBoxMom?
  • What is most puzzling is that these videos look great in other media players UNTIL YouTube gets a-hold of them.

    Try converting to an MPEG-4 format using anyvideoconverter or freemake video converter or MediaCoder FLV edition (use MPEG option with options set to baseline so it will work in WMP)

    Then upload that to Youtube and see if it plays nicely with that.

  • I've already done so. See the end of the 3rd paragraph in my original post. :) The errors look different, but are still there. The video glitches look a bit different, but still as bad (hard to describe that). The audio glitches change from a clicky-staticky sound, to a more digitized-sounding garble. I've tried converting both to MPEG4 and FLV, as I've been told that YouTube currently converts vids to MPEG4, and that their old format was FLV. FLV looks horrible! And I still get the glitches also. Joy.

    In case you're curious, here's a video with both some video and audio glitches right in the beginning. Also, at about 1:39, you can see a good example of how video elements don't update immediately. There's a "hand" pointer that remains in a separate area, after I've moved the pointer, and cycled through some other pointers. At 20:40, you can see when King Graham walks off screen, an after-image of him remains behind. If the screen hadn't refreshed with a new area, the image probably would've remained longer. These after-images have remained for up to 10 seconds.

    Anyway, linky:

    The strange thing is that these glitches are intermittent, and seem to be random. If I deleted that video and uploaded a new one, I'd probably have glitches in other parts of the vid, or... if I'm very lucky, no glitches at all. Just the other day, I uploaded a Dungeon Master vid, and the second half of the video was a loud static. I deleted that sucker, of course, especially because it hurt my ears, and undoubtedly would hurt the ears of anyone using headphones! I uploaded it again, and no static at all. Same glitches as usual, though. That's only happened once, thank God.

    Thanks for all your help! I'm thinking this may work on another/better computer? I can't see why not.

    - Amy
  • edited February 2012
    I don’t have an answer, but I can offer a few suggestions.

    First, I’d set up a separate Youtube “test account” to upload 30 second test clips with nonsense tags (to keep them “invisible”) to avoid wasting time on longer uploads.

    You want to remove all of the variables you can to see which is causing the problems with your uploads. Both HyperCam and CamStudio HD720 output produces a packed bitstream AVI. Youtube processing removes the extra frames, but may be stumbling while doing so. Try a short test clip with Cam (BTW I’m using 2.0), using the following settings:

    Framerates .... 40/25
    Then click on “configure” and on the Xvid Configuration panel, choose:
    .. Generic Standalone
    .. Quantization Type: H 263
    .. Target Quantizer: At least 2.0 or higher
    .. Quality preset: Real time
    Now, next to “Generic Standalone, click “more” and:
    .. Uncheck ALL other boxes on that panel - most importantly packed bitstream

    That will produce a video which should be fairly Youtube friendly. I don’t really know why you’ve had the problems with FLV uploads. Sorenson/FLV videos usually work quite well on the “Tube” although it seems to have problems specific to values (light/dark) with these.

    Anyway, it’s something to try.

  • Thanks, Ken - I'm definitely interested to hear what Amy comes up with after trying your suggestions. I didn't know about the packed bitstream issue. My videos have never had any issues at all, but if/when then do...!

    The only other thing I can think of that would be making these audio glitches would be the recompression of one compression format into another. So, perhaps I've never encountered such because I ALWAYS check "Use MCI to record" in the "Audio options for microphone" section. That makes a big file, but still well under the 2GB max limit when using Xvid. It forces 16-bit, 44.1kHz audio (system audio), which YouTube likes, as the audio quality is stellar in the 720p HD (and even 420p) videos I've produced.

  • My apologies for the delay. It took me awhile to find time to fooling with this. I appreciate both your comments, and all the help and ideas given. Thanks so much! Unfortunately, the errors remain. Some details:

    I kept this vid on the same channel, but had it set as "unlisted." Nobody could see it unless I put in a playlist, or gave a link to it. ;) I made the video a bit longer, so as to better catch these intermittent glitches. It proved to be unnecessary, though.

    Ken, I was able to set everything you specified, except for the "Generic Standalone." Would this have been found under the "Profile @ level" dialog? I couldn't find any setting with that name (and many of the other settings had "Packed Bitstream" checked and grayed). I thus chose "(unrestricted)" for that dialog, and I was able to select all the other choices exactly as you had specified.

    Terry, I've been using the "MCI to record" setting since the beginning. I learned how to use CamStudio by watching your excellent videos. :)

    Thanks again to both of you. Here's the video:

    - Amy
  • Terry’s advice re audio is right on the money. I would just add that it’s a good idea to make sure that it is set to your specific device and not to the generic option.

    You’re not getting the options mentioned in my post because your MPEG 4 codec version doesn’t support those options. Go to:

    and download the 32 & 64 bit (Stable - EXE installer) and install. When properly registered (it worked perfectly for me) those options will show up.

    Now I’m really thinking that this is the problem.

  • Hiya!

    I have MCI recording set for "Stereo Mix," as apposed to "default input device." Those are the only options in that box. I'm thinking all is well there.

    The good news: I downloaded the codec you provided, and installed it... and the option for "generic standalone" did indeed show up.

    The bad news: When attempting to record, CamStudio crashes with the following error box:

    I went back to my default settings whilst using this same codec, and it still crashes, so for some reason, there seems to be some problem with that codec and my system. Keep in mind that this isn't the only codec I've tried. I believe that the first one I used was the one that came with CamStudio 2.0 (though that was almost a year ago, so details are fuzzy there). The second one was Celtic Druid's 64-bit Xvid, as provided by nickthegeek on Jan 30th. Both of those work fine, this one doesn't. *shrug* Unless you have any ideas on why this is crashing or how to fix it, I'll have to stick with the former codec.

    I'm wondering if it's just my system, as far as the original problem. Have you heard of anyone having issues with CamStudio and Intel G33/G31 Express Chipset Family (Intel integrated graphics chip)? A lot of people disparage this graphics adapter, but I figured it was merely because of sub-par performance, not bug-related issues. Now I'm beginning to wonder...

    - Amy :)
  • P.S.- By "work fine" in pertaining to the two previous codecs used, I of course meant that CamStudio doesn't crash. lol ;)
  • P.P.S. - VirtualDub crashes now also. Their error screen is a bit more informative as to what may be the problem with this new codec:

    Here's a link to VirtualDub's crashinfo.text (error dump file):

    Just in case anyone's interested. As for me, they might as well be writing in Japanese. :P

    - Amy
  • Yes, the box at the top of the audio should say “Stereo Mix” as yours does. That means that the program has recognized the fact that you have enabled the stereo mix on your computer, as opposed to seeing just the generic default input device. You might also want to look at the Stereo Mix properties to make sure that the “listen to this device” (if it has that) is UNchecked.

    The integrated chipset you have is a weak one, in terms of intensive games and such, but you’re not asking it to do anything like that, so I can’t see where it could be causing problems. Intel seems to suggest that a rollback may be in order in the event of some types of glitches, but that seems like a somewhat Draconian approach to dealing with this type of problem.

    The links to your CamStudio errors don’t work for me, so I can’t see what’s happening there. I have the same Jawor’s version, as well as the very same VirtualDub build that you’re using on my 3 computers, so I’d really like to hear Terry’s take on the crash situation, and why the mere presence of Jawor on your computer would cause your VirtualDub to crash as well. That program (VDub) did have a known bug which would have generated a “divide by zero” error, but that was supposedly fixed on the version you have.

  • Make sure you have the 32-bit version of Jawor's Xvid installed, even if you do not go with the dual 32 plus 64-bit version.

    I've never heard of it crashing CamStudio before, so I suspect a bad download, maybe.

    Uninstall it first, then re-install a fresh download. You only need the 32-bit one for CamStudio, so maybe start with that one.

    If it works, we'll at least know it was just a corrupted file. Then you can install the 64-bit one for your 64-bit VirtualDub and 64-bit WMP (the only two things I know of that run in native 64-bit that would use a codec!)

  • Ken: I don't have a "listen to this device" setting anywhere. I don't think that the audio is the issue. It's how YT is interpreting the videos, for lack of a better word. :) I still have that info from the program crashes, so if there's an easy way to share it, let me know. The VirtualDub error did say "divide by zero," but it's the same VDub that I've been using since June, and once I switch back to Celtic Druid's codec, all is fine.

    Terry: I uninstalled and then installed the 32-bit version. The same thing happens. CamStudio just crashes. I uninstalled that & installed the 64-bit version. It won't show up in CamStudio's list, probably because I'm using the 32-bit CamStudio? (Reminder: The newer alpha build CamStudio won't run at all... more crashing.)

    - Amy

  • There is an alpha build????

    (I didn't know... alpha builds are for testers and the most brave only...)

    Yes, CamStudio is a 32-bit application, so it needs 32-bit codecs, as do most of the audio programs on your machine other than the two I mentioned above that I know of.

    I can't imagine what could be happening there, unless some chipset update is messing with you. Or, something must be different in the settings being used in these latest videos being produced that is subtly different from the older videos that worked.

    It is still the same old CamStudio that it's been for a long time now! (That is soon to change - update imminent.)

  • If it were my computer, I’d consider the following things:

    It’s not a chipset issue. Considering how common that chipset is, if it were, this board would be flooded with reports of problems similar to yours, and I don’t see any others at all. Yes, it could be a problem with a bad update, and Intel does seem to acknowledge that this can be an issue on some machines and suggests a rollback in these instances.

    The first sign of a problem occurred back when 2.0 was working, but producing video which would not work with some applications. That still suggests to me that CS was more a victim of the problem, rather than the cause, especially since material produced by other programs was having similar problems. The (messy) workaround for this, as it relates to the Youtube issue, is just to load the file into a free editor like Avidemux and re-code it as an MPEG (PS A+V) and send it along to the Tube. That program will not properly load without un-packing, so any frame issue will be resolved at that point. If Avidemux cannot load the file at all, it suggests that this whole thing is a codec issue, and again if it were my computer, I’d dump the entire collection of codecs and start from scratch. The fact that the Jawor 32/64 bit version caused a problem really jumps out at me, because it’s exactly what we installed on our Vista machine, and it seems to be peacefully coexisting with the codecs which were already there, including the vanilla MP4 version. I’d be suspecting something quirky is happening with the Xvid or DivX components already installed, and that would also be the cause of the Youtube glitch. Memory crashes or those related to the registry in VDub seem to be fairly rare. The “out of bounds” variety are seen far more often, but since you can’t even get that program to launch, we can’t see what error code we might be getting if you were able to load a video. Since VDub is an easy program to uninstall and reinstall, it wouldn’t hurt to try that. (Go back and get a new download, rather than using your last exe file, just in case), however, my guess is that with better codecs, properly registered, those problems will go away on their own. It might be useful to hear from someone who has had Vista 32/64 bit issues and has been able to solve them, and whether older codecs might be contributing to or causing the problem.

  • Heck, I don't know why this slipped my mind to mention...

    I've been having major problems with DivX for a year now, and have written them detailed support requests asking that they fix whatever they've done that makes DivX break CamStudio. I gave up last August. At one point, their release wouldn't allow CamStudio to run at all till DivX was removed! At an earlier point, their updater took over people's computers, maxing out their CPU at 100% (You'll see in some of the tutorial videos that I mention that... and a work-around hiding the updater files. At least the codec worked then!)

    Having witnessed all these persistent problems with DivX, I've ceased using it, even though I bought it. Jawor's Xvid, discovered via the doom9 forums, has more than made up for the loss...

  • I'm sorry for not responding for so long. Strangely enough, for the last 4 or 5 days, my vids have been uploading to YouTube (and playing) flawlessly.


    Maybe my uninstalling and re-installing codecs just finally nudged something in the right direction. Or maybe YouTube tweaked their in-house compression a bit. I would fool around with this some more, and try the things that the both of you mentioned, but:

    1) I'm afraid of going back to the way things were, since I still don't know how it was fixed.
    2) I'll have a new computer in a few weeks anyway, and will cease recording on this one.

    As for your other questions:

    Terry: Not alpha build, I meant beta build (2.6), sorry. That's the one that crashes on me once I try to start recording. I'm sorry for your DiVX troubles. I'll remember to stay away from that. Once this new computer comes, I'll still be using CamStudio for whatever Fraps doesn't want to record. I imagine I'll just stick to XVid in those instances. :)

    Ken: I really appreciate all your help and ideas. I seriously do. Since things are working for now, though (knock on wood), and since a brand new computer with a different setup is on the way, there wouldn't be much point to go uninstalling & reinstalling things now. But thank you.

    Thanks to both of you. The problem may not have been fixed in any way that I can understand, but I did learn a lot from reading your responses on here, and from Nick as well! :)
  • That's great news! I wouldn't put it past YouTube's engineers to be constantly tweaking things over there! ;-)

  • You know, there's something I realized here, that may have a connection to this problem and it's sudden disappearance. I read what you wrote above about DiVX. Now, I've used this codec for encoding all of one time, in trying to fix the problem you were trying to help me with. (It was before I even visited this forum at all.)

    I've never had a problem with DiVX that I can tell (but who knows, right?), and about the same time that my vids started uploading right, DiVX stopped working. It would crash intermittently, and I would get these errors from Windows that "COM Surrogate has stopped working." These errors would repeat over and over in a loop; COM Surrogate would crash, restart, crash, restart, etc. In looking for a solution to this, I was seeing advice on how to uninstall codecs from your system. (Maybe related to my uninstalling and reinstalling the Xvid codecs multiple times?) I didn't want to mess with any codecs, since my uploads were FINALLY working correctly. I saw another solution of not having thumbnails in your video directories, so I opted for that.

    I can't help thinking this is all connected somehow. I don't use the DiVX codec. I use Xvid. Why it would keep crashing when I used it once back in September, I have no idea. I know that I've had it on this system all along. Maybe it was being used as a decoder for .avi file playback? Or maybe it's just used for displaying the thumbnails of video files? I don't really care either way. But perhaps it was interfering in some way, in the recording of my videos.

    Just a thought. :)
  • Since you’re getting a new computer soon, have you thought about waiting till you have that one set up and then going back and digging into your old one in an effort to find the problem? I’d start with getting rid of DivX entirely and then trying Jawor’s again to see if that glitch is cleared up. My guess is that there was (and probably still is) a conflict there which pops up intermittently and differently, depending on which program you’re using .... Ken
  • I'll give it a try if/when I have the time. :)
Sign In or Register to comment.