This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

"Error recoding AVI File using current compressor. Use Default Compressor?"

edited February 2012 in Announcements
So I kept getting this error, no matter what I did. I tried using divx (with the height/weight parameters divisible by 4 and 2 as necessary - i even set the height and weight TO 4 and 2) and xvid (with height/weight divisible by 2) and to no avail. No matter what I would do, it would not work, and I spent soooo much time trying to figure it out. I tried every other codec and no matter what, no worky!

Thankfully I have an awesome coworker who finally figured it out.. It couldn't work because the folder that it was writing to.. I didn't have permission to write to. Such a simple fix >.< changed destination folder to something else, and viola, it worked!

I just wanted to post that here because i spent, literally, hours making it work, and I wanted to save someone else the frustration - just in case anyone else was having the same issue.


  • Oh, Gadzooks! Thanks for pointing that one out! It hits Vista and Win7 folks who use the basic settings that try to write to their program files folder - and the security settings in those two operating systems don't like that!

    Glad you found your way clear!

  • It has nothing to do with file permissions. I'm using 2.6. I'm the only user on this pc and have full access to every file, folder on it. But I still get that error; I specify a custom directory and file name, instead of the default settings and it still gives me the error. I tried it twice recently: the first time it worked, because the record window's dimensions were within XVID specifications. The second time I tried it, it gave the error, because this time the window was slightly bigger in width and height than XVID specifications. But because I don't know what the window dimensions were, it's a matter of trial-and-error. It gives the error most times (and when it says "use the default compression?" it fails to do that too).

    I still cannot get CamStudio to use compression consistently. While I have the latest DIVX codec installed, it does not show up in the available codecs list. I can only use the codecs which don't use compression. But given that a PCM wave file (which is what they use for audio) has a size limit of just over 2GB, this means there is a file size limit on the final video. (I've tried using audio compression - LAME, etc - but it ignores it and uses PCM instead). Meaning the video can only be relatively short, which renders CamStudio useless if you want to make longer videos. I've found that a 5min video is 32GB which is just stupid. I will not use CamStudio again until I figure out how to make it use compression, or if it gets improved in later versions.
  • Though YOU may have access to every folder in your computer's hard drive, programs are a different story.

    Where are you putting your custom directory? I have mine in My Videos and have no issues.

    To select a region of a known size, use the "Fixed Region" choice, and the "Select" button will allow you to use your mouse cursor to select a section of your screen. Then, adjust the numbers manually to be even numbers.

    That "default compression" is Microsoft Video One - awful stuff, really.

    DivX may be the cause of all of your problems. It did not work at all for months and months last year - totally froze CamStudio and recorded only a single frame. Use Xvid instead - superior according to the doom9 forums folks.

    Check "Use MCI to record" and compress later on to preserve good audio/video sync, and refer to my video and articles listed in the sticky post above for best settings.

    I record 3-hour videos with Xvid set at its highest quality setting of 1, using MCI to record at 1280X720. Is that long enough to satisfy you? That's keeping under the 2GB file size maximum that the AVI-1 container we are still using limits us to. I then compress the audio even further in post using Any Video Converter converting to MP4 using the AC3 audio codec (mp3 sucks for MP4 conversions and often throws the sync off.)

    Patience. I appreciate your frustration that things don't just work "out of the box", but CamStudio has many settings, and that flexibility is actually one of its strengths.


  • Certainly is. But remember that if converting via VLC, don't put the movie into your iTunes library.
  • edited March 2012
    How do you convert via VLC? I thought that was a media player only? (Interesting...)

  • I looked and it has a converter, (CTRL-R) but I cannot tell what format it is converting to - perhaps that only comes up during the actual conversion (that is, you have to do one.)

  • I like Any Video Converter's Custom MP4 conversion with AC3 audio. Good sync, good quality from Xvid originals, and works on all media players.

  • I have the same error while trying to record from "Window" instead of "Full Screen".
    It has nothing to do with file permissions, because I successfully recorded in Full Screen mode and the program was able to create it's files.
    Initially I didn't change any settings, but, as it didn't worked, I set Video Options compressor to be XviD MPEG-4 Codec. It didn' help - same error.
    Then I changed compressor to be x264 - H264/AVC encoder. After try to record in Window mode the program crashed with a standard Windows error message.
  • edited October 2012
    There definitely is a problem with certain versions of CamStudio in capturing full windows - not always, but with certain hardware configurations. The famous "one-extra-pixel" bug rears its ugly head, turning the even-numbered, MPEG-4 compatible width and height into an MPEG-4 incompatible odd numbered width and height.

    This problem oscillates between versions into either the fixed region or window region as well. 2.6b it is in the window, so I have to set Sizer to a pixel smaller when auto-sizing my windows. In 2.6c, it is the fixed region that requires I subtract a pixel, and my window regions work correctly without the pixel fiddling in Sizer. So in other words... what a pain!

Sign In or Register to comment.