This forum software has now been archived into static HTML page (i.e. it does not function as a working forum anymore, so you cannot login.)

In due course a new forum will be available to help support newer CamStudio versions.

Sorry for the inconvenience and thank you for your patience.

Save fails

edited May 2012 in Support
First: I'm very happy to have found CamStudio. Such a fine project!

But I had no success. After producing a video, Save failed with something like "could not copy/rename audio file". (I hope that's close to the actual error message.)

I tried a number of times ... nothing fancy ... and failed that way each time.

Is that meaningful in some way?
I can't think of what might be causing it, so can't think of how to fix it.

A known issue?



  • edited May 2012

    First, make certain it is set to "Ask for Filename" so you can save it to an un-protected space like your My Videos folder. It is possible that it is trying to save it where your temp files are being stored, and that may be protected space (on many machines, the Program Files folder is such a protected space).

    Second: Was that file size possibly over 2-gigabytes? If so, there is a limitation there that cannot be overcome in the AVI-1 package CamStudio uses.

    If trying to use the lossless codecs (CamStudio Lossless or Lagarith, etc.) the files get oversize in a mere 11 minutes!

    Watch the "2012" tech video I just put up on YouTube mentioned in the sticky post near the top here. It explains how to use Xvid as a compressor, and the YouTube info box has all the links you'll need.

  • edited June 2012
    Terry, I am having the same problem. It doesn't matter how long the video is. I tried it with about a 20 second segment to test it, but I get the error, "File creation error. Unable to rename/copy audio file." I have it prompt me for a file name and i save it on my data drive that is not even associated with my C: drive. There should be no problems with file permissions there.
  • edited June 2012

    Perhaps the temp folder is not accessible for some reason. Try doing what I do in the "2012" tech video, setting the temp directory to one inside the "My Documents" folder.

    That's just a guess at something that may be affecting this.

    Another thing to try would be to run CamStudio as an administrator.

    Could it be a codec error? What codec are you using? Does this video test include audio?

    We'll get to the bottom of this eventually...

Sign In or Register to comment.