Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Recording are choppy

Whenever I make a recording, it always comes out really, really choppy. I've tried different frame rates and playback rates, as well as turned down the quality. I do not have the recording region in full screen; it is only set to fit a standard sized YouTube video. It's even stranger because I have PLENTY of free disk space, as well as a virus-free computer with a fast processor.

But yet, even with all of that, the recordings still come out choppy. Can anyone give me suggestions on how to make the videos smoother? Thanks.

Comments

  • I meant to put recordings are choppy >.>
  • You didn't mention which codec you're using, but I would assume it's MPEG 4 of some variety? If by "choppy" you mean something with an irregular pattern of motion, the problem most likely involves the fact that you're overtaxing your computer's processing capicity. If the "choppy" is actually "frame flutter", it means that your MPEG compressor is producing a VOP sequence which your players can't deal with.

    The first thing I'd try doing is to create a more friendly environment for Cam to work. Temporarily shut down all A-V programs, aggressive firewalls (like Zone Alarm), messenger services, updaters and anything else which may be taking resource and is of no use to the process. Don't bother trying to change screen resolution and graphics accelateration, and don't bother to shut down the monitor, because those things will make little difference.
    Now do your MPEG capture at 5/200 with 200 key frames setting.

    Look at the video in Terry's "2012 Cam Studio 2.0 ... " thread, specifically at the Any Video Converter portion. Take your AVI into that program and export as MP4 using a 30 FPS setting.

    Assuming you are producing video with a reasonable frame sequence, the result will most likely be as good as you're going to get with your machine on high motion capture. Beyond that, all you can do is try capturing a smaller area, or using a full feature video editor to tweak the product.

    Ken
  • Ok thanks. Well, as for the codec, I'm using the Cinepak Codec by Radius. By "choppy", I basically mean that after I record, and play back the video, my computer doesn't lag, but rather, the video itself seems like it only updates a frame only every half a second, coming across as not having smooth motion.
  • I did a test using that codec on the same streaming video I usually use for my tests and got the same result you're getting. My opinion is that it's totally unusable with Cam, and the better option is to try Xvid MPEG-4. It's much faster and smoother.

    Ken
  • Ken and Nick,

    Interesting to hear about Cinepak. I see lots of people try that without much success, but once in a while somepne reports using it and liking it. I'd stay away until we discover the limitations it is working under - it may only like certain capture and playback rates.

    Terry
  • @Terry: Hmm...well, I guess there's nothing much that I'm required to do right now...but there is many things I would certainly like to do. But either way, thank you for helping me, TerryBritton and bmoreken.
  • edited July 2012
    Nick7cool,

    Do take a look at this video at YouTube - it has all the links to things you may require in the "more info" section. Watch in HD (720p) full-screen for best results!

    My YouTube channel:

    https://www.youtube.com/tbritton33

    And this thread, though today the video is broken there:

    http://camstudio.org/forum/discussion/980/2012-camstudio-2.0-and-2.6-b-c-tech-webinar-win7-xvid-audio-video-settings-etc-



    Terry
  • Thanks. I watched the video. I also downloaded Jawor's Xvid, and made that the compressor for CamStudio.
  • Wait wait...well, I did get the notification saying it couldn't record using the current compressor. So I tried what you said with making the region be the width and height that you want, - 1. But I still get the error notification.
  • Nick7cool,

    That's odd! What sizes were you going for? I've had good luck with 1280 X 720 (or 1279 X 719 if having to make the adjustment).

    Terry
  • Actually, I think I might've fixed it. I tried recording a couple of times, and I still got the message, then it seemed to fix itself...but thank you for the help!

    If I've been annoying, sorry about that. You see, I had an old laptop which had CamStudio 2.0 on it, and then I had a bunch of trouble with it having a defective video card and such...so, I JUST got my new computer after about 3 months.

    I haven't been able to keep up with updates and all, so I pretty much knew nothing at all about the new release.
  • Nick7cool,

    No way are you being annoying - always happy to help! The whole goal is to get you recording videos that you are happy with!! :-)

    Come back with any other questions you have come up anytime!

    Terry
Sign In or Register to comment.