Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Increased region size problems (camstudio 2.0)

edited July 2012 in Support
Camstudio 2.0
Lossless Codec 1.4
Set key frames - 50
Capture Frames - 20
Playback Rate - 50
Temporay dicterory- Windows temp
Average FPS: 14

Region: 800x595 Time: 19mins Quality: 70 File size after compression: 1.7 GB

Region: 1280x720 Time: 18 mins (Quality: 70=Fail / Quality: 40=Fail)
Time: 2 mins Quality: 40 File size after compression: 120,898 KB
Multiplied up- 20 mins = 1.2 GB

The problem i get is it can't compress the file when i record for over 10 odd mins.
This sounds like the 2GB limit... but how come i recorded the first video sucessfuly?
Any fixes? i don't mind tweaking settings a little.

Comments

  • In my recent tests using Lagarith and other lossless codecs, I found that 2.0 would revert to using MSV1 when the lossless codec's presets were not respected in Cam's settings and would do so without warning. You've set the key frames to 50 and the pixel vertical to an odd number, either or both of which might cause 2.0 to capture using its default compressor, which would account for the smaller of the file sizes. In my tests, I used a capture area of 848 x 480 and found that the 3 lossless types tested reached the 2 GB file size in less than 4 minutes.

    You can look at the codec actually present in the finished files using a program like GSpot or by loading them into a video editor which will accept this type of file.

    BTW if the quality setting you use in Cam actually makes it around a codec's presets, using 40 or even 70 with a lossless will totally negate any advantage you might have by using a lossless in the first place. Also, the 14 FPS you're getting is killer, in terms of being able to capture anything with any movement. It might be caused by limited processing resource or a very slow codec.

    Ken
  • edited July 2012
    Ken,
    thanks for the reply. To be honest, I have had problems with the codec reverting to the default codec in the past and I didn't know the problem lied with the odd numbers used within the regions and the set key frames being 50.

    And honestly, I didn't some looking over of some of the videos and the fact that I'm changing the quality doesn't do anything to the output file, so you are somewhat correct there... And this is probably why my fps is so low when recording, which is why I have been experimenting with Lossy codecs, with no success so far.

    But thankyou for explaining that to me, and it has helped me a lot.

    -Jack
  • It's a good idea doing test clips of exactly 30 seconds to keep the math simple and avoid wasting a lot of time processing longer files.

    Try a test using Xvid MPEG-4 using settings of 5/200 or 10/100 and key frames set at 200. I'm using it with the "target bitrate" option selected and the value of 6400 selected. Make sure that both pixel dimensions are even numbers.

    You'll have to take the finished AVI into a program like Any Video Converter to change the output FPS to 25 or 30 to insure that players can deal with the file.

    Ken
  • edited July 2012
    Jack,

    Here are links to Jawor's Xvid and to any-video-converter, and a video showing how I set these up, among other things:


    Jawor's Xvid - http://jawormat.republika.pl/xvid.html
    Any-Video-Converter - http://www.any-video-converter.com/products/for_video_free/

    Terry



Sign In or Register to comment.