Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

CamStudio 2.6 (Build r294) + Windows7 64Bit + Codecs?

Ok, so i know this has been talked about on the net and the forums before but no matter what solution i try to use that seems to work for others i just can't fix this issue.

Problem/Issue:
I installed CamStudio 2.6 (Build r294) on my Windows 7 laptop and everything works fine, it records beautifully with very little lag while playing Minecraft but the file sizes are way to bit so i wanted to install some other codecs so that i could record in a h.264 compression.

I tried installing FFDShow, KLite Codec Pack (FULL), h.264 Codec but non of them are showing up in the list of video compressions, i then tried CamStudio Lossless Video Codec v1.4 but even this was't showing up in the list.

The only one that showed up in the list was XVid but that wouldn't allow me to record and just came up with an error message about how it couldn't record in that compression and should it use default.

I dont mind recording at Microsoft Video 1, the quality is pretty decent and i dont get any lag BUT the file sizes are through the roof and my computer doesn't have that much space on it, thats why i really want h.264 as the compression is virtually lossless but the file sizes are tiny in comparison.

Solutions I've Tried:
Well i've tried many different youtube video and forum posts explaining fixes that have found but non have worked.
someone said to use CamStudio 2.6c from the SourceForge site but this didn't bring them up in the list either.

I've also installed all Visual C++ version suggested (2008 and 2010) form Microsoft, i've tried different Codec packs (as listed above), i tired using CamStudio 2.0 to see if it was a bug in 2.6 but still nothing and i've tried several reinstalls and reboots.

Non of these have solved the issue at all, so can anyone shed some light as to what i can do to get this working?

Comments

  • Monkey,

    Xvid was giving that message because your width and height were not multiples of 2, which is required by all MPEG-4 based codecs. See my 2012 Tech seminar video for that fix among others, or search for "width" here. I use the fixed region, but it varies from computer to computer whether you need to subtract one pixel from that setting or not. Also, 2.6b vs 2.6c sometimes brings up the one-pixel-over problem. Just enter a value desired minus 1 to get it to work correctly.

    The newest 2.6c version does bring up the full list of codecs, and needs the 32-bit 2010 version of the MS C++ Runtime libraries. All the files are listed in the info area for the tech seminar. Or see this post: http://camstudio.org/forum/discussion/comment/4331#Comment_4331

    Terry

  • Thanks i worked out the XVid issue after looking specifically for that but i still can't work out the other codecs.

    As i said in the original post i've tested out 2.6c forgot to mention that i have 2010 & 2008 MS C++ Runtime libraries installed as well but they still don't show up in the list.

    But thank you for the help.
  • Monkey,

    You have the 32-bit versions? That's odd, because everyone else has reported 2.6c having the primary feature of having fixed the missing codec issue.

    Xvid is the best, anyway...

    Terry
Sign In or Register to comment.