Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Xvid codec not working, still records in MS Video

Hi!

I've read several threads and i still dont find an answer for my issue. I downloaded Xvid coded directly from Xvid webpage, selected Options->Video Options ->Xvid MPEG-4 Codec and Region -> Region to select a partial protion of the screen for recording.

Two things occurr:
a) If selecting record to AVI, I get "CamStudio could not record the AVI file using the current compressor. Use default compressor?" and the only option is "No" since "Yes" only gets the same message back.
b) If selecting record to SWF, regardless of the previous Xvid settings selection, it just records to MS Video 1 in very poor quality and very heavy file size

I've restarted, reinstalled both CamStudio and the codec, and still not working. Can you please help me??

Comments

  • You have to use a region with even-numbered values for both width and height for Xvid (or other MPEG-4 based codecs) to work. If the number is off, CamStudio will default to the MS Video 1 compressor (which sucks). If it LOOKS like the numbers ARE even (like, in the Region: Fixed Region settings area) then you likely have a version of CamStudio that has the "1-pixel-added" bug -- a bug that seems to alternate between the Region:Window and Region:Fixed Region depending upon the version. It is maddening, but can be overcome by simply subtracting 1 from the desired setting, making an odd number, which the 1-pixel-added bug will add 1 to resulting in an even number for the width and height after all.

    Terry
Sign In or Register to comment.