Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

x264 issue with Sony Vegas Pro

edited February 2013 in General Discussion
Just upgraded to CS 2.7. Everything works fine. I downloaded an x264 codec from a link that Terry supplied in numerous discussions and it works very well, except...

Vegas Pro doesn't recognize it. Does anyone know of a codec that has the excellent quality/small file size of this codec but is recognized by Vegas. Vegas does recognize other h.264 files. In fact, if I take the one from CamStudio and convert it to another h.264 in Any Video Converter, Vegas likes it.

It would be nice not to need to do the intermediate step. Any ideas???

Harold

Comments

  • Vegas and Premier both are pretty picky with the codecs of what they'll accept. I've only heard of people using a converter... I hope someone offers a good answer to this question.

    Terry
  • edited February 2013
    Harold,

    I just had a thought -- are you by any chance running on a 64-bit machine? If so, you will need two versions of each codec you use - a 32-bit version for CamStudio to use, and a 64-bit version for any 64-bit ready programs you have. If that is the case, download and install the 64-bit version of x.264 also, alongside the 32-bit one.

    I've read the vfw version is the one that works with Vegas Pro. Here are both versions from SourceForge:

    http://sourceforge.net/projects/x264vfw/files/

    Let me know if that works out for you!

    (PS - folks recommend exporting the finished version using a different codec and always the MPEG-4 container...)

    Terry
  • Vegas doesn’t like H.264 in an AVI container, and that’s what Cam produces using the x.264 encoder. Try using AVC to place the video in an MP4 container and it should work.

    Ken
  • Terry,
    Yes, I'm running 64bit. I don't think I need to install anything else 64-bit-wise, as Vegas already likes h.264 (from several sources) fine, except for what comes from CamStudio. I think bmorken is right. "Vegas doesn't like H.264 in an AVI container".

    Bmorken,
    I have used Any Video Converter to do just that. It places the file in a .m2ts container and it works just fine. I think, though, that leaves me with the same problem... a 2-step process... right?

    Harold
  • I just had a thought. What if I merely renamed the CS-produced .avi to a .mp4 or .m2ts. Maybe Vegas would buy that. The bad news is that I just learned that I don't know how to do that in Windows (lol, can you believe it). I'm probably just having a senior moment but for now, can anyone tell me how to do that?

    Harold
  • Well, it doesn’t sound as bad if you say “it adds one more step to the process”. Anyway, changing the extension of files will sometimes work in terms of programs being able to “see” them, as with VOBs to MPGs, but it won’t get the program to improve on the fact that it cannot use whatever decoder it has to open a file. I guess an intermediate step could also include changing the FPS to something usable, so there’s something else to be gained.

    Ken
  • Do you know how to change the extension in Windows?

    Harold
  • Just right click on the file and choose "rename". It'll warn you when changing an extension ..... Ken
  • Nope. Tried that. It went from filename.avi to filename.mp4.avi
  • Highlight the whole thing and re-type ...

    Ken
  • OK. Figured it out. Gotta go into your folder options ORGANIZE > FOLDER AND SEARCH OPTIONS > VIEW and uncheck the box that tells Windows to hide extensions for known file types. Then it'll let you change the extension.
  • Ah - you beat me to the answer, Harold!

    So, did it work????

    Terry
  • I'm afraid not. I'm still using Vegas 10... 12 just came out. Perhaps when I upgrade the newer one will work.

    Thx guys.
  • Yes, I did.

    H
Sign In or Register to comment.