Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Recommended settings and codecs for full screen vids?

edited February 2008 in Support
Hi guys. I've been using CamStudio for a while now but I want to do some bigger videos, however, whenever I try to use full screen mode (in any codec mode) i get an AVI file error.

Also, if by some chance i do like half of a screen, it wont give me an error, but the video comes out all gray with just the sound.

The only way i can record vids if the resolution is 500x500 or lower.

Also, whenever i record using DivX, the video starts to chop up after 30 seconds, and the CamStudio Lossless Codec doesn't work for me (video comes out gray). I end up having to use the codec that comes with Camtasia. Im using version 2.0 by the way. here are my machine specs:

AMD Athlon 64 3200+ (2.4 ghz rated at 3.0ghz)
1.5gigs of ram
128meg of onboard shared ATI Radeon X200 memory

I've seen people with much worse (pentium 3, 512 megs of ram, and 32 megs of onboard video) record smooth videos at any resolution using different codecs. Could it be because of my AMD processor? Does it work better for intel processors?

Comments

  • Also, note that I dont only have this problem with CamStudio, but many other recorders ive tried as well, so im not trying to single out this great program, im just wondering if theres something i can do to make these programs (preferably camstudio) run better on my PC?
  • I've had good experience using the MSU-codec mentioned in the blog (http://camstudio.org/blog/general/best-video-codec-found-so-far) for recording. For distributing (the few videos I've posted here and there) I use x264, compressed in Virtualdub.

    What settings are you using? I usually record at 15 fps. That is, record a frame every 66 ms, and a playback rate of 15fps.
  • I record at 30fps. Alot of people recommended it to me. I'll try that codec along with 15fps recording to see how well it goes.
  • edited February 2008
    Err unfortunately, i got a lot of garbleness like you would see when your cable signal's not working. :( im really beginning to believe nothing likes my PC. If possible, could you post your exact settings?

    Oh and also, whenever i try to go into the video settings menu within CamStudio after my first time in the menu, the entire program crashes on me. I don't know why. So now I can't even go back and change codecs and settings unless i reinstall the whole thing (this is on 2.5 by the way)

    Im gonna try it on 2.0 and see if it does that. UPDATE just tried it on 2.0 and it does the same thing. =( I really don't get what's happening here.

    UPDATE - well I can safely say that all the products based off of the CamTasia Studio source is doing the problem which I described above (crashing). This is odd.
  • Yeah, the MSU codec is temperamental - it works on some machines, not on others.

    I would advise NOT to record full screen unless you absolutely have to, because even with a good video codec, your AVI will get big REALLY quick and then you'll begin to run into the AVI filesize limit (2GB on a FAT16 drive, 4GB - on a FAT32 drive, virtually unlimited on an NTFS formatted drive) BTW, this is not a limit with CamStudio, but with the AVI filetype itself.

    To record fullscreen at 30fps, you're going to need some serious processing hardware to do that and make sure minimal other programs are running to keep everything smooth, so that's another factor to bear in mind.

    That said, I'm not sure exactly why you're experiencing these issues - and you certainly should be able to record screen perfectly above 500 x 500.

    Are you using the most up to date ATI-issued graphic drivers?

    Cheers

    Nick :)
  • edited February 2008
    Not sure if it helps, but I can explain how I've done it when recording fullscreen:

    First I set the resolution of the screen down from the default 1440x900 to 1280x800. In Camstudio the video settings are set like this:
    http://i27.tinypic.com/346xg13.png

    When it comes to audio, I've mostly had to use another program (Audacity) to record that. The reason being that after I formatted the PC a while back, any recording including audio would create corrupt AVI-files that would crash any program they were opened in. Not an optimal solution as it creates a little extra work (encoding video in Vdub, exporting audio from Audacity, and then muxing them together with MKVmerge, instead of just encoding everything in Vdub) and could make audio and video a little out of sync, but it works.

    You could try this approach:
    http://camstudio.org/blog/tutorials/first-camstudio-tutorial-video-online (also, read the comments - more links)

    EDIT: Nick, concerning filesizes: I just recorded a 7:27 minute video in 1440x900 with the settings shown above, without audio. The file ended up on 73,7MB. Of course, the audio would have added greatly to this, but still, it's a long way to go before reaching any file size-limits.

    EDIT2: Concerning compression: This isn't what the thread is about, but I can mention it anyway. The audio is exported from Audacity using Ogg Vorbis with a quality setting of 0 (on a scale from 0-10). The video, as mentioned above, is compressed with x264. The video (if fullscreen) is resized to 80%, which makes it 800x500, and sharpened a little. I use two pass encoding with a bit rate of 100.
  • Torbjorn: Nice post, thanks.

    This probably obvious, but I'll say it anyway, if you have to record fullscreen or at a relatively high resolution, make sure audio codec is at MP3, 22kHz, 32 kbps, Mono if it's just you speaking.
  • What I have found working is using the camstudio codec and lame mp3 as the audio encoder 22.05kHZ, Stereo , then I use virtdub with either xvid or x264 taking from the k-lite codec pack or xp-codec pack , you can google them to find those. Results are great, im getting decent video at 1280x1024 with a decent frame rate and crisp video. Of course the original camstudio codec file is huge but after encoding it down it is in a manageable state.
  • edited February 2008
    If you don't want to install a lot of codecs you won't need, go with this instead (just x264, nothing else):
    http://www.free-codecs.com/download/DTS_x264_VfW.htm

    And for audio, this (just Lame):
    http://www.free-codecs.com/download/LAME_ACM_Codec.htm

    Having heard that codec packs can cause a lot of problems (not saying they will, but they can), I've never installed any.
  • edited February 2008
    I'm using CamStudio 2.5beta on
    AMD x64 3200+
    4gb RAM
    2.5tb Disk space
    MS Windows Vista

    I have compatibility mode set to Windows XP sp2
    The codec I'm using is CamStudio Lossless Codec v1.0
    Quality set to 70
    Capture frame every 50ms
    Playback 20 frames/second

    I recorded a 20 minutes video full screen just playing around and had no problems with the playback (other than the gigantic file size) AFTER I turned AVG off

    I'm wondering OGWilson, if you have a lot of processes running in the background that is taking resources. It's a thought.
  • Have you tried using the Camtasia Studio codec? I use that, and it seems to run perfectly on my below par system. The stats are:
    Acer Aspire 5100
    (The graphics card is so horrible, don't remember it) Some ATI Radeon 1100 series
    1gb of RAM
    120 GB of Disk space
    MS Windows Vista

    Also, I use the "Disk Cleanup" utility whenever I use know I will make large files, and I encode with the Lame MP3 codec. Plus, as stated by djsmyers, make sure to turn off ALL of the programs running in the background that you don't need, and aren't part of the systems files that Windows NEEDS. The codec(s) can be found here:
    Install ALL codecs, see what's the best. http://www.techsmith.com/codecs.asp
    http://lame.sourceforge.net/index.php -- MP3 codec
  • I think you need a registred version of Camtasia to use Techsmith's codec for encoding (not for decoding though). At least it used to be that way.
  • No, no programs were running except Camstudio and Dev C++ (which doesnt take up much resources). Well Im going to play around some more with more codecs and such. One thing is, Im on a fresh install now and I have the program working functional so far for a couple days now, no crashing, etc. But my audio is off sync and sometimes in the audio, it will skip forcing my video/audio to be out of sync permanently (nonfixable since the skip is there). that was using PCM though. Im going to try LAME instead and see how that goes. Thanks for all the support so far. Ill keep on trucking.
  • Also, Torbjorn, I've tried the Camstudio codec, but i get some message errors everytime i try and it eventually just makes the program crash. the MSU is still not working for me unfortunately, but the Camstudio Lossless is working just fine for me (still with audio sync problems though). Also, how to use Vdub in conjunction with camstudio? I thought just recording the video on camstudio might be enough but it seems you guys do some more advanced things.
  • First I have to say that I was wrong concerning Techsmith's codec. I just tried it for a couple of seconds, and both recording in Camstudio and encoding in Virtualdub went just fine.

    As for your last post, OGWilson:
    Did you mean that Techsmith's codec gives you error messages every time?

    About Virtualdub: I use Vdub for further compressing the videos. The original video is too large for distributing on the web (I think), and anyone wanting to see it would have to install the MSU codec first. Therefore I use Vdub to 1) change the resolution of the video from 1280x800 to 800x500 and 2) converting to a codec that is more common to have installed (x264). This also reduces the filesize, to roughly 1MB/minute, while maintaining decent quality.
  • Torbjorn, I think he means the CS codec, not the TS codec. ;) Anyways, I think that if you try recording using a lower screen resolution, or using Microsoft Video 1, you might be able to get a better looking video, and possibly the audio won't skip-- it might interleave better.
  • Yeah, but the next sentence he writes "the MSU is still not working for me unfortunately, but the Camstudio Lossless is working just fine for me (still with audio sync problems though)." That's what got me confused.
  • Oh, sorry about that. I hope OGWilson will come to see some of the solutions.
Sign In or Register to comment.