Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Bug report: CamStudio not keeping settings (and workaround)

edited February 2008 in Support
Hi:
First of all, thanks for keeping this great little program under development; it's a really useful app. Unfortunately, I registered to report a bug (I'm using version 2.5 Beta 1 under Win XP Pro SP2) and to inform how I dealt with it. As the thread title describes, I was having problems with CamStudio not keeping my settings (even with "Options -> Program Options -> Save settings on exit" activated).
Out of curiosity, I opened "CamStudio.ini" and, to my surprise, the settings (the changes I made) were all there.
Then, I compared that "CamStudio.ini" with the original from "CamStudio.2.5.b1.bin.zip" and found the culprit: for some reason, when CamStudio exits and saves this file, it changes the first line from this:

[ CamStudio Settings ver2.50 -- Please do not edit ]

to this

[ CamStudio Settings ver2,50 -- Please do not edit ]

It writes a comma (between numbers 2 and 5) where a dot should be. And the bug only seems to be triggered by entering in "Options -> Video options". It doesn't matter if you then change a setting and press OK or if you just Cancel without changing anything.

If I open "CamStudio.ini", change the comma for a dot, save the file and then open CamStudio, now "my" settings are there, instead of the deafaults.
Just to be clear on that point, I made no other manual edition to "CamStudio.ini" (or to any other file, for that matter) except changing the comma for a dot, and that was only AFTER I found the aformentioned problem.
I hope this may be of help to the dev and to anyone having the same problem.
Best regards.

PS: One last tip; if you don't want to keep doing the ", for ." change, you can do the following: once you have decided what settings you want as the defaults, open "CamStudio.ini" properties and set it to read-only. Keep in mind however, that the program won't save any new settings until you deactivate the read-only attribute.

Comments

  • Thanks for the tip! I've experienced this bug as well, resulting in a couple of videos in 200fps ...
  • You're welcome, Torbjorn. I'm glad it was of help :D
  • It is bug reports like this that really help to make a great product better for the community. Thank you ever so much for the report and the work-a-round.
  • 7Orfeo7

    Thanks for taking the time to submit this and your fix - we'll try to get this sorted for the next release.

    Cheers

    Nick :o)
Sign In or Register to comment.