Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Trouble with audio from PC to Camstudio

I got camstudio downloaded and it works great recording my voice, but I'm having trouble with how to get audio I play on my computer to be captured when recording. It captures my voice and the screen shot, but not the music I'm playing. I've tried playing a CD in Windows Media and playing the song on Youtube and neither one is working. I'm needing some background audio to go with my voice. Let me know if this is possible and if so how to accomplish.

Comments

  • What computer do you have? Windows XP? Vista? 7?
  • The main system I have been using for this has XP. I have another system with 7, but it doesn't currently have Camstudio on it or any of the other tools I am using in conjunction with, so would prefer to stick with the XP system, but if 7 is way better for this sort of thing I can make that happen.
  • Hi Jarrod

    I'm not sure you can capture your audio AND the speaker audio at the same time.

    The usual method I give to users who want to capture audio from the speakers/soundcard is by changing your input audio to Stereo/Mono Mix/What-U-Hear.

    In XP, double-click the speaker icon in the system tray and select Advanced > Properties > Recording

    If there's a Stereo Mix, Mono Mix, Wave Out or What-U-Hear option in the list, tick the checkbox and then make it the active audio input by selecting the checkbox underneath the fader.

    In Vista you have to enable Stereo Mix (sometimes also called Wave Out Mix) as it's sometimes hidden by default:

    1. Select "Sound" from the control panel.
    2. Select the recording tab.
    3. Right click on the background of the tab and choose "show disabled devices".
    4. Right click on Stereo Mix and click enable.
    5. Make Stereo Mix as your Standard

    Now start CamStudio and select:

    Options > Audio Options for Speaker
    Choose "Stereo Mix" at Soundcard Device

    Now select Options > "Record audio from speakers"

    The issue here is whether you can also record the audio from your microphone at the same time.

    Whenever I've tried it on my Vista laptop, it hasn't worked, but go ahead and see if you can.

    HTH

    Cheers

    Nick :o)
  • edited July 2010
    Naturally, you also have to enable the mic in the regular volume levels controls.(not the recording levels - only the "What U Hear/Stereo Mix" input should be selected there)

    If your mic isn't SHOWING in the regular levels controls, you have to make it appear either via options/properties (XP) and checking its check-box, or by right-clicking and showing disabled/hidden devices, then enabling it (Vista, Win7).

    Links to YouTube videos explaining how to enable "Stereo Mix" are found here: http://camstudio.org/forum/comments.php?DiscussionID=404&page=1#Comment_1504

    Terry Britton
Sign In or Register to comment.