Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

cannot record PC audio

edited July 2010 in Support
Hey guys,
I'm having some major problems getting camstudio to record audio from my PC or desktop like if I was playing music from a game or something.

I have windows 7 home premium. I have a realtek HD audio soundcard. I did try the right clicking the sound panel and went to the "recording" and checked for disconnected and disabled devices. I made sure realtek was my default device. For the stereomix properties, I clicked on the "listen" tab and tried to find "speakers" so the playback can go through there but speakers isn't listed. The only devices I have listed are microphone, speakers, headphone and line-in. Everything is plugged in except mic and the line-in I don't have a cam or microphone. Oh, speakers are also not plugged in because I use a headphone. So the only way I listen to sound is through my headphone.

I went to "record audio from speakers." Of course, I got the error, "waveoutgetsselectedcontrol() failed" message. I ignored that and just went to audio options then the options for the speakers. I selected "Stereomix" and went to try and record a sound from my computer. Nothing. My sound is working and everything but the mic, line-in and speakers are plugged in. I thought you didn't need a mic or speaker? I use a sound recorder for now and it's able to pick up sound just fine so I figured it's a camstudio issue and not my sound settings. I tried to search both manually and automatically the sounds but if I tried automatically, it'd give me that error message I mentioned earlier. If I tried manually, it said something about the soundcard not matching with the recording line or something like that. I had to restore my system and that got rid of camstudio so I'm posting based on what I remembered. The recording line couldn't be found and it's been grayed out anyway.

I've done everything I could that I could think of and the things they've done on Youtube and while it worked for most people, it didn't for me. I had to restore my system twice because I was messing around with the sound panel and couldn't get it back. So that meant my anti-virus program stopped working every time I restored so I had to redownload my anti-virus program after both restores. I am hoping that I can find a solution without having to mess around with the sound panel again and just with camstudio. This has been very frustrating and I have no idea what is going on.

Here's a couple of screenshots of what things looked like when trying to get camstudio to pick up sounds from my desktop when messing with my sound settings.

PS: Oh, and I am running camstudio with windows xp service pack 2 compatibility mode and everything was fine when I used to have windows xp service pack 2. I hope we can come up with a solution because I feel like I tried everything. This problem is so weird!


  • What version of CamStudio are/were you running?
  • What are your settings under the "Levels" tab? That is the one that is relevant, not the "listen" tab.

  • @booklover, I am running 2.0. I've heard of newer versions but couldn't find them on this website. I just saw a newer beta version now for experts and am hestitant to go for that. I would download only from the software's original website instead of other places because there could be viruses etc..

    @tbritton, the levels tab for the playback or recording? Under playback, the level is set to 46 for headphones which is my default device instead of realtek. Again, I've messed with the settings trying to get realtek as my default and lost my sound before I had to restore my system. For realtek, the level is 100. Under recording, the balance is 100.
  • edited July 2010
    Make certain the "Wave/MP3" levels are up and not muted. If you are using your microphone, make certain that level is up and not muted. If you don't SEE those, check that they are not simply hidden (right click, I believe).

    Newer version that is fairly stable is at https://sourceforge.net/projects/camstudio/files/ - version 2.6 beta

  • I do not have a micorophone so it is not plugged in. I downloaded and installed the newer version of camstudio (come out as v.2.6) and now I have another problem. When going to audio options for speakers, Stereo-mix is not even listed! Now it's just "Headphones (Real High Defini..." and "Realtek Digital Output (Realtek...". That's it, nothing else. Stereomix did show up in the 2.0 version.
  • Can you get to StereoMix to enable it via your regular audio control panel access? (for recording controls)
    Can you see your output mixer sliders? (with Wave/Midi, Line In, Microphone at least?)

  • edited July 2010
    Ok, I'm just going to post a video as I take you around so you can see how everything looks and what I do to get camstudio to record when it won't. The video works but the sound won't. I went back to 2.0 because when trying to record with the newer version, camstudio won't record at all (I even looked in the folder for camstudio under program files) and I have to uninstall and reinstall to get it recording. This is why I don't like messing with betas. So here's me trying to take you around so you know how everything looks using camstudio 2.0. Hopefully the video will help give you a better idea of what's going on. Let me repeat this... messing around with adjusting what default devices I use causes me to lose my sound and I cannot get it back unless I restore my system, which means I lose my antivirus program and have to uninstall and reinstall it again. Now if you can help me figure out how to mess around with default devices without me losing my sound, restoring my system and reinstalling my antivirus, then great. I hope this will help because I've been working at this for over a week and it's so frustrating, I don't understand what the problem is after watching YouTube videos on this type of thing. I can't figure out what is going on and I'm about to find another screen recorder if I don't get this resolved soon.

    Click on the magnifying glass to view in full screen.
  • edited July 2010
    First, to do with this line: "unless I restore my system, which means I lose my antivirus program and have to uninstall and reinstall it again."

    Use system restore to set a restore point a little more current -- so you can restore back to that one, instead of going so far back that you lose your antivirus program. (ie.; "Create Restore Point").

    In the video, you seemed to have everything right except that you are using "Record Audio from Speakers".

    In your case, you have already set up "Stereo Mix", so you select "Record Audio from Microphone" (confusing, I know...)

    Then click on the menu item, "Audio Options ==> Audio Options for Microphone" and at the top under "Audio Capture Device", your default input device (the Realtek) will be showing (or manually force the Realtek by selecting it in the list). Click on the "Volume" button, and your recording controls will appear. You likely already have the "Stereo Mix" recording control selected. I recommend you set it a bit lower than you show in the video.

    The only thing missing in your video is the volume controls for your playback settings - these have to be set with adequate volume and not be muted in order to hear them. If you are hearing anything already, they are probably set right. I get to mine by double-clicking the little speaker icon in my tray. For you, right-clicking and selecting "Open Volume Mixer" would get you to these controls. When using "Stereo Mix", its slider determines the overall "master" volume - the "Volume Mixer" controls determine the individual volume levels and the "mix". I can port my microphone through into the "mix" to include it with other audio if I make the mic visible (un-hide or enable it) and un-mute it.

    I hope that is more helpful. I seriously am not sure why they put the "Record Audio from Speakers" tool back in there, since it has had problems with several versions of Windows.

    The "Record Audio from Microphone" wording should be changed to "Record Audio from System Settings", since "Microphone" is only one of the options available to us from that dialogue.

    I hope this has finally helped you get where you want to be! And thanks for the tremendously helpful video!

    Terry Britton
  • edited July 2010
    Ok when clicking "Volume" for audio options for microphone, nothing happens. Nothing will show up. Is it because microphone is not plugged in? This happens whether I select Default Device or Stereomix. Volumes in all mixers are already up.
    Here's how it looks like

    By the way, I did restore to the most recent points and still lost my antivirus.
  • edited July 2010
    This is mysterious, I'll grant you that! (as it is also odd that a recently created restore point would still force a re-install of your antivirus software! What antivirus software does that? Granted, it may be a way the antivirus software is protecting itself, to note that a restore has taken place.)

    What happens if you select Realtek Digital Output as the default playback routing instead of Headphones?

    I cannot for the life of me imagine why clicking the "Volume" button would not open your input volume controls. But since you have that configured already to "Stereo Mix", it should not even be an issue. The only thing that stands out now from viewing your videos is the fact that you always route the audio to the headphone amplifier. This might be forcing a bypass of the digital signal around the rest of the system to send everything directly to that headphone amp. That's why I have to suspect that perhaps "Realtek Digital Output" may be the direction you want to route the audio signal. Please try that and let me know if the Volume button again becomes active, and/or you are able to record audio.

  • Ok, I did try selecting Real Tek as the default playback again, afraid I would lose my sound again. Well, I did. But I did pay attention to what I was doing so I can reverse it and I was able to get my sound working again without restoring! So that was fine. So to answer your question about what happens if I select Realtek as the default playback, I lose my sound. Well, now that I know how to turn it back on, I did try "Volume" button again without the sound working to see what happens. No luck. Volume control still won't show up (on Camstudio, that is). So I just turned my sound back on after knowing how to get it back without restoring. Here's the thing now. After playing around with the settings for playback again, my headphones is default device but I just now noticed that Realtek is Default Communications Device. What does that mean or does it mean anything? Again, if I make Realtek default device like headphones, I lose the sound and I still can't open the volume control on camstudio either, anyway. So whether or not I lose the sound, the volume control won't open.

    This is a very weird situation and I don't know why it's doing this. I only needed Camstudio for just one thing and tonight, I figured out something so that I can get the sound and video at the same time. I have a sound recorder (and that's working fine, I have no idea why lol) and the only issue is to sync the video and audio together and I just figured out a few minutes ago how to do it so hopefully that'll work out. I guess that's what I'll have to do since we're really running out of solutions.

    Oh, I'm running Mcafee anti-virus.
  • Hi, Liz --

    Following are the CamStudio 2.0 settings I use on my Toshiba laptops (this one running XP SP2) that are able to capture sound as well as video. The audio card is Realtek.

    video option - Cam Studio
    record audio from speakers
    Audio Options for speakers - device attached to speakers = Realtek HD audio output
    Under the recording line configuration, sometimes by playing around with the auto search and then the manual search I can get it to show line 1, but it seems
    as if it doesn't really matter -- it still catches the audio. When I get the "WaveOut" error message, I just ignore it, and it seems to work OK.

    Before I posted this, I plugged an old headset into the computer, changing nothing else, and again tried to capture something off the internet. It worked just the same as it did without the headset plugged in.

    Below is a link to the first capture. I recorded the whole screen rather than just a specific part of it as I normally do, and I also converted the file from avi to wmv so it would upload more quickly, so overall the quality's not too good but it did get both video and audio. The speech and video are also out of synch, but CamStudio provides a way to compensate for that.

    Here's the link: http://tinyurl.com/2cxlxpe

    Maybe this'll help.
  • edited August 2010

    When you say, "I lose sound" I'm imagining that you mean you lose sound through your headphones, since those are your only listening device (no speakers or stereo-out connection). So, that would make sense! I'm just puzzled why none of those three (whether you can hear sound over your headphones or not!) are directing their output to the Camstudio software. Totally strange!

    Are you using VirtualDub to re-connect your audio with your video? And might you be using Audacity to record audio? I've heard of several people who use that option anyway (recording the audio with Audacity, whether Camstudio's audio recording is working or not) because they like the features in that (like silences between pauses and ease of editing out umms and uhhhs).

    What an ordeal - I'm so sorry you have had to jump through all of these hoops! At least you have found a working solution. I'd love to hear any more details of that when you have time!

    I'll post here again should I stumble upon another person with a similar issue who had solved the problem.

    (Oh, and thanks for turning me on to tinyurl - I had no idea they did videos now! I had been using Jing for short screen captures to share (up to 5 min.), but I'd rather be using Camstudio with tinyurl for the nice user interface.)

  • edited August 2010

    When you say, "The speech and video are also out of synch, but CamStudio provides a way to compensate for that" - why do you suppose your settings are producing out-of-sync audio and video?

    Perhaps see this article I wrote for a possible solution.


    Some of this entry also appears in the sticky forum entry, "Fixing Audio/Video Sync Issues With VirtualDub", about the fourth item down.

    All the best - thanks for your always positive input!

  • edited August 2010
    Terry, I didn't really care on this since I was merely testing captures with sound in hopes of helping Liz. Most of what I do with CamStudio is screen captures at the puppycam. Most days he doesn't turn on the sound, and when he does it doesn't really matter that the pups' yips are in sync with the video.

    In this case it may well have been converting to wmv so I'd have a smaller file and consequent faster upload that caused the out-of-sync as well as some degradation in video quality. Quality wasn't really my concern on this; demonstrating the settings that enable audio capture on a computer with Realtek audio was. Also, I normally just capture a specific area rather than the whole screen as I did in this case. The original avi file of this capture was, after the first few seconds, in sync, so I suspect it was the conversion.

    Yes, as you may have noticed, I'm a big fan of VirtualDub. But in this case I really didn't care about the out-of-sync but thought I'd mention that I was aware it was there. Thanks for the link and your kind words.

  • Jo,

    Have you been keeping your settings so that the "Capture Frames Every" setting TIMES the "Playback Rate (fps)" setting are always equal to 1000? Just wondering. I've not had WMV conversions throw off the sync ... yet! ;-)

    Puppycam, eh?! I love that one! Great application, I'd say!

  • Jo, I'm afraid I don't understand because it sounds like you're doing what I already tried as stated in this thread so I'm not sure how what you did is different than what I've tried so far.

    Terry, yes, I lost sound through the headphones as well (before I got it back of course). Actually I did suspect it had to do with a sound recorder I was using so I tried uninstalling it. No luck. I'm not using audacity or Virtualdub. I wanted to use Audacity but wasn't sure whether it's compatible with Windows 7. The only solution I came up with was to synch the video and audio together on windows movie maker. By the way, I was using tinypic.com I was using to upload the videos. Just wanted to be sure you knew that because tinyurl.com actually creates shorter url addresses so they're different from each other!

    Yeah I don't know why my issue is so wierd because I've looked at everyone else who also uses camstudio on windows 7 on youtube and they have no problems. I was thinking it was just camstudio and windows 7 not getting along but no one else seems to have a problem. It's weird. If there's anything else you want to look at or want me to show you on camstudio, let me know what and I'll take you there and maybe we can figure out if you think of something.
  • edited August 2010
    Liz, after the earlier post I did another capture, this time on my Windows 7 Pro machine, which I'm just learning to use and still not quite comfortable with, but it also seemed to do OK. Of course different brands do things differently, and yours being an HP and both mine Toshibas might account for the difference, although both have Realtek for their audio.

    One more thing I did check after recording the Meet the Press segment was that all my settings for sound in the control panel were left still at the defaults.

    Here's the later capture made on the Windows 7 machine: http://www.youtube.com/watch?v=xXPtoY7KqJA


    Edited to add: did I see somewhere in going through your video that your computer does not have speakers built in? Seems as if I saw something about speakers not being plugged in. Or maybe I dreamed it.

    I went through your video slowly, comparing its settings to mine. Although they're arranged somewhat differently, I found only two differences: 1-- Audio Options device -- I think you and Terry have covered this -- on my computer Realtek HD Audio is selected.
    2. -- Realtek Digital Output Properties -- mine has speakers as the only option, but your shows Realtek Digital Output.

    One other difference I noticed, which shouldn't affect this problem: I notice you're using the Microsoft Codec rather than the Cam Studio Lossless one. I know I've read that many different codecs will work fine, but since I did a topic-by-topic comparison I thought I'd mention it anyway.

    I'd be interested to know about whether they're built into the computer or whether they need to be plugged in separately if you want to use them instead of the headset.
  • Terry, I haven't been fooling with the frames figure at all since for most of what I do I haven't needed to sync and if things were out of sync it was barely noticeable and, if necessary, I figured I could clean it up with VirtualDub. I did figure out what had caused the out-of-sync on the earlier one -- I had adjusted CS's sync for some reason and had neglected to put it back to zero. If you play the later capture just above, it's much closer to being totally in sync.

    Maybe when I get done some of the things I've gotten behind on while I played with this stuff I can experiment some. It'd certainly be more fun than what I NEED to be doing!

  • Yeah I never use the speakers as I always use the headset so I didn't bother getting them. I think Nick told me in an email that it shouldn't matter so I wasn't concerned.
  • What happens if you plug your headphones into the speaker output? Can you enable the speakers then? (Who knows - that might be all that it is!)

  • edited August 2010
    Good idea, Terry.

    I did look around a little on the net today to see if other HP owners were having similar problems. I did see a few, although their problems weren't exactly the same.

  • Ok, wow, surprised this thread is still around. Well, I know it's been a long time but I stopped using camstudio all this time because I didn't have time to mess with it with school. Now school's out and back to using camstudio. Unfortunately I'm still having problems. I checked out tbritton's new video on this issue and that video assumes that I am using a mic or a speaker. I'm using neither and neither are plugged in. I don't have the speakers at all so I won't be able to use them. All I have is headphones and realtek high definition audio and I listen to my sounds on my computer through my headphones.
  • edited May 2011

    Yeah, I don't think the RealTek cards are allowing Stereo Mix WITHOUT some kind of speakers plugged in - but you COULD plug your headphones into the speaker jack (like we all did in the old days) which would fake-out the "auto-sensing" to think there are now speakers plugged in after all, and then you could make "Speakers" the Playback default, and Stereo Mix as the Record default would start to work, like in the video. (You don't need to follow the microphone part at all, of course).

    Try it and let me know if that works.

    And remember to use the "Record Audio from Microphone" setting, not "From Speakers" - I know you have no microphone, it is getting the audio from Stereo Mix.

Sign In or Register to comment.