Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

x264vfw, FFDShow and Ut Video codecs unavailable

Hi guys.
Just wanted to mention that x264vfw and FFDShow codecs are no longer recognized by CamStudio in versions R273 and R294. The Ut Video Codec is only partially available: the RGB portion is available, while the yuv422 and yuv420 are not. The last version these codecs worked to their full extent was in version 2.6b R264. Let me know if there's a workaround.

Thanks and keep up the good work.

Comments

  • I remember that I had something simular after I installed a set of codecs I downloaded from .....
    Reinstall of CS solved a lot.
    I still have yuv422
    Will make a mental note to study how CS codecs module determine which codecs are availble.
  • edited January 2011
    Thanks for the response.
    A few things I wanted to add. I switched to win7 64bit recently and ran the R264 version from the Program Files folder of my previous OS (WinXP installation on another HDD), so the R264 version I was running was already installed, just not in win7. I then went and installed the R273 and R294 versions and neither showed those codecs I mention. I doubt reinstalling CS will help as it seems the issue is with the recorder.exe file. Still, I'll mess with reinstalling CS in the next couple days. If anything new comes up, I'll post it here.
  • To all:
    Are there any other users with the same issues or is this just bad luck?
  • edited January 2011
    See if the fix moisamva arrived at in the "Lossless Codec Not Showing Up" thread fixes the issue when applied to these other codecs using a similar approach. You'll have to discover the names of the files for these "missing" codecs, of course.

    http://camstudio.org/forum/comments.php?DiscussionID=310&page=1#Item_8

    Also, be mindful of the details described in this post in "Divx doesnt show in compressors": http://camstudio.org/forum/comments.php?DiscussionID=125&page=1#Item_10

    Terry
  • edited January 2011
    Hey, Terry. I managed to register camcodec.dll with the procedure, described in the first link. Didn't even notice it wasn't present on the list of codecs in CS :). Thanks.

    The only location that seems to control codec visibility (at least the 32bit ones) is "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32". I decided to do a little test and remove x264vfw from the list of codecs in VirtualDub/CS R264 (CS R264 shows all installed codecs, with the exception of: Zipped Motion Block Video, Fraps and Ut Video Codec RGBA). The String Value name for x264vfw is vidc.x264 and its Value Data is x264vfw.dll. The file is located in the SysWOW64 folder. If I delete the vidc.x264 String Value, the codec goes away and cannot be accessed. If I recreate the vidc.x264 String Value, the codec reappears.

    At this point I'm at a bit of a loss. The R264 version shows the installed codecs, as mentioned above, and all the subsequent versions don't. On my machine, anyway. I copied the R264 version of recorder.exe to the R294 folder, ran it and still had the codecs.
  • kevinV,

    Sleuthing backwards in the registry, what keys reference "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Drivers32" I wonder?

    Hmmmm - actually, if the 294 pointer was corrupt, it wouldn't point to that key... but then it wouldn't show ANY codecs, I should imagine.

    This is CRAZY! (I just had to get that out of my system...)

    We'll keep investigating, but this seems like an oddball issue happening mainly to your machine. BTW - are you running 294 as an administrator (or have you tried that? Might try running the installer as an administrator as well.) Of course, you mentioned this happened on an XP machine also, right? Odd.

    Terry
  • edited February 2011
    I was running ver R264 in WinXP, never installed any of the more recent versions.
    I removed all CS installations in win7 and everything else related to CS I could find in the registry. I then installed versions 2.6b R294 and 2.0 (yes, version 2.0), both with admin privileges. Can you guess which one had the codecs?
    2.0.

    I could be missing some runtime component or something.
    Since I'm pretty much the only person with this issue, don't waste too much of your time on this :). I'll report back, if I get this fixed.
  • edited January 2011
    KevinV,

    Re-install the C++ runtime binaries and see if that helps. That did it for me on one occasion.

    Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)

    http://www.microsoft.com/downloads/details.aspx?familyid=A5C84275-3B97-4AB7-A40D-3802B2AF5FC2&displaylang=en

    The package is required but not included.

    Terry
  • edited January 2011
    KevinV,

    I have been trying to get this to work but to no avail. I'm also on a Win7 64-bit machine. Like you are experiencing, r264 shows all the codecs, but r273 and r294 do not.

    Programmers - here is a reference sheet with screen shots of the codecs drop-down in Video options. K-Lite mega pack and FFDShow-Tryouts installed codecs.

    http://screencasttutorial.org/camstudioversions.html

    I'll keep messing with this, but for now I'll be reverting to using r264 when I want to use FFDshow or others that are missing.

    http://sourceforge.net/projects/camstudio/files/CamStudio%202.6%20beta/CamStudio_2.6b_r264_build_14july2010.exe/download

    Terry
  • edited January 2011
    http://terrybritton.com/CamstudioVersions_files/Image%20%5B2%5D.png
  • edited February 2011
    Sorry for the late update.
    I uninstalled all the runtime binaries I could find (2005, 2008, 2010). I didn't even bother reinstalling them, I simply ran all the installed versions of CS and got the same results.
  • edited February 2011
    kevinV,

    OK, well thanks for trying that out. This is considered a top issue to be looked into by the programmers, so hopefully they will have good luck in sorting this one out. Look forward to the next beta release... meanwhile, revert back to r264 to get those codecs.

    BTW - give Lagarith Lossless a try and let me know how it goes. That appears with all three beta versions. I used K-lite Mega Codec Pack to install that (but I advise you do not get codec-happy and install everything in that pack!!) http://www.free-codecs.com/download/k_lite_mega_codec_pack.htm

    Terry
  • edited February 2011
    I didn't want to mess with k-lite, I picked up Lagarith from the official site (ver. 1.3.21; http://lags.leetcode.net/codec.html). It installed fine and shows up in all versions, even 2.0, which I find odd, since it's not in your screenshot for ver 2.0.

    I spent some time digging through win7 registry hoping to find some clue as to why only the RGB (ULRG) variant of UT Video codec would show up in r294, but not the other three as well (rgba, yuv422/420), also why Lagarith shows up in every CS version. Didn't have much luck with it, obviously.

    Thanks for looking into this, I really appreciate it. If this get's resolved, I'd really like to know what's going on.
  • edited February 2011
    kevinV,

    Thanks for the lagarith link. I'll recommend that to people over K-lite for the lagarith codec, as I consider K-lite to be a little too dangerous to just give to anyone. There are too many codecs in that pack, and it seems certain combinations can wreak havoc. (Holy Moly - it was updated just yesterday!)

    Terry
  • I just wanted to add that I too have problems with the new builds and x264 codec mentioned above.
    the last version this worked in was the 2.5 version.

    I don't even see the camstudio codec or alot of the other codecs I have installed.

    don't know if the following helps, but with VirtualDub, if you install a 32bit codec, you won't see this codec in the 64bit version of virtualdub, and vice versa.
    this shouldn't be any problem due to the fact that the recorder is 32bit.

    as a reference, I'm running Win7 64bit

    cheers
    Tomse
  • tomse,

    Your observation of the 64-bit codecs not appearing in the 32-bit softwares and visa-versa is normal behavior - 64-bit codecs are the only kind that work in 64-bit software. You need to have both kinds to have it for both your 32-bit and 64-bit softwares.

    That is academic, of course, as it does not pertain to our problem with the codecs not appearing in CamStudio versions! This is pretty frustrating!

    I'm recommending people use the Lagarith Lossless for now (which appears across all versions on my various machines and works great - thanks kevinV and digiday!) and then convert afterward to other codecs via "any video converter" or VirtualDub later.

    http://lags.leetcode.net/codec.html

    http://www.any-video-converter.com/products/for_video_free/

    http://virtualdub.sourceforge.net/


    Terry
  • edited March 2011
    Also note that even though ffdshow shows, as said in a video I made, comparing all the codecs: http://camstudio.org/forum/comments.php?DiscussionID=623

    ffdshow will not show all options for encoders. (Even if you run as admin) I really love MSMPEG4 as it gives the best quality and frame-rate.
  • Also, r264 doesn't show the ffdshow for me.
  • Looks like it's back somehow, but it won't show restricted formats anymore :(

    And I loved MS MPEG

    http://i.imgur.com/XFSkf.png
  • Using an older revision helps somehow: http://www.digital-digest.com/software/download-1030_0_158_file_ffdshow_rev3572_20100913_clsid.exe.html

    Make sure you uninstall your current ffdshow.
  • coldReactive,

    Who would imagine that older versions of ffdshow would get through! I wonder what the heck is going on here!?!?

    Does ffdshow have 16-bit display color vs. 32-bit display color restrictions? I am just wondering, because some codecs don't show up based upon such restrictions in 2.0 (never noticed whether this was true or not in later versions beyond 2.5!)

    Thanks for keeping up with this - hopefully you'll get MS MPEG back in there soon (I know this missing-codec thing is a major subject/bug being looked into now by the programmers).

    Terry
Sign In or Register to comment.