Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Recording a 2-hours exam with this settings?

Hello everybody! I gotta take an online exam of 120 minutes and 120 questions to complete, I can repeat it so want to ensure I record it correctly,

I attach to you my settings in a JPG file, I do not record audio and 1 minute takes 4 MB (120 mins less than 2GB, which is the AVI limit) the quality is enough to read the questions

Please tell me if everything is ok with this settings: http://img851.imageshack.us/img851/5486/settings.jpg

thanks in advance

Comments

  • rodarreh,

    These will work, but the Microsoft Video One codec will look absolutely terrible.

    Try running a test before the "big show" using either the CamStudio Lossless codec or the Lagarith Lossless codec.

    http://lags.leetcode.net/codec.html

    Also, you do not need to adjust the slider at the bottom unless you have the "auto adjust" box ticked - it is merely a quick way to enter settings. Your settings for SKFE, CFE and PBR are fine for stretching out your mileage. You could set your keyframes every value even higher (like to 100). I've written an article on what that setting actually does here:
    http://screencasttutorial.org/18/best-settings-for-camstudio-to-sync-audio-and-video-28/3

    Good luck on your test - but do TEST your settings before actually trying this - remember that the AVI specification limits your file size to 2 gigabytes.

    Terry
  • edited March 2012
    Hello,

    Not sure this is the right post to add a comment to, but I'm experiencing the sync problem though the size does not exceed 2GB limit. I'm recording approximately 1 hour long presentations.

    My settings are Set Key Frames Every 100 frames, Capture Frames Every 10ms, Playback Rate 100 frames/second. I tried other settings for Capture Frames Every and Playback Rate so they sum up to 1000, to no avail. Also I tried to bifurcate the 1 hour long lecture on a test run, and the resultant file sizes were 348MB (wav file for audio) and 527MB (wav file for video). I run Windows 7, 64bit. What seems to be the problem?

    Thanks in advance.
  • edited March 2012
    When I check "Use MCI to record" in the audio panel, and thus use the system audio settings (basically, 16-bit recording at 44.1kHz), my sync is always perfect using the same video settings as you are using.

    I've found that when compressing the video into a different format that using MP3 (I believe this has always been the LAME encoder in use) has been catastrophic in most cases, whereas using AC3 for audio in MP4 conversions has always worked correctly. Also, when I upload the original content - though weighty, admittedly - to YouTube, they always encode it with the sync working well, and they use AC3 as well.

    So, I'm suggesting those two areas be looked at first - are you using MCI to record and if re-compressing, are you perhaps encountering problems with MP3 as I did?

    If anyone has had success using MP3, I'd like to know how you did it, though it is not that important currently as AC3 is a worldwide standard now.

    BTW - I have managed to get up to 3 hours using Jawor's Xvid at quality settings of 2-4
    (haven't tried quality-1 for those tests yet), but I do have to convert to MP4 using AnyVideoConverter for these to play on all media players. RealPlayer, QuickTime and VLC have shown that they have problems with the raw 10fps recordings made with Xvid.

    Terry
  • edited March 2012
    Thanks, Terry,

    But I'm recording from speakers, or this "Use MCI Recording" applies in both cases?

    In my case recording a short video gets success, like 5 minutes.

    TeaSipper
  • edited April 2012
    In the "record from microphone" control panel, "Use MCI to record" simply forces the 16-bit, 44.1 kHz system audio directly without any parsing through CamStudio's settings or control panel. I'm not certain at all about the "record from speakers" implementation.

    If you are getting only 5 minutes to stay in sync, there is something odd going on. I keep 3 hours in sync! But your SKFE, CFE and PBR settings all seem to be correct in theory. However, mine reverse two of your settings: Key Frames Every 100 frames, Capture Frames Every 100ms, Playback Rate 10 frames/second. By your capturing every 10ms with PBR of 100 it should have resulted in pretty large file sizes fairly quickly!

    Which compressor are you using? (...from Video Options - the drop down menu at the top)

    I must say I am surprised that "record from speakers" is working for you, as that employed a hardware hook that hasn't existed in most computers since XP, SP2! Most people use "record from microphone" and the "Stereo Mix" inputs instead.

    Terry
  • Terry,

    Did you mean codec? I use CS lossless codec v1.5 on the setting, but while running, CS says it's using the Microsoft one in the window... Not sure how it came about and which is really being applied when I'm recording. My compressor is LZO set at level 6; but, to be plain honest, I'm not familiar with this setting and what's best for my instances of recording.

    The same can be said for SKFE, CFE and PBR. I don't feel myself properly familiarized with these settings.

    Yeah, I can record short minutes fine with no noticeable problem, and the resultant file comes in AVI. The presentations I was recording ran about 1 hour each and in that case, recording would fail, creating 2 .wav files ( one that's video and another that's audio, both playable). So my present goal/plan is to merge them in one file to a format that's playable on a media player. I presume I'll be using conversion first, then a video editor, either VirtualDub or Avidemux or maybe Lightworks...just one of those freewares. Finally, though it may be unnecessary, I'll convert it back to whatever format seems suitable for my purpose...Well, I'm still in the process choosing a right video/movie editor.

    What did you mean by "hardware hook"? I thought recording from microphone would catch a lot of noise and that wasn't ideal, and recording from speakers would do the job. So I'm using that option... Or maybe I was misleading. I recorded presentations from the web, so the sound came from my computer...
  • edited April 2012
    I proceeded with the conversion of 5 .wav video files to .avi. It got partial success with 2 out of 5 properly converted to .avi files. The rest 3 ended up with tilted image, kind of collapsed to one side. For conversion, I used iWisoft free video converter (http://www.easy-video-converter.com/), and even in its preview window before conversion, the odd image is shown. (For those interested, iWisoft supports many audio and video formats and is equipped with basic editing features (check the link). I mainly use this freeware to convert to one or some of the supported video formats.)

    I can't figure out what's the difference between the successful and unsuccessful conversions in the files. The same CS settings, same display aspect ratio, same frame rate (20 fps). Only noticeable difference seems to be the recorded time length, thus file size. I again can't figure out myself how it relates to the success and failure. Does somebody happen to know?
  • edited April 2012
    If you are converting to a MP4-based output, the width and height have to be even-numbered dimensions, or you will get that skewing effect. I have used the filters in VirtualDub to crop a wayward video to even dimensions, and then it straightened right out.

    Do try using Xvid (with even dimensions) rather than the CamStudio codec. It still will need processing into an MP4 file later to work with all players, but it allows much, much longer recordings without going over the size limit. I particularly like Jawor's 720HD profile in his rendition of Xvid:

    http://jawormat.republika.pl/xvid.html (get at least one that has a 32-bit version, as CamStudio is 32-bit itself.)

    I'll make a video on how to use it Saturday and post it here. But also watch my long webinar where I cover most things you'd need to know.

    Terry

    http://camstudio.org/forum/discussion/684/-terrys-first-free-live-camstudio-webinar-watch-the-2hr-replay-here-sign-up-for-future-webinars
  • edited April 2012
    "Record from Microphone" just means "Use System Mixer", so if you select "Stereo Mix" as the source in there, you get your speaker's sound, not the mic.

    * Watch the following at YouTube (click the YouTube logo), as they've changed their embedding system and these aren't playing for me today. Full-screen at 720p is best.

    Windows XP




    Windows Vista and 7

  • Hi Terry, just wanted to thank you for taking the time to put these together. Great job!
  • WebWeaver64,

    You're very welcome!

    Terry
Sign In or Register to comment.