Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

How to record from speakers to include media player or game audio AND the microphone in Windows 7

[This is now viewable as a video at my blog -
http://screencasttutorial.org/27/record-microphone-and-speakers-via-stereo-mix-into-camstudio-in-windows-7-with-gain-staging-395
or at YouTube -
http://www.youtube.com/watch?v=Cm8zNeHtXeo ]

This question is perhaps one of the most often asked in the past on the XP systems. Here is how to do it in Windows 7. I have a RealTek HD Audio sound card, but the settings should be similar across any Windows 7 audio system, as they all share the new Windows 7 audio sub-systems.

First, open the Sound control panel. There are 3 ways to do this: Start menu Control Panel Flyout, Control Panels Window, or Right-Click on the Speaker icon.

If you do NOT see "Stereo Mix" in your Recording tab, right-click on an empty area and make certain that both "Show Disabled Devices" and "Show Disconnected Devices" are checked. If this brings up the Stereo Mix input, be sure to Enable it by right-clicking on it and selecting "Enable".

Now, ensure that "Stereo Mix" is selected as the default device in the Recording tab. Open it and set the Levels to 100.

Also in the recording tab, make sure your microphone input's "Listen" tab has "Listen to this device" checked and is directed to the Speakers - not anything else, or it won't work correctly. Set the levels between 10 and 100. My Line-in is very noisy with a whine from the motherboard, so that is why I have it set to 10 here, and since my mic is plugged in through a mixer going to Line In, I crank up the volume at the mixer to compensate and get better signal-to-noise levels.

Now with that done, very importantly, select the Playback tab, and make certain that Speakers are selected as the default device. If you have Headphones selected, even with no headphones plugged in so it falls-back to the speakers, the media player or game audio will not get routed to the Stereo Mix. Set the level to 100 on the main output slider, but then scroll down to the bottom on a RealTek HD Audio system, and turn the "Front" sliders down to between 40-50 to avoid overloads. The Stereo Mix receives its actual signal from this slider.

While I'm in this panel, I should mention headphone monitoring. In the RealTek HD Audio Manager, which is available from the Control Panels, you have the possibility of routing the mic or line-in to the front panel headphones via the "Device Advanced Settings" link in the upper right side. Check the first one to pass through your mic. Note that the "Line In" and "Microphone" sliders in the Speaker's properties levels tab only control this pass-through volume and have no effect upon the recording levels.

While I'm in the RealTek HD Audio Manager, make certain you have your effects disabled (unless you want them) in the Speakers tab, and double check that there is no "Red X" over the mouth of the little guy in the Karaoke setting, or it will "scoop out" the mid-range audio and sound terrible. Also go through and ensure all your Default Formats are set to 16-bit 44.1 kHz Stereo, since that is what CamStudio uses.

You SHOULD do a check to monitor your levels over your headphones. This can be done by double clicking Stereo Mix to bring up its properties and check the box in it's Listen tab, sending the output to your Headphones. There will be a 1/10th second or so delay to the microphone that is very distracting, so only use this to check your mix, then turn it off and rely on the RealTek advanced settings pass-through to monitor your mic. You'll have to "fly by instruments" once recording into CamStudio, so rehearse your volume settings in advance to get them right, or enable and disable listening to the stereo mix at intervals when necessary.

You can use the Windows 7 Volume Mixer to adjust the media player volume. It gives numbers as you move the slider so you know where you are.

Remember that in order to hear your playback of your recording after you're done over your headphones, you'll have to set "Headphones" as the default. Remember to set it back to Speakers as the default to record additional takes.

Again, a synopsis of the gain-staging is:
Microphone - Level 10-75, in Listen tab, "listen to this device" checked ==> out to speakers
Speakers - main slider 100, "Front" slider 40-50, set to default Playback device
Stereo Mix - 100, set to default Recording device
Music source adjusted to be underneath the mic volume. This can be adjusted using the audio mixer sliders (right-click speaker and select mixer)

Finally, in CamStudio, be sure to have "Record from Microphone" selected and then under "Audio Options for Microphone" select "Stereo Mix" from the drop-down. That's it!

I hope this helps you immensely. Please comment on what I might have left out here.

Comments

  • Hi,

    I found the 'record from microphone' technique not to work for my computer.
    I have an old Dell that has its sound card integrated into the mother board and has been upgraded from Win XP to Win 7. Here's how I finally got it to work with both Camstudio 2.0 and Camstudio 2.6 beta:
    Under the 'Options' dropdown menu, I clicked 'Record audio from speakers'. Under 'Audio options', I clicked 'Audio options for speakers'. Under the 'Soundcard Device', I clicked the only option, 'SoundMAX Integrated Digital Audio'. Under 'Recording Line Configuration', you may have to utilize one of the 'Search' configurations, but mine was already set and worked OK.
    The only difference between Version 2.0 and 2.6 was 2.6 automatically set the volume.
    Hope this helps anyone who is having troubles with their Camstudio sound.

    -neilvmcc
  • Hi!
    How do I record only from speakers?
    Thanks
  • Madcow,

    XP, Vista or Win7?

    Terry
  • I realized the true problem.
    It records from the microphone when speakers are changed, and soundcard is set at audio options. I have windows 7 ultimate 64 bit. I also gut an error message when setting to record from speakers: "WaweoutGetSelectControl()".
    Thanks for help in advance
  • madcow,

    Yes, since Vista, most computers won't work with the "Record from Speakers" options. You have to use "Record from Microphone" and set up Stereo Mix.

    Terry
  • Thanks
    Is there a list of steps about recording from speakers?
  • edited November 2014
    (BTW - this technique also works with other recorder software, not only CamStudio, like Mirillis Action and others similar.)
  • I only want to use CamStudio to record from speakers. I went to control panel/sound/recroding and set the stereo mix to default. When I went to CamStudio it showed Options/record audio from microphone. If I check record audio from speakers, CamStudio works fine. The problem is I want it to stay at speakers but if I close CamStudio and then re-open it, it shows record from microphone. How do I get it to stay at record from speakers?
  • wa0goz - please learn to use Voicemeeter as a mixer instead. It blows away using Stereo Mix, and allows much better control over your monitoring. Either the original version or Voicemeeter Pro "Banana" will serve you far better.
    http://vb-audio.pagesperso-orange.fr/Voicemeeter/index.htm

    If you set up Voicemeeter as both the default playback device and recording device (as you should when using this program), then CamStudio's problematic fall-back to "default" will stop being a problem.

    That gets around all the issues one can have with Stereo Mix. However, if you want to stay with Stereo Mix, have you tried setting that as the default recording device in the Windows Audio control panel? That also should get around the problem. Sorry that part of CamStudio is broken!
Sign In or Register to comment.