Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

BUG? enable audio results in no video

any time i enable audio, regardless of audio settings, i lose video, regardless of video settings
i've tried different audio and video settings/codecs

win 7 x64 sp1

Comments

  • kamr,

    I've heard of this once before, and do not have an answer for you. Could you be more specific on the computer model, video card and sound card and drivers, perhaps?

    This makes little sense, since the two drivers should be entirely distinct from each other. But clearly it is happening to some people, yourself included, so if you can, help us get to the bottom of this one.

    You are using 2.6b, right? Does this happen with v2.0?

    Terry
  • kamr,

    Reference for the other instance this has been reported:
    http://camstudio.org/forum/discussion/comment/3476

    Terry
  • hi tbritton

    computer is a Clevo/Sager W870CU notebook, Intel Core i7
    video is Nvidia GTX 460M, driver version 8.17.12.7533
    sound is Realtek HD driver version 6.0.1.6235 (also has the Nvidia HDMI drivers installed)

    i'm using the 2.6 beta, yes. i have not tried 2.0

    i tested using MCI on/off with all the available video codecs (Intel, MS, Cinepak)

    i also have the Xvid 1.3.2 32-bit codec installed and the results with it are also the same - if i enable audio, no video is recorded

    so it seems audio related

    can't post the ini settings because of length apparently
  • kamr,

    I'll notify the programmers to take a look at this. Thanks for the update!

    Meanwhile, try 2.0 and see if it also has this problem. Definitely don't bother trying the "Record from Speakers" option - just use "Record from Microphone".

    Terry
  • @kamr

    Are you getting this problem with different video/audio codec combinations or is it just specific ones?

    Are you using the 64-bit versions of the chosen codec?

    Can you tell us exactly what video/audio codecs you are using that generate this error and also the settings you're using for each?

    Thanks

    Nick :o)

  • edited September 2011
    hi nick

    the problem is the same regardless of the audio and video codec used

    both audio and video codecs are the win 7 defaults, except for the xvid codec which is the 32 bit version - the custom one... Jav.. something?. i assume the default codecs are also 32 bit.

    the program options don't seem to matter. right now i'm using the following...

    auto-pan (tried with this off)
    record mic
    minimize on start
    save settings on exit
    save video to user specified directory
    thread priority = normal
    key/cap/playback = 100/50/20 (tried other settings)
    vid codec = xvid (all were tried)
    frame size = fixed, 1200x600 (i tried different sizes)
    audio = PCM (tried Microsoft ADPCM)
    audio = MCI (tried with this disabled)
    audio interleave = 100 ms

    all of the above work fine if i disable audio

    the only vid codecs i have installed are the default (Intel, MS, Cinepak) and then the xvid - all result in no video if i enable audio

    i did not try the CS 2.0 version yet
  • edited September 2011
    found the problem

    first of all, i tried 2.0 and it "sort of" worked - i left the the video player set to default and it worked (recorded audio/video). at some point i changed the player to my default, MPC HC, and set a custom temp dir, auto-naming and auto-playback, after which it probably worked, but the video file (avi) was deleted as soon as i stopped recording if MPC was set as the player, or as soon as it was done playing if using the CS player.

    also i'll mention again that CS ignores the environment variables - if the temp directory is set to the default, it should be reading the %TEMP% variable which is not necessarily c:\windows\temp

    uninstall 2.0 and re-install 2.6...

    this time the video doesn't get deleted, but only the sound plays back in MPC. it will play back with the CS player and VLC, just not MPC, regardless of codec used to record.

    i don't know enough about video to know if CS is mangling the video or if it's something else. i know that MPC plays virtually anything i throw at it, including other xvid recorded video

    another apparent difference i noticed - and it may just the settings i used - is that the auto-pan seemed to be much smoother with the 2.o version. with 2.6 it seems really jumpy regardless of settings

    UPDATE

    latest version of MPC HC is working fine (1.5.2.3456)

    so other than the auto-pan being really notchy and a couple small bugs (help file doesn't open from menu; env variables), 2.6 seems to be working ok
  • edited September 2011
    kamr,

    So, you are saying it was the player, then. I've had similar glitches with some videos played via Winamp - even upside-down videos (not ones made by CamStudio, in this case).

    VLC contributes its own problems, unless they've finally fixed a problem that has persisted for months (which they admitted was their problem.)

    Terry
  • i can't say with any certainty that the player (MPC HC) was the problem, only that updating to the new version allowed the video to play

    i think if MPC had a bug that serious that it wasn't able to render a proper video, it would've been known long ago as it is a very widely used player. so my feeling? i think CS may not be writing a proper video file and that VLC, and now the newer MPC, just happen to be able to play it anyway
Sign In or Register to comment.