Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Error in creating AVI

This is an intermittent fault, however it happens about 80% of the time.

I am running Windows 7 32bit SP 2 and have just installed CamStudio 2.6 build 294. When it works I run the app and it captures both the video and sound perfectly. However when it fails it returns the error:-

"unable to rename/copy audio file"

What I find then is that the .AVI file is broken and the ~temp-????.wav file is still in the temporary directory.

I have tried all the different settings for "directory for recordings" option. In the custom setting I have tried various local folders both off the root of C: and other local and network locations. The issue is not one of permissions as I am administrator of the workstation I am working on and also domain admin. I have also tried running the app as admin.

I have tried having names automatically allocated and also prompting for name and using names of no more than 8 characters.

I have tried un-installing and reinstalling too.

Nothing gives me reliable success and there seems no pattern whatsoever. I'm tearing my hair out can anyone help?

Charlie

Comments

  • Are you going over the 2-gigabyte AVI file size limitation? That breaks it every time. There are threads here on how to recover the video from the temp files using VirtualDub (use search), but you can probably avoid the size overage issue by using Jawor's Xvid. http://jawormat.republika.pl/xvid.html

    What codec did you use? And how long were your videos?

    (For instance, using Lagarith Lossless, with 16-bit color video settings you can get 11 minutes, but with typical 32-bit color you get only 9.5 minutes with 16-bit audio (recommended for sync, btw...)

    Terry
  • Thanks Terry. Yes the files are over 2GB so that may be the issue. I'm a complete newbie regarding video stuff sorry: I'm not sure how to check which codec I'm using. I'm guessing it's the Compressor at Options/Video Options? If so the only options I have are "Microsoft Video 1", "Intel IYUV", "Logitech Video (l420)" and "Cinepak Codec by Radius". The setting I used there was "Microsoft Video 1".

    The videos are about 7 minutes long.

    Also I'm at sea as to how I use the Xvid, I'm probably being stupid but from the page you linked to and the FAQs there I can't work out what it actually does? Would you mind giving me some pointers?

    Charlie
Sign In or Register to comment.