Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

Audio not Video Plays is Camstudio but not Microsoft Media Player

edited February 2009 in Support
Hello,

About six months ago I recorded numerous videos with Camstudio. I had it output to AVI. Then I would import it into Microsoft Movie Maker to convert it into a wmv to reduce the file size and have some control over displaying them in a html page.

When I tried it again just yesterday I noticed the avi files don't play the video through microsofts media player. I am not sure what changed.

I tried using the option to convert to swf but you dont have any control over any of the viewer setting like loop or auto start.

Any suggestions on getting the video working again or how to add parameters like sliders to teh flash viewer?

Thanks.

After further testing I have found that Microsoft Movie Maker or Media Player will not play the video of any avi file create by Camstudio. It will play other avi files fine.

Comments

  • Update. I tried to have someone else play the file as welland they are not able to play it either.
  • Hi, bigbavarian:
    Maybe it has something to do with the codec you're using. Try with a different one by going to "Options > Video Options". Maybe XviD/DivX, which you'll probably have already installed.
    Best regards,

    Gabriel.
  • Hello, I see this is a bit old thread but don't see any answer to problem.

    Has anyone found out how to fix this problem yet?

    I just recorded a video with voice and in windows media player only audio plays same in vlc but in quicktime the video plays but not the sound.
    I used microsaft video 1 as compressor.

    I read in a older thread from 2008 something about virtualdub can save my video with some sort of direct stream copy but no one said anymore instruction than that so I don't know what to do.
    Been testing lots of things now for 3 hours and getting really tired.
  • I registered on this forum to ask the same thing BUT fixed it on my own! But since you have the same problem, I will be be more then happy to tell you how to fix it.

    First of all, as it turned out, it is not a video codec issue. It's an audio codec issue! By default it uses MP3 codec and for some reason this causes playback problems with my external programs. (even my video converters would have trouble with it) So I changed it and that corrected it. It also made converting it much more pain free.

    To change the audio codec, go to the Options menu, then go to "Audio Options". Then go to the Microphone audio options.

    From there flick the "Choose Compressed Format" button. From ther, use the dropdown menu to find "PCM". PCM was the format that fixed it for me. Howver since PCM is a lossless format, this will result in large AVI files. If this becomes a problem for you, you can try out other formats. But as long as the format isn't MP3 as it was before, then you should be fine.
Sign In or Register to comment.