Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

xvid-mpeg4 codec not working

Only 4 days ago I used Camstudio for the first time to record a tutorial, it worked just fine, however the only format I can actually use in my video editor is the xvid-mpeg4 codec, it worked just fine. I updated my graphics card drivers yesterday and now every time I try recording with the xvid-mpeg4 codec, the program freezes, how can I fix this?

Comments

  • edited May 2012
    Dinokaizer,

    First, I'd make sure it was actually the graphic card driver update that caused this. Go into your device manager and double-click the video card, then click the drivers tab and click on the "Roll Back Driver" button. That will at least eliminate that possibility. If it still does not work, then re-install the driver update (likely only need to click the "update driver" button as the files are already downloaded).

    By the way, do other codecs work? (I have seen a similar incompatibility arise a FEW times with the DivX codec...)

    My second approach would be to re-install CamStudio and Xvid AND the appropriate Microsoft C++ runtime libraries for your system and CamStudio version. 2.6b uses the 2008 runtime libraries, while the newer 2.6c (a 7-zip self contained folder with the program found in the "Next" folder at Sourceforge) uses the 2010 version.

    Here's a paste from the recent 2012 tech video I've got at YouTube with the download links should you need them:

    Jawor's Xvid - http://jawormat.republika.pl/xvid.html

    Any-Video-Converter - http://www.any-video-converter.com/products/for_video_free/

    ZoomIt - http://technet.microsoft.com/en-us/sysinternals/bb897434.aspx

    Sizer - http://www.brianapps.net/sizer/

    Microsoft C++ 2008 Runtime Libraries 32-bit (for 2.6b) - https://www.microsoft.com/en-us/download/details.aspx?id=5582

    Microsoft C++ 2008 Runtime Libraries 64-bit (for 2.6b) - https://www.microsoft.com/en-us/download/details.aspx?id=2092

    Microsoft C++ 2010 Runtime Libraries 32-bit (for 2.6c) - https://www.microsoft.com/en-us/download/details.aspx?id=8328

    Microsoft C++ 2010 Runtime Libraries 64-bit (for 2.6c) - https://www.microsoft.com/en-us/download/details.aspx?id=13523

    7-Zip (for 2.6c) - http://www.7-zip.org/download.html

    CamStudio 2.0 Legacy Folder - http://sourceforge.net/projects/camstudio/files/legacy/

    CamStudio 2.6b r294 "Stable" Folder - http://sourceforge.net/projects/camstudio/files/stable/

    CamStudio 2.6c "Next" Folder - http://sourceforge.net/projects/camstudio/files/next/

    Part of the "How to Use CamStudio" Playlist: https://www.youtube.com/playlist?list=PLA57A11C0D77BBF9B&feature=plcp

    Good luck with this and let me know how it goes!

    Terry
  • Unfortunately none of the things suggested work, even when rolling back the driver it didn't change, I really don't know what the issue is, the xvid-mpeg4 codec just... stopped working. This really sucks because Microsoft 1 looks terrible (the color banding is ugly), nothing works with the lossless codec (I can't even convert it), the rest of the formats don't work with my Mac (which is what I use for editing with final cut pro), the only one that worked was xvid-mpeg 4, do you know how I could perhaps convert the lossless codec to another codec (the converter you linked to does not work with the lossless codec).
  • Dinokaizer,

    Try using ffdshow or ffdshow tryouts along with the new version (get the C++ runtimes for 2010 to use it, if you don't already have that installed).

    CamStudio 2.6c "Next" Folder - http://sourceforge.net/projects/camstudio/files/next/

    Terry
  • edited June 2012
    1. Open Cam Studio, go to "options"->"video options", select the Xvid codec, then click "configure", then click "other options" at the bottom, and make sure the "Display encoding status" is UNCHECKED.

    2. The screen area you are recording must have a width multiple of 4 and a height multiple of 2, or Xvid cannot encode the video.
    Example:
    1024x768 1024/4 = 256, 768/2=384, so this is an acceptable resolution
    586x586 586/4= 146.5, 586/2=293, so this is NOT an acceptable resolution
    700 x 325 700/4=175, 325/2=162.5, so this is NOT an acceptable resolution
  • edited June 2012
    ForbiddenSoul,

    Actually, Xvid only requires division by 2 for both width and height. DivX does require division by 4 for the width as you describe.

    That is, unless Xvid has changed something on me - could you double check that for us?

    Terry
  • Cam needs only multiples of 2 to create with Xvid, so that’s not the problem. I might add that 640, 720, 848, and 1024 can be divided by 16, and are common video sizes and will always work with AVIs when those files are run through video editors, so it’s not a bad idea to stick with those.

    But that wasn’t the cause of the OP’s problem. The fact that new hardware and associated software were added just before the issue arose is too much of a coincidence. The suggestion to roll back the driver is good, but it’s probably too late for that. My guess is that the new installation did damage to the codec registration, and I would have serious suspicions about possible “enhancements” which came with any software that accompanied the card, including some sort of Divx installation. The result is that Cam, the processor and Xvid are no longer running on the same loop, so to speak. Sounds like something’s hitting an empty key and getting thrown into a circular spin. One quick test would be to set Cam up with the proper MPEG 4 settings and run, using what we know is a faulty odd dimension capture area. If the program has any communication with the codec at all, we would see the “...use default compressor?” splash, but if the recording process starts and then Cam freezes, we can assume that no codec info is available to Cam from this particular codec.

    If that’s the case, the first option is to rollback as suggested and hit an old Windows restore point, which will restore the old registry configuration. I wouldn’t do that for one damaged codec, however. What I’d do instead is to rollback the driver, and try to locate any other software that may have been installed and remove that. I’d then remove all of the MPEG4/Xvid program files and of course any Divx files. At this point, (if it were my computer) I’d uninstall any K-Lite package that might be on the computer. I’ve come full circle on that one, now thinking that it’s just a bunch of outdated and unnecessary junk. Contrary to what a lot of people have said, the K-Lite uninstaller works very well.

    I’d then install Jawor’s and give it a try. If working, I’d re-install the new driver (only) and check again. If it’s broken again, there’s no doubt about what’s causing the problem.

    Ken
Sign In or Register to comment.