Due to continual spamming, forum registrations are now by Invitation Only. Hopefully this will be only a temporary measure to combat spammers.

If you want an invitation contact forumapplication @ camstudio . org

Sorry for the inconvenience.

FFV1 Codec

edited August 2011 in Support
I’ve been experimenting with various codecs, mostly for the purpose of capturing high motion videos with civilized file sizes. Overall, I’d have to say that the overall best result I’ve gotten is with the FFV1 codec, but there is one odd problem. While the file size is suitable, assuming the capture can be done in segments and edited later (very easy process), and the overall motion capture is far superior to Mpeg-4 Xvid (Jawor’s tweak) the glitch is that, periodically the process results in dropped frames, which causes a distracting jump.

When I first noticed this, my thought was that it was due to a lack of processing resource during the initial capture, but then I tried 30 second capture tests with the starting point staggered in increments and found that the jumps occurred on the same frames each time. To me, this indicates that the FFV1 capture just can’t “see” certain frames (although the real-time display is perfect) and I’ve been trying to figure out why.

Comments

  • - continued

    I took the pieces into an editing program and looked frame by frame and noticed that the jumps do indeed seem to correspond to dropped frames. This is NOT the result of frames removed as a result of unpacking a packed bitstream video, so I’m thinking the problem may be with the way CamStudio is using FFV1 to process the capture. Since Lagarith and the Huffy variations produce ridiculously large files and test my computer’s resource, I was hoping this might be an alternative, but I can’t get past this problem.

    So far, my tests have been with rates set at everything between 10/100 and 100/10 with key frames set at 8 and 12, with no real difference in the end result. Has anyone else had more success using this codec than I’m having?

    Ken
  • bmoreken,

    I'm not familiar with FFV1. I'll admit to being taken in by the raves at the doom9.org forums over Xvid lately, and had pretty much stopped my searching. You do have Xvid's quality set at 1, I take it. The doom9.org forums may have some info on how to tweak both Xvid and FFV1.

    http://www.doom9.net/
    http://forum.doom9.org/

    Have you tried matching the key frames setting to the playback rate, or to some multiple or even division of that? Just a thought, since my understanding of the key frame setting is that it describes the interval where it grabs complete frames rather than only recording the differences. Perhaps you are experiencing a kind of "beat frequency" effect with them not being nodal somehow. (Pure speculation there...)

    Terry
  • Terry - You might have something with the keyframe spacing. I’ll try variations in my next round of tests. Since I posted, I’ve discovered that a setting of 5/200-10 is producing the best result. In fact, except for the periodic jumps, it’s better than I would have hoped for. Upon further analysis, the jumps seem to occur where there is sudden and substantial movement, which as I said, do not show up in the original stream, but are apparent in the CS capture. I’ll keep working on it and report if I find anything.

    Ken
  • bmoreken,

    In your setting of 5/200-10, what does the 10 represent? is that the keyframe setting you are using?

    Terry
  • Yes, the 10 is the I-frame increments. I actually tested using that formula before I read your previous reply, and I haven’t yet had a chance to try other possible combinations, so maybe I’ll exhaust those before reaching any conclusions.

    Ken
Sign In or Register to comment.